jockey-text crashed with OSError in _execute_child()

Bug #403925 reported by Nghiem Ba Hieu on 2009-07-24
72
This bug affects 16 people
Affects Status Importance Assigned to Milestone
jockey (Ubuntu)
Undecided
Unassigned

Bug Description

:)

ProblemType: Crash
Architecture: amd64
Date: Fri Jul 24 15:06:41 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/jockey-text
InterpreterPath: /usr/bin/python2.6
MachineType: Hewlett-Packard Compaq Presario CQ40 Notebook PC
Package: jockey-common 0.5.3-0ubuntu2
PackageArchitecture: all
ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.31-3-generic root=/dev/sda9 ro splash nmi_watchdog=0
ProcCmdline: /usr/bin/python /usr/bin/jockey-text -e kmod:wl
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-3.19-generic
PythonArgs: ['/usr/bin/jockey-text', '-e', 'kmod:wl']
SourcePackage: jockey
Title: jockey-text crashed with OSError in _execute_child()
Uname: Linux 2.6.31-3-generic x86_64
UserGroups:

dmi.bios.date: 07/28/2008
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.21
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 30FE
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 01.53
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.21:bd07/28/2008:svnHewlett-Packard:pnCompaqPresarioCQ40NotebookPC:pvr1:rvnHewlett-Packard:rn30FE:rvr01.53:cvnHewlett-Packard:ct10:cvrN/A:
dmi.product.name: Compaq Presario CQ40 Notebook PC
dmi.product.version: 1
dmi.sys.vendor: Hewlett-Packard

Related branches

Nghiem Ba Hieu (hieunghiem) wrote :
tags: removed: need-duplicate-check
Andreas Olsson (andol) on 2009-07-25
visibility: private → public
Sander Jonkers (jonkers) wrote :

The same crash occured on my Karmic Alpha 3 32-bit on a Dell Studio:

On a ubuntu live boot, I was offered to install the proprietary wifi drivers, which I accepted. I was then asked the root password, where I just pressed <enter> (live CD, so I don't know any root password). Then the crash occurred.

oli z (oliver-z) wrote :

Same here on Live CD with a Dell Vostro 1000 (trying to install the STA driver)
It also happens if the password is set (for user and root)

oli z (oliver-z) wrote :

I just installed the driver above (Broadcom B43 Wireless Driver) and then installed the STA wireless driver.
Its now working. Strange behaviour.

Mario Limonciello (superm1) wrote :

This is actually fixed in jockey bzr already. See rev # 364

Changed in jockey (Ubuntu):
status: New → Fix Committed
ichhaankur (n-arju-lx) wrote :

9.10

Was trying to change driver from the BROADCOM B43 DRIVER (FREE) to BROADCOM STA WIRELESS DRIVER (PROPRIETORY) and something crashed.

My Wireless's not working.

Seanzer (lee-2817) wrote :

karmic koala (9.10 alpha 3)

My wireless (bcm4328) is not working. I was using the STA driver perfectly fine in Jaunty. Jockey only gives me the option to chose the STA driver and everytime I try to activate it, I get this error. I don't know where else to dissect the problem. I've tried rmmoding ssb and playing with b43.

No wireless...

Nghiem Ba Hieu (hieunghiem) wrote :

There was a trick to let STA driver works in Karmic Koala (9.10 Alpha).
Following these steps:
1) Goto System -> Administration -> Hardware Drivers
choose firmware for wireless from b43 (fwcutter version), let it download and do installing. Wait and just finished it.
2) Open shell, type:
    sudo rmmod b43
    sudo rmmod ssb
3) Edit /etc/modprobe.d/blacklist.conf, add these lines:
# disable b43
blacklist b43
blacklist ssb
4) Goto System -> Administration -> Hardware Drivers again
now installing STA Wireless driver, it should be worked.

Ps: Step 3 is just for sure, normally, jockey does automatically blacklisting b43.

Cheers

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.5.3-0ubuntu3

---------------
jockey (0.5.3-0ubuntu3) karmic; urgency=low

  [ Martin Pitt ]
  * broadcom_wl.py: Run rmmod with full path, since the backend doesn't have a
    $PATH when being activated by D-Bus. (LP: #403925)

 -- Mario Limonciello <email address hidden> Fri, 07 Aug 2009 16:02:26 -0500

Changed in jockey (Ubuntu):
status: Fix Committed → Fix Released
Jean.c.h (slug71) wrote :

Just got this bug running Lucid 32bit Alpha 2 all updates applied.

Slug:
Please file a new bug report. This bug was particular to karmic, and
although a lucid one may look similar, it likely has a different root
cause.

On 02/09/2010, Slug71 <email address hidden> wrote:
> Just got this bug running Lucid 32bit Alpha 2 all updates applied.
>
> --
> jockey-text crashed with OSError in _execute_child()
> https://bugs.launchpad.net/bugs/403925
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Sent from my mobile device

Mario Limonciello
<email address hidden>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers