(easy,+1 patch) Jockey should set the bugAddress() field of the KAboutData object

Bug #398920 reported by Dario Andres on 2009-07-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
jockey (Ubuntu)
Undecided
Unassigned

Bug Description

To properly use the crash reporting assistant of KDE4.3, Jockey needs to call KAboutData::setBugAddress("https://launchpad.net/ubuntu/+source/jockey/+filebug"); so if the application crashes the user is redirect to that site. Otherwise, the crash reporting tool will file a new report at bugs.kde.org where it does not belong; like https://bugs.kde.org/show_bug.cgi?id=200061
Thanks in advance

--
Dario Andres
KDE BugSquad Team, DrKonqi2

Dario Andres (andresbajotierra) wrote :

Mh, it seems that this app is a pure PythonQt one, with no KDE integration. In that case you can't set the bugAddress field, as there is no KAboutData object. However in that case, DrKonqi should not be started for this kind of app.... mh...

Jonathan Thomas (echidnaman) wrote :

It is a PyKDE application with full KAboutData. (Except for the bug address) Maybe you're looking at an old version? :)

Anyway, I set the bug address field, but dr. konqi is still showing up. I guess it's not working? :(

Dario Andres (andresbajotierra) wrote :

DrKonqi will always appear, but it will not allow the automatic reporting process to the KDE bugzilla site. (it will stop on the "Conclusions" step, after fetching the backtrace). - Could you check if it is that way ?
(another way to test this would be using the Process List, checking the command that invoked DrKonqi and checking the email address)
Regards

Jonathan Thomas (echidnaman) wrote :

I got all the way to the preview at the end and pressed send. It said it was sending the report so I quickly closed Dr. Konqi.

Jonathan Thomas (echidnaman) wrote :

Ah, in jockey-kde all the various KAboutData fields are set as variables before the KAboutData constructor. Turns out that the bugEmail variable wasn't part of the KAboutData constructor. Just a silly error on my part. :D

Changed in jockey (Ubuntu):
status: New → Fix Committed
Dario Andres (andresbajotierra) wrote :

Thanks for fixing it :)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.5.7-0ubuntu1

---------------
jockey (0.5.7-0ubuntu1) lucid; urgency=low

  * New upstream release:
    - gtk/autostart/jockey-gtk.desktop.in: Fix regression from r596, add back
      "--check" mode. This fixes jockey always popping up after session start.
    - kde: Set the bugEmail variable and add it to the KAboutData constructor
      (LP: #398920)
    - kde: Bump notification pixmap size down to 22x22, for consistency with
      other KDE apps
    - kde: Optimize KIcon usage in general
 -- Martin Pitt <email address hidden> Thu, 11 Feb 2010 15:40:43 +0100

Changed in jockey (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers