jockey doesn't display progress or allow cancel

Bug #365883 reported by James Strother on 2009-04-24
This bug report is a duplicate of:  Bug #311650: Hardware Drivers usability issues.. Edit Remove
2
Affects Status Importance Assigned to Milestone
jockey (Ubuntu)
Undecided
Unassigned

Bug Description

I'm running 64-bit Jaunty, fully-patched. I just tried to install the nvidia driver (v. 180) after a fresh install, and the "downloading and installing" box hangs indefinitely at 0% progress. Clicking the cancel button does nothing. So I ran killall jockey-backend, then restarted jockey-backend with the debug flag, and restarted jockey-gtk. I'll attach the output of both. The jockey-backend process hangs after printing the "Installing package: nvidia-glx-180" after which I interrupted the process. The jockey-gtk process outputs nothing until jockey-backend is interrupted, after which it prints the attached.

James Strother (jstrother9109) wrote :
James Strother (jstrother9109) wrote :
summary: - jockey hangs indefinitely
+ jockey doesn't display progress or allow cancel
James Strother (jstrother9109) wrote :

I took another look at this and it appears that jockey wasn't really hanging, the ubuntu repositories were throttled and the downloads were progressing at a glacial pace (as observed by checking the file sizes in /var/cache/apt/archives/partial). While that is much better than simply hanging, the current behavior is still something less than ideal. As is, it appears that the progress bar is only updated with file-level granularity. For something like the nvidia drivers where most of the download is in a single file, this is not so useful. Anyone without a broadband connection is going to see the progress bar sit at 0% for around 15 minutes. I suspect most people will assume it is stalled. If jockey-gtk is using python-apt then it should be possible to display the progress within each file download. Also, as I mentioned in the original post, during the download clicking cancel does nothing. I'm not sure if the download would be cancelled after the first file was downloaded, but clicking cancel should really cause immediate termination of the installation.

I've updated the bug description to reflect the new information.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers