Offer nvidia driver version 96 again

Bug #293107 reported by Fabián Rodríguez on 2008-11-03
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
jockey (Ubuntu)
Undecided
Martin Pitt
Intrepid
High
Martin Pitt
Jaunty
Undecided
Martin Pitt

Bug Description

When going to System > Administration > Hardware Drivers, Jockey reports "No proprietary drivers are in use on this machine". As a result, nvidia-settings can't be used, thus preventing dual monitor setup. Desktop effects most probably not working either.

More details to come.

Barry Warsaw (barry) wrote :

This is affecting my machine. Details:

]% lspci | grep -i vidia
01:00.0 VGA compatible controller: nVidia Corporation NV18GL [Quadro NVS 280 SD] (rev a2)
% uname -a
Linux mission 2.6.27-7-generic #1 SMP Thu Oct 30 04:18:38 UTC 2008 i686 GNU/Linux

Barry Warsaw (barry) wrote :

Here's the root problem:

After resetting X (thanks Fabian!) I now have a single monitor working at 1900x1200. Dual monitor does not work and nvidia-settings complains with the following message:

You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.

Running nvidia-xconfig does nothing noticeable. It definitely does not allow nvidia-settings to be run.

Alberto Milone (albertomilone) wrote :

can you attach the output of this command?
lspci -n | grep 300

Barry Warsaw (barry) wrote :

% lspci -n | grep 300
01:00.0 0300: 10de:018a (rev a2)

Alberto Milone (albertomilone) wrote :

Barry, your card seems to be supported only by nvidia-glx-71 and nvidia-glx-96. I have provided updated drivers in intrepid-proposed which are still blacklisted in Jockey, therefore you'll have to install them manually.

See this bug report:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-96/+bug/251107

Barry Warsaw (barry) wrote :

I grabbed -96 from proposed and installed it through synaptic, but nvidia-settings still isn't happy.

Is there something else I need to do? Should I try -71? Or should I just wait until they show up in not-proposed and Jockey is unblacklisted?

Alberto Milone (albertomilone) wrote :

what's the output of this command?
ls -lR /var/lib/dkms/nvidia

Barry Warsaw (barry) wrote :

Alberto, sorry I actually just got it working! Now twinview is enabled and I have my dual screens back. Thanks for your help.

(Aside: how to stop the deskbar from extending into the second screen? I'd like it if it just showed up on the left screen)

Martin Pitt (pitti) wrote :

Actually, it is a duplicate, but let's use this bug for tracking the removal of the -71 and -96 blacklisting in jockey. This will happen once bug 251107 is confirmed working.

Changed in jockey:
assignee: nobody → pitti
status: New → In Progress
description: updated
Martin Pitt (pitti) wrote :

Bug 251107 seems to confirm that the version 96 in intrepid-proposed now works, but 71 doesn't yet. So I unblacklisted version 96 in the ubuntu bzr branch.

I'll merge this to the intrepid branch and upload to -proposed.

Changed in jockey:
status: In Progress → Fix Committed
assignee: nobody → pitti
importance: Undecided → High
milestone: none → intrepid-updates
status: New → In Progress
milestone: intrepid-updates → none
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

Accepted into intrepid-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Elfy (elfy) wrote :

This is working fine for me, reports that the 96 driver is enabled.

Endolith (endolith) wrote :

I installed the proposed update and restarted, but I'm still getting the "No proprietary drivers are in use on this system" with an nVIDIA GeForce FX Go5200 64 MB. Should I file a separate bug?

https://answers.launchpad.net/ubuntu/+question/49574

Endolith [2008-11-05 0:37 -0000]:
> I installed the proposed update and restarted, but I'm still getting the
> "No proprietary drivers are in use on this system" with an nVIDIA
> GeForce FX Go5200 64 MB. Should I file a separate bug?

Do you have the nvidia-common package installed? It seems a lot of
people don't, mainly they used apt-get dist-upgrade for the upgrade
from 8.04. If not, does installing it help?

Endolith (endolith) wrote :

> Do you have the nvidia-common package installed? It seems a lot of
> people don't, mainly they used apt-get dist-upgrade for the upgrade
> from 8.04. If not, does installing it help?

After the update and re-installing nvidia-common, I see both 96 and 173 in the Hardware Drivers box, but I can't Activate either.

Martin Pitt (pitti) wrote :

Endolith [2008-11-06 3:58 -0000]:
> After the update and re-installing nvidia-common, I see both 96 and 173
> in the Hardware Drivers box, but I can't Activate either.

What happens exactly?

Can you please open a Terminal window and so

  sudo killall jockey-backend
  sudo /usr/share/jockey/jockey-backend --debug -l /tmp/jockey.log

then open Hardware Drivers, try to enable a driver, close it again, go
back to the Terminal, press Control-C, and attach /tmp/jockey.log
here?

Thanks!

Martin Pitt (pitti) wrote :

More positive reports in bug 251107, considering verified.

Martin Pitt (pitti) wrote :

intrepid-proposed package copied to jaunty.

Changed in jockey:
status: Fix Committed → Fix Released
Endolith (endolith) wrote :

> What happens exactly?

1. Open Hardware Drivers window
2. It lists "NVIDIA accelerated graphics driver (version 173) [Recommended]" and "NVIDIA accelerated graphics driver (version 96)" with gray lights next to them, and an "Activate" button with a green light. Clicking on either driver shows "This driver is not activated" at the bottom with another gray light.
3. I select either of the drivers and click the Activate button.
4. Asks for password
5. An "Untitled window" dialog pops up that says "Downloading and installing driver", with an indeterminate-progress indicator.
6. After a long wait, the progress bar starts to fills up, and it acts as though it is installing, though it provides no feedback after it's done; it just disappears
7. The "Activate" button is still lit green, and the lights next to the drivers are still grey.

After a reboot it ends up in low-graphics mode because it's not configured correctly.

> then open Hardware Drivers, try to enable a driver, close it again, go
> back to the Terminal, press Control-C, and attach /tmp/jockey.log
> here?

Attached. I tried installing both a few times during this log

Martin Pitt (pitti) wrote :

Copied to intrepid-updates.

Changed in jockey:
status: Fix Committed → Fix Released
Endolith (endolith) wrote :

Created a new Bug #298584 for my problem

Sam Liddicott (sam-liddicott) wrote :

I have the same problem:

jockey's debug says:

2009-01-16 19:42:14,825 WARNING: DriverID for module nvidia does not refer to a
locally available module and does not specify free/description/package; ignoring
2009-01-16 19:42:14,826 DEBUG: no corresponding handler available for {'driver_t
ype': 'kernel_module', 'kernel_module': 'nvidia', 'jockey_handler': 'KernelModul
eHandler', 'package': 'nvidia-glx-96'}

and "Hardware Drivers" doesn't offer me any nvidia drivers.

If I type:
sudo apt-get install nvidia-glx-96

it tries to uninstall most of xorg

If I type:
sudo apt-get install nvidia-glx-96 xorg

it says:
The following packages have unmet dependencies.
  xserver-xorg-core: Conflicts: xserver-xorg-video-4

My graphics card is a go5600,
$ lspci -n
01:00.0 0300: 10de:031a (rev a1)

lspci
01:00.0 VGA compatible controller: nVidia Corporation NV31M [GeForce FX Go5600] (rev a1)

I'm using jaunty with proposed and backports

Sam Liddicott (sam-liddicott) wrote :

I managed to build nvidia-glx-96 (although it didn't work) but it seemed enough to coax jockey in to fetching nvidia-glx-173 (which I could build, but dkms couldn't build)

Sam Liddicott (sam-liddicott) wrote :

I lied, it did download and install nvidia-glx-173, but it also un-installed ubuntu-desktop, xorg and all the other goodies - and then also failed to load nvidia.ko !

So no joy :-(

Alberto Milone (albertomilone) wrote :

Sam: this is not the right bug report for your problem. Keep an eye on this bug report for updates:
https://bugs.launchpad.net/bugs/308410

it was working fine then it would not recall desktop settings then, nothing I can't initiate it

Changed in jockey (Ubuntu):
status: Fix Released → Fix Committed
Changed in jockey (Ubuntu Intrepid):
status: Fix Released → Confirmed
Martin Pitt (pitti) on 2010-02-06
Changed in jockey (Ubuntu):
status: Fix Committed → Fix Released
Changed in jockey (Ubuntu Intrepid):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers