WL and B44 Not Properly Configured

Bug #289845 reported by Dave Vree on 2008-10-27
14
Affects Status Importance Assigned to Milestone
jockey (Ubuntu)
Undecided
Martin Pitt
Hardy
Undecided
Unassigned
Intrepid
Undecided
Martin Pitt
Jaunty
Undecided
Martin Pitt

Bug Description

I originally reported this issue as part of bug #263097, but was asked to file a new bug.

I am using the latest Intrepid on a Dell XPS M1210 laptop with a Broadcom BCM4328 wifi.

In my case, B44 was being loaded (and thus ssd) prior to jockey attempting to utilize "wl". B44 was being loaded dur to my ethernet adapter. However, because ssd was loaded prior to wl, my wireless networking adapter (wlan0) never showed up.

I had to work around this problem by forcing the loading of wl prior to b44 and ssd -- which I did via the following command:

echo -e '#ssb workaround, added `date`\ninstall wl modprobe -r b43 b44 b43legacy ssb; modprobe --ignore-install wl $CMDLINE_OPTS; modprobe b44;' | sudo tee -a /etc/modprobe.d/wl

At this point, both my ethernet adapter and my wireless adapter are both working just fine -- at the same time.

Martin Pitt (pitti) wrote :

Thanks; I discussed that with Mario, and he suggested something similar. Either we keep the blacklisting of b43/ssb and install such a modprobe.d file if b44 is available, or we use an rmmod/modprobe script like you proposed.

I just generally try to avoid rmmod, since at least in the past it was not generally safe, and also leads to unwanted effects like NetworkManager disconnecting/reconnecting.

Changed in jockey:
assignee: nobody → pitti
status: New → In Progress
Dave Vree (hdave) wrote :

I'd consider my "workaround" to be a complete hack (it's not even mine - it was provided by a helpful forum user).
I'd love to see a better and more permanent solution...so much work has gone into jockey, it'd be a shame to see it not work for an entire class of popular laptops.

I'd be happy to try out any proposed solution.

Han Chung (han+c) wrote :

I can confirm this /problem/, I have the exact some laptop as you are with same ethernet chip except that my Wireless is a Intel PRO/Wireless 3945ABG.

Han Chung (han+c) wrote :

Scrap it, its not.

Mike McDonald (pyrite90) wrote :

I can confirm this problem with BCM4309. The workaround shown above got the wireless working again.

Nero147 (nero147) wrote :

I had the same problem with my install of intrepid ibex. I had the problem with a BCM43XG card. It said that the wl driver was loaded, but nothing was associating with ifconfig, or iwconfig. However they both showed the interface. I read in a forum that SSB was conflicting in this kernel with the wl driver. I ended up getting around this by blacklisting B43 B44 and SSB. I then added wl to /etc/modules because it wasn't loading. My ethernet no longer works, but it's a desktop I only use wireless on so it's not a huge issue.

Martin Pitt (pitti) wrote :
Changed in jockey:
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :
Changed in jockey:
assignee: nobody → pitti
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.5~beta3-0ubuntu9

---------------
jockey (0.5~beta3-0ubuntu9) jaunty; urgency=low

  * Merge from trunk:
    - jockey-gtk: Enlarge driver list if there are more than 3 available
      drivers. (LP: #291028)
    - ui.py: If an activated driver has a package, label the action "Remove",
      not "Deactivate". (LP: #284435)
    - Update German translations.
  * backend/com.ubuntu.DeviceDriver.service: Write debug log to
    /var/log/jockey.log by default when starting the backend. (LP: #290036)
  * Add debian/jockey-common.logrotate for rotating jockey.log.
  * data/handlers/broadcom_wl.py: If b44 is loaded, don't disable the entire
    handler, but instead install a "wl" modprobe handler which removes ssb and
    b44 first, then loads wl, and reloads b44 again, which makes both devices
    work. (LP: #289845)

 -- Martin Pitt <email address hidden> Fri, 28 Nov 2008 11:57:56 +0100

Changed in jockey:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Ported to hardy: http://bazaar.launchpad.net/~ubuntu-core-dev/jockey/hardy/revision/195

Would anyone be able to test this fix on hardy?

I uploaded the updates to hardy and intrepid now, waiting for Steve to process.

Changed in jockey:
status: New → Fix Committed
Steve Langasek (vorlon) wrote :

Accepted into hardy-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Pitt (pitti) wrote :

Accepted into intrepid-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Fix didnt work for me on HP DV6285eu laptop:

ss@hpdv6285:~$ uname -a
Linux hpdv6285 2.6.27-10-generic #1 SMP Fri Nov 21 12:00:22 UTC 2008 i686 GNU/Linux

What debug can I send through to help? (I'm not quite sure)?

imran ali [2008-12-08 3:49 -0000]:
> Fix didnt work for me on HP DV6285eu laptop:

What did you do? Please send the output of "lspci", and your
/etc/modprobe.d/blacklist-bcm43. So your wifi works, but not your
ethernet, or what do you observe?

My ethernet (b44) works, but wireless (b43) does not. nothing showing up in restricted drivers list but my nvidia graphics driver...

Please find output as requested:

imran@hpdv6285:~$ lspci
00:00.0 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.1 RAM memory: nVidia Corporation C51 Memory Controller 0 (rev a2)
00:00.2 RAM memory: nVidia Corporation C51 Memory Controller 1 (rev a2)
00:00.3 RAM memory: nVidia Corporation C51 Memory Controller 5 (rev a2)
00:00.4 RAM memory: nVidia Corporation C51 Memory Controller 4 (rev a2)
00:00.5 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.6 RAM memory: nVidia Corporation C51 Memory Controller 3 (rev a2)
00:00.7 RAM memory: nVidia Corporation C51 Memory Controller 2 (rev a2)
00:02.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:03.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:04.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:09.0 RAM memory: nVidia Corporation MCP51 Host Bridge (rev a2)
00:0a.0 ISA bridge: nVidia Corporation MCP51 LPC Bridge (rev a3)
00:0a.1 SMBus: nVidia Corporation MCP51 SMBus (rev a3)
00:0a.3 Co-processor: nVidia Corporation MCP51 PMU (rev a3)
00:0b.0 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0b.1 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0d.0 IDE interface: nVidia Corporation MCP51 IDE (rev f1)
00:0e.0 IDE interface: nVidia Corporation MCP51 Serial ATA Controller (rev f1)
00:10.0 PCI bridge: nVidia Corporation MCP51 PCI Bridge (rev a2)
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
00:14.0 Bridge: nVidia Corporation MCP51 Ethernet Controller (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
05:00.0 VGA compatible controller: nVidia Corporation GeForce Go 7200 (rev a1)
07:05.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller
07:05.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 19)
07:05.2 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 0a)
07:05.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 05)
07:05.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev ff)

imran@hpdv6285:~$ cat /etc/modprobe.d/blacklist-bcm43
blacklist bcm43xx
blacklist b43
blacklist b43_legacy
blacklist ssb

Thanks

Martin Pitt (pitti) wrote :

imran,

then you actually have a different problem. This one fixes the case where you do see b43 and wl in jockey, but previously wl was not shown if you had a b44 ethernet card. Please file a new bug and do

  sudo killall jockey-backend
  sudo /usr/share/jockey/jockey-backend --debug 2>&1 | tee /tmp/jockey.log

and then start the hardware drivers window from the menu once, quit it again, and press control-C in the terminal with jockey-backend. Please attach /tmp/jockey.log to the new bug.

Anyone who has the original problem in this bug who can test this?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.5~beta3-0ubuntu6.1

---------------
jockey (0.5~beta3-0ubuntu6.1) intrepid-proposed; urgency=low

  * debian/control: Update Vcs-Bzr: for intrepid branch.
    (LP: #283765)
  * fglrx.py: Unconfigured driver defaults to ati, which already provides
    compositing. This fixes gnome-appearance-properties to endlessly ask to
    install the fglrx driver on systems where ati works fine. (LP: #285879)
  * data/handlers/b43.py: Add missing OSLib import. (LP: #295530)
  * data/handlers/broadcom_wl.py: If b44 is loaded, don't disable the entire
    handler, but instead install a "wl" modprobe handler which removes ssb and
    b44 first, then loads wl, and reloads b44 again, which makes both devices
    work. (LP: #289845)
  * tests/detection.py: Fix yum printer test for changed package name on
    openprinting.org. This only affects the test suite, so that it succeeds
    again. (Cherrypicked from trunk r501)

 -- Martin Pitt <email address hidden> Fri, 28 Nov 2008 11:43:06 +0100

Changed in jockey:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Anyone who could test the hardy update of jockey, whether it does the right thing now wrt. configuring wl?

Dave Morley (davmor2) wrote :

I have tried this from Live cd dated 20090121 i386 version

Hardware spec can be found here http://www.davmor2.co.uk/hplappy.html (result of sudo lshw -html)

This seems to be working fine for me.

Luke Yelavich (themuso) wrote :

I tested the amd64 version of the Hardy live CD dated January 21 2009. Enabling broadcom wireless in jockey caused a new blacklist file to be created in /etc/modprobe.d, blacklisting all b43 related drivers, including ssb. A restart was required, which is not possible for the live CD without loosing the settings, but all appears to get configured correctly.

I am using a MacBook Pro 4.1, with broadcom wireless using the wl driver.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.3.3-0ubuntu8.2

---------------
jockey (0.3.3-0ubuntu8.2) hardy-proposed; urgency=low

  * data/handlers/broadcom_wl.py: If b44 is loaded, don't disable the entire
    handler, but instead install a "wl" modprobe handler which removes ssb and
    b44 first, then loads wl, and reloads b44 again, which makes both devices
    work. (LP: #289845)

 -- Martin Pitt <email address hidden> Fri, 28 Nov 2008 12:06:26 +0100

Changed in jockey:
status: Fix Committed → Fix Released
Bradley Taranto (yldblueman) wrote :

i JUST WENT THROUGH THIS.
OPTION 1
 Load kubuntu-desktop in synaptic. USE PATCH CABLE NETWORK 500 MEGS of files. You can now use additional drivers in a graphical environment.
Option 2
Attempt to install your wifi driver. If it install your done. If it say's BLACKLISTED or check log file /var/log/jockey.log OPEN A TERMINAL and run "sudo gedit /var/log/jockey.log" if it has a series of errors scroll to bottom and see if it lists drivers as BLACKLIST.
If so, run "sudo ls /etc/modprobe.d/" and it will return something like
alsa-base.conf blacklist.conf blacklist-oss.conf blacklist-ath_pci.conf
blacklist-firewire.conf blacklist-rare-network.conf dkms.conf
blacklist-bcm43.conf blacklist-framebuffer.conf blacklist-watchdog.conf iwlwifi.conf
blacklist-modem.conf broadcom-sta-common.conf vmwgfx-fbdev.conf
figure out witch ones have your drivers in it. I used:
blacklist-bcm43.conf
broadcom-sta-common.conf
blacklist.conf
using the command "sudo gedit /etc/modprobe.d/blacklist-bcm43.conf" unblacklist the driver using (# driver ). The comments at the top of the file is guide for commenting. Do this for each PERTINENT file. Reboot.
YOU THINK IT WOULD HAVE WORKED BUT NOOOOO! using the command "sudo gedit /etc/modprobe.d/blacklist-bcm43.conf" FOR each PERTINENT file and comment out every blacklisted driver from your manufacturer.
# Warning: This file is autogenerated by bcmwl. All changes to this file will be lost.
# blacklist b43
# blacklist b43legacy
# blacklist ssb
# blacklist bcm43xx
# blacklist brcm80211
# blacklist brcmfmac
# blacklist brcmsmac
# blacklist bcma
THIS WORKED FOR ME!!!!!!!!!!!!!!!!!!!!!!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers