Jockey takes very long before starting to uninstall a printer driver package

Bug #279073 reported by Till Kamppeter on 2008-10-06
12
Affects Status Importance Assigned to Milestone
jockey (Ubuntu)
Low
Martin Pitt

Bug Description

As I do not have a printer which needs a driver download from OpenPrinting, I test Jockey by uninstalling "splix" and then running

dbus-send --print-reply --dest=com.ubuntu.DeviceDriver /GUI com.ubuntu.DeviceDriver.search_driver string:"printer_deviceid:MFG:Samsung;MDL:ML-1610;CMD:GDI"

This calls Jockey the same way as a printer setup tool should do when it detects a Samsung ML-1610. Jockey then comes up and tells that the SpliX driver is available for download. Clicking the appropriate button lets a password dialog appear and a few seconds after entering the password the LSB package of the driver gets downloaded and installed.

Closing Jockey and running the above-mentioned command again also opens the Jockey windo but this time telling that SpliX is already installed and active. Clicking for uninstalling/deactivating the driver immediately opens the password dialog, but after entering the password it takes a rather long time (perhaps a minute) without any message (and perhaps even the possibility to click the uninstall button again) before the progress bar window indecates that the driver gets uninstalled.

This uninstallation should either be started much more quickly or a wait message window telling that the uninstallation is prepared should appear.

Changed in jockey:
assignee: nobody → pitti
importance: Undecided → Medium
milestone: none → ubuntu-8.10
Martin Pitt (pitti) wrote :

It takes some 4 seconds for me (time between entering password and the progress dialog starting), and the entire removal takes no longer than 10. I wonder what happens for you, then. Can you please do

   sudo killall jockey-backend
   sudo /usr/share/jockey/jockey-backend --debug -l /tmp/jockey.log

then do the procedure you described again? After that, Control-C the jockey-backend process, and attach /tmp/jockey.log. Thanks!

Changed in jockey:
milestone: ubuntu-8.10 → none
status: New → Incomplete
Till Kamppeter (till-kamppeter) wrote :

I have tried it out but now it works much better for me (uninstall wait window 3-4 seconds after entering password). Perhaps one could let the wait window already let appear immediately after entering the password, with infinite progress bar (rectangle going forth and back, no percentage) in the beginning and a normal progress bar for the uninstall itself.

Martin Pitt (pitti) wrote :

OK, I will do that then. Thanks!

Changed in jockey:
importance: Medium → Low
status: Incomplete → Triaged
Martin Pitt (pitti) wrote :

Fixed upstream, r481.

Changed in jockey:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.5~beta2-0ubuntu2

---------------
jockey (0.5~beta2-0ubuntu2) intrepid; urgency=low

  * Merge bug fixes from trunk:
    - openprinting.org detected handlers: Add supplier and support contacts to
      long description. (LP: #269454)
    - backend.py, set_enabled(): Report progress signals early when handling
      packages, to avoid delays until package manager sends out the first
      progress. (LP: #279073)
  * data/handlers/fglrx.py: Enable driver again, current version works now.
    Also add "Recommends: fglrx-modaliases", so that detection works in a
    default installation. (LP: #262819)

 -- Martin Pitt <email address hidden> Wed, 15 Oct 2008 00:10:53 +0200

Changed in jockey:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers