jockey-gtk crashed with AttributeError in handler_info()

Bug #273231 reported by Hew McLachlan on 2008-09-22
266
Affects Status Importance Assigned to Milestone
jockey (Ubuntu)
Medium
Martin Pitt

Bug Description

I clicked on the Nvidia drivers available to me and noticed there were no descriptions appearing for them. I closed jockey and then apport appeared (but I suspect the problem was with the lack of descriptions).

ProblemType: Crash
Architecture: amd64
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/bin/jockey-gtk
InterpreterPath: /usr/bin/python2.5
NonfreeKernelModules: nvidia
Package: jockey-gtk 0.5~alpha1-0ubuntu2
PackageArchitecture: all
ProcAttrCurrent: unconfined
ProcCmdline: /usr/bin/python /usr/bin/jockey-gtk
ProcEnviron:
 PATH=/home/username/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/jockey-gtk']
SourcePackage: jockey
Title: jockey-gtk crashed with AttributeError in handler_info()
Uname: Linux 2.6.27-3-generic x86_64
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin plugdev sambashare video

Hew McLachlan (hew) wrote :
Andrea Caminiti (nrayever) wrote :

same here! i just installed 8.10 beta and when i tried to install nvidia drivers jockey crashes!

nrayever

Hew McLachlan (hew) wrote :

Triaging based on the above comment, thanks.

Changed in jockey:
importance: Undecided → Medium
status: New → Triaged
Martin Pitt (pitti) wrote :

Did you recently upgrade jockey? (Or your system in general?) This looks as if you already have the new jockey backend running (jockey-common), but still have the old graphical user interface (jockey-gtk). Can you please fully upgrade your system, restart it, and see whether you can still reproduce this? Thanks!

Changed in jockey:
status: Triaged → Incomplete
Hew McLachlan (hew) wrote :

I can't remember exactly, but I had probably just upgraded at the time and opened jockey to test. I now have jockey-gtk 0.5~beta1-0ubuntu2 and have restarted since installing. I cannot reproduce the problem, so I'm closing this report.

If someone else can reproduce the problem after restarting their system, please reopen the bug report. Thank you.

Changed in jockey:
status: Incomplete → Invalid
Martin Pitt (pitti) wrote :

Hew, thanks; actually, I just noticed that there are lots of duplicates, so there is most likely something real going on here.

I just spotted an error in the code which would cause this. It happens if the UI is started, left running for more than 10 minutes, and then you try to do something. In that time, the backend timed out, and drivers need to be re-detected.

I guess a common case for that is the --check mode (where you get the icon in the tray, and ignore it for some time). I'll get that fixed.

Changed in jockey:
assignee: nobody → pitti
status: Invalid → In Progress
Martin Pitt (pitti) wrote :

Fixed in trunk.

Changed in jockey:
status: In Progress → Fix Committed
Hew McLachlan (hew) wrote :

You're right. I opened jockey and left it for 10 min. I was then able to reproduce the crash by selecting another driver.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.5~beta1-0ubuntu3

---------------
jockey (0.5~beta1-0ubuntu3) intrepid; urgency=low

  * Merge bug fixes from trunk:
     - Update the name of fglrx; radeonhd etc. are accelerated, too.
       (LP: #263359)
     - ui.py, backend(): Re-detect device drivers after the backend timed out.
       (LP: #273231)
     - backend.py, set_enabled(): Propagate exceptions from the enable/disable
       threads. (LP: #278034)
     - jockey-{gtk,kde}: Fix display of UI elements if no drivers are
       available. (LP: #277616, #277702)
     - jockey-kde: Actually show a license dialog when clicking on "Details"
       for the license. [Alberto]
     - Fix enabling/disabling of video drivers if multiple cards are
       configured in xorg.conf. [Alberto]
     - detection.py, get_printers(): Intercept RuntimeError harder.
       (LP: #272721)

 -- Martin Pitt <email address hidden> Mon, 06 Oct 2008 13:34:12 +0200

Changed in jockey:
status: Fix Committed → Fix Released
Jouke (digigram) wrote :

yeah - don't have this problem with current intrepid

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers