jockey-gtk crashed with SystemError in run()

Bug #258713 reported by Marc on 2008-08-17
148
Affects Status Importance Assigned to Milestone
jockey (Ubuntu)
Medium
Unassigned
Nominated for Intrepid by Hew

Bug Description

Again I could tell what happened...

ProblemType: Crash
Architecture: amd64
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/bin/jockey-gtk
InterpreterPath: /usr/bin/python2.5
NonfreeKernelModules: fglrx
Package: jockey-gtk 0.4+r354-0ubuntu1
PackageArchitecture: all
ProcAttrCurrent: unconfined
ProcCmdline: /usr/bin/python /usr/bin/jockey-gtk
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=fr_CA.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/jockey-gtk']
SourcePackage: jockey
Title: jockey-gtk crashed with SystemError in run()
Uname: Linux 2.6.26-5-generic x86_64
UserGroups: adm admin cdrom dialout fuse lpadmin plugdev sambashare

Marc (m-chabot) wrote :
Hew (hew) wrote :

As I mentioned in bug #259047, this is due to jockey not liking the xorg.conf. Regenerating with dkpg-configure xserver-xorg fixes the problem.

Changed in jockey:
importance: Undecided → Medium
status: New → Triaged
Bremm (bremm) wrote :

Confirmed, I just did the described procedure.

$ sudo dpkg-reconfigure xserver-xorg
xserver-xorg postinst warning: overwriting possibly-customised configuration
   file; backup in /etc/X11/xorg.conf.20080912225801

$ gksu /usr/bin/jockey-gtk
/home/bremm/.themes/XubuntuStudio/gtk-2.0/gtkrc:81: Murrine configuration option "hilight_ratio" will be deprecated in future releases. Please update this theme to get rid of this warning.
/usr/bin/jockey-gtk:99: PangoWarning: Error loading GPOS table 0x157f
  self.w('dialog_manager').show()

Brian Murray (brian-murray) wrote :

Bug 269469 seems to be related to this one. It also seems that jockey could be better about catching errors with commit in apt.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.5~alpha1-0ubuntu3

---------------
jockey (0.5~alpha1-0ubuntu3) intrepid; urgency=low

  * Merge some bug fixes from trunk:
    - Fix search_drivers() to not return unrelated available handlers.
    - Change --search-driver UIs from confirmation dialog to displaying list
      of matches. (One half of LP: #269454)
    - OpenPrintingDriverDB: Show shortdescription and functionality fields.
      (Other half of LP: #269454)
    - Drop a lot of redundant probing from add_driverdb() and search_driver().
    - Build KDE .ui -> python on build time, to avoid runtime uic dependency.
      (LP: #271317)
    - nvidia, fglrx handlers: Remove RgbPath option, it causes X.org to crash.
    - ui.py: Update action button strings according to latest recommendations
      from Matthew Thomas, thanks!
    - ui.py: Properly intercept failure to connect to D-BUS. (LP: #258472)
  * Add python-kde4-dev build dependency, now needed to get pykde4uic.
  * fglrx, nvidia: Uninstall -kernel-source in disable(), thanks Alberto.
    (LP: #251962)
  * jockey/oslib.py, install_package(): Intercept SystemError. (LP: #258713,
    LP: #272146)

 -- Martin Pitt <email address hidden> Mon, 22 Sep 2008 15:39:42 +0200

Changed in jockey:
status: Triaged → Fix Released
mirniy (perviy) on 2008-10-09
Changed in jockey:
status: Fix Released → Invalid
Brian Murray (brian-murray) wrote :

I'm changing this bug back to Fix Released since there was no indication as to why it should be Invalid and the bug really was fixed.

Changed in jockey:
status: Invalid → Fix Released
gregford (gregford) wrote :
Download full text (32.5 KiB)

2008-10-11 23:48:31,363 WARNING: modinfo for module nvidia failed: modinfo: could not find module nvidia

2008-10-11 23:48:31,367 DEBUG: Instantiated Handler subclass __builtin__.NvidiaDriver from name NvidiaDriver
2008-10-11 23:48:31,367 DEBUG: NVIDIA accelerated graphics driver availability undetermined, adding to pool
2008-10-11 23:48:31,368 DEBUG: loading custom handler /usr/share/jockey/handlers/fglrx.py
2008-10-11 23:48:31,385 DEBUG: Instantiated Handler subclass __builtin__.FglrxDriver from name FglrxDriver
2008-10-11 23:48:31,392 DEBUG: ATI/AMD proprietary FGLRX graphics driver availability undetermined, adding to pool
2008-10-11 23:48:31,393 DEBUG: all custom handlers loaded
2008-10-11 23:48:31,393 DEBUG: querying driver db <jockey.detection.LocalKernelModulesDriverDB instance at 0x7f9857253fc8> about HardwareID('modalias', 'acpi:PNP0501:')
2008-10-11 23:48:31,394 DEBUG: querying driver db <jockey.detection.LocalKernelModulesDriverDB instance at 0x7f9857253fc8> about HardwareID('modalias', 'input:b0003v045Ep00F6e0111-e0,1,2,4,k110,111,112,r0,1,8,am4,lsfw')
2008-10-11 23:48:31,736 DEBUG: no corresponding handler available for {'driver_type': 'kernel_module', 'kernel_module': 'evdev', 'jockey_handler': 'KernelModuleHandler'}
2008-10-11 23:48:31,737 DEBUG: no corresponding handler available for {'driver_type': 'kernel_module', 'kernel_module': 'evbug', 'jockey_handler': 'KernelModuleHandler'}
2008-10-11 23:48:31,737 DEBUG: querying driver db <jockey.detection.LocalKernelModulesDriverDB instance at 0x7f9857253fc8> about HardwareID('modalias', 'acpi:PNP0303:PNP030B:')
2008-10-11 23:48:31,737 DEBUG: querying driver db <jockey.detection.LocalKernelModulesDriverDB instance at 0x7f9857253fc8> about HardwareID('modalias', 'acpi:PNP0100:')
2008-10-11 23:48:31,738 DEBUG: querying driver db <jockey.detection.LocalKernelModulesDriverDB instance at 0x7f9857253fc8> about HardwareID('modalias', 'pci:v00001106d00002336sv00000000sd00000000bc06sc00i00')
2008-10-11 23:48:31,838 DEBUG: querying driver db <jockey.detection.LocalKernelModulesDriverDB instance at 0x7f9857253fc8> about HardwareID('modalias', 'usb:v045Ep00F6d0121dc00dsc00dp00ic03isc01ip02')
2008-10-11 23:48:32,141 DEBUG: no corresponding handler available for {'driver_type': 'kernel_module', 'kernel_module': 'usbhid', 'jockey_handler': 'KernelModuleHandler'}
2008-10-11 23:48:32,142 DEBUG: no corresponding handler available for {'driver_type': 'kernel_module', 'kernel_module': 'usbmouse', 'jockey_handler': 'KernelModuleHandler'}
2008-10-11 23:48:32,142 DEBUG: querying driver db <jockey.detection.LocalKernelModulesDriverDB instance at 0x7f9857253fc8> about HardwareID('modalias', 'pci:v00001106d0000B188sv00000000sd00000000bc06sc04i00')
2008-10-11 23:48:32,143 DEBUG: no corresponding handler available for {'driver_type': 'kernel_module', 'kernel_module': 'shpchp', 'jockey_handler': 'KernelModuleHandler'}
2008-10-11 23:48:32,143 DEBUG: querying driver db <jockey.detection.LocalKernelModulesDriverDB instance at 0x7f9857253fc8> about HardwareID('modalias', 'input:b0010v001Fp0001e0100-e0,12,kramls1,2,fw')
2008-10-11 23:48:32,144 DEBUG: no corresponding handler available for {'driver_type': 'kernel_mod...

gregford (gregford) wrote :

greg@ubuntu:~$ gksu /usr/bin/jockey-gtk
Traceback (most recent call last):
  File "/usr/bin/jockey-gtk", line 346, in on_button_toggle_clicked
    'toggle', False):
  File "/usr/lib/python2.5/site-packages/jockey/ui.py", line 574, in set_handler_enable
    handler_id, enable)
  File "/usr/lib/python2.5/site-packages/jockey/backend.py", line 103, in polkit_auth_wrapper
    return fn(*args, **kwargs)
  File "/usr/lib/python2.5/site-packages/jockey/backend.py", line 87, in dbus_sync_call_signal_wrapper
    raise _h_exception_exc
dbus.exceptions.DBusException: org.freedesktop.DBus.Python.SystemError: Traceback (most recent call last):
  File "/var/lib/python-support/python2.5/dbus/service.py", line 696, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/lib/python2.5/site-packages/jockey/backend.py", line 309, in _f_result_wrapper
    self._f_result = f()
  File "/usr/lib/python2.5/site-packages/jockey/xorg_driver.py", line 157, in enable
    KernelModuleHandler.enable(self)
  File "/usr/lib/python2.5/site-packages/jockey/handlers.py", line 439, in enable
    Handler.enable(self)
  File "/usr/lib/python2.5/site-packages/jockey/handlers.py", line 224, in enable
    self.backend.install_package(self.package)
  File "/usr/lib/python2.5/site-packages/jockey/backend.py", line 543, in install_package
    hasattr(self, '_locations') and self.install_progress or None)
  File "/usr/lib/python2.5/site-packages/jockey/oslib.py", line 220, in install_package
    c[package].markInstall()
  File "/usr/lib/python2.5/site-packages/apt/package.py", line 421, in markInstall
    fixer.Resolve(True)
SystemError: E:Unable to correct problems, you have held broken packages.

gregford (gregford) wrote :

i don't know if you guys can make sense of all that stuff but ever since i installed alpha 5 that what happens when i try and hardware drivers to install the proprietary amd driver

waspbr (notaduck) wrote :

I am running a system on an athlon XP 3000+ with a radeon hd 3850 AGP and the bug is still there, synaptic points that jockey 0.5 beta1 is installed.

dkpg-configure xserver-xorg does not fix the problem.

Hew (hew) wrote :

This bug has already been fixed, I had the problem and can confirm it has gone. If you are still having problems with jockey, please file a new bug on your issue. If your problem is because jockey is crashing, simply submit the crash report through apport. Thank you.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers