jockey-gtk crashed with SIGSEGV in gtk_icon_set_render_icon()

Bug #204134 reported by nitalaut on 2008-03-20
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GTK+
Unknown
Critical
jockey (Ubuntu)
Medium
Martin Pitt

Bug Description

hardy

ProblemType: Crash
Architecture: amd64
Date: Tue Mar 18 08:07:15 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/jockey-gtk
InterpreterPath: /usr/bin/python2.5
Package: jockey-gtk 0.3.2-0ubuntu1
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/jockey-gtk
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin
 LANG=en_US.UTF-8
Signal: 11
SourcePackage: jockey
StacktraceTop:
 gtk_icon_set_render_icon ()
 gtk_widget_render_icon ()
 ?? () from /usr/lib/libgtk-x11-2.0.so.0
 ?? () from /usr/lib/libgtk-x11-2.0.so.0
 ?? () from /usr/lib/libgtk-x11-2.0.so.0
Title: jockey-gtk crashed with SIGSEGV in gtk_icon_set_render_icon()
Uname: Linux 2.6.24-12-rt x86_64
UserGroups:
SegvAnalysis:
 Segfault happened at: 0x7fe7e2ef3250 <gtk_icon_set_render_icon+1552>: mov 0x8(%rax),%r8
 PC (0x7fe7e2ef3250) ok
 source "0x8(%rax)" (0x00000008) not located in a known VMA region (needed readable region)!
 destination "%r8" ok
SegvReason: reading NULL VMA

nitalaut (nitalaut-gmail) wrote :

StacktraceTop:IA__gtk_icon_set_render_icon (icon_set=0x9e3530, style=0xe4e000,
IA__gtk_widget_render_icon (widget=0xf1b820, stock_id=<value optimized out>,
ensure_pixbuf_for_icon_name (image=0xf1b820)
gtk_image_calc_size (image=0x7fe7e3068257)
gtk_image_size_request (widget=0x7fe7e3068257, requisition=0x10)

Changed in jockey:
importance: Undecided → Medium
Martin Pitt (pitti) on 2008-03-20
Changed in jockey:
importance: Medium → Undecided
Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=523592

Changed in gtk+2.0:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Triaged
Changed in gtk:
status: Unknown → New
summary: - jockey-gtk crashed with SIGSEGV in gtk_icon_set_render_icon()
+ gtk applications crashes with SIGSEGV in gtk_icon_set_render_icon()
summary: - gtk applications crashes with SIGSEGV in gtk_icon_set_render_icon()
+ gtk applications crash with SIGSEGV in gtk_icon_set_render_icon()

the issue is similar to bug #86698 and easy to trigger with DISPLAY= /usr/share/apport/apport-gtk -c crash

summary: - gtk applications crash with SIGSEGV in gtk_icon_set_render_icon()
+ jockey-gtk crashed with SIGSEGV in gtk_icon_set_render_icon()
affects: gtk+2.0 (Ubuntu) → jockey (Ubuntu)
Changed in jockey (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Triaged → New
Martin Pitt (pitti) wrote :

trunk r570

Changed in jockey (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: New → Fix Committed
Kees Cook (kees) on 2009-09-16
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.5.4-0ubuntu1

---------------
jockey (0.5.4-0ubuntu1) karmic; urgency=low

  * New upstream bug fix release:
    - Update tests for openprinting.org changes; LaserJet 3020 does not exist
      any more, replace with DesignJet 3050CP.
    - Handler: Reload module blacklist after installing a driver package,
      since it might ship blacklists.
    - setup.py: Fix DistUtilsExtra version check. (LP: #428337)
    - jockey-gtk: Check for having $DISPLAY at startup to avoid crashes.
      (LP: #204134)
  * ui.py: Fix error message parsing, thanks to rugby471! (LP: #386375)
  * Add data/handlers/dvb_usb_firmware.py: Handler for DVB USB cards which
    need to have the linux-firmware-nonfree package installed. (LP: #223212)

 -- Martin Pitt <email address hidden> Mon, 21 Sep 2009 18:31:45 +0200

Changed in jockey (Ubuntu):
status: Fix Committed → Fix Released
Changed in gtk:
importance: Unknown → Critical
dino99 (9d9) wrote :

On genuine Precise i386 with nvidia-current driver i get:

oem@oem-desktop:~$ sudo jockey-gtk
[sudo] password for oem:

Gtk-CRITICAL **: gtk_icon_set_render_icon_pixbuf: assertion `icon_set != NULL' failed

tags: added: i386 precise
Changed in gtk:
status: New → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.