jockey-gtk crashed with NameError in enabled()

Bug #203958 reported by Fabio Frijo on 2008-03-19
110
Affects Status Importance Assigned to Milestone
jockey (Ubuntu)
High
Martin Pitt

Bug Description

- Release:

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)

- Source package: jockey-gtk

- Version: 0.3.2-0ubuntu2

It is crashed on system boot, unfortunately I was not able to understand the reason ... I hope that the information posted can be helpful ...
Thanks!

ProblemType: Crash
Architecture: i386
Date: Wed Mar 19 17:25:19 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/jockey-gtk
InterpreterPath: /usr/bin/python2.5
Package: jockey-gtk 0.3.2-0ubuntu2
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/jockey-gtk --check 60
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/jockey-gtk', '--check', '60']
SourcePackage: jockey
Title: jockey-gtk crashed with NameError in enabled()
Uname: Linux 2.6.24-12-generic i686
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse lpadmin netdev plugdev powerdev scanner tape vboxusers video

Related branches

Fabio Frijo (dj-wolf) wrote :
Martin Pitt (pitti) wrote :

Argh, my bad, that's a regression in the last version.

Changed in jockey:
assignee: nobody → pitti
importance: Undecided → High
milestone: none → ubuntu-8.04
status: New → In Progress
Larry Reaves (yrral86) wrote :

adding:
from jockey.handlers import KernelModuleHandler

to /usr/share/jockey/handlers/b43.py fixed this for me

Martin Pitt (pitti) wrote :

Fixed in bzr head.

Changed in jockey:
status: In Progress → Fix Committed
Fabio Frijo (dj-wolf) wrote :

Thank you all for your good work and for the speed with which you answered!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.3.2-0ubuntu3

---------------
jockey (0.3.2-0ubuntu3) hardy; urgency=low

  * Cherrypick some bug fixes from trunk:
    - Add automatic testing for all shipped custom handlers in examples/ and
      data/handlers/. So far the test suite only covered the standard
      handlers.
    - This uncovered that the fglrx and nvidia handlers still crash if
      xorg.conf does not have a Screen section; fixed for real now.
      (LP: #200832)
  * data/handlers/b43.py: Add missing import (also uncovered by above test
    suite). (LP: #203958)

 -- Martin Pitt <email address hidden> Thu, 20 Mar 2008 16:30:32 +0100

Changed in jockey:
status: Fix Committed → Fix Released
ibeleaf (david-infusini) wrote :

so what exactly do i have to type in terminal to overcome this glitch? im fairly new to ubuntu sorry.

my computers name is "david-laptop"... if that helps.

ibeleaf [2008-03-25 2:50 -0000]:
> so what exactly do i have to type in terminal to overcome this glitch?

Just update to the latest packages in Ubuntu Hardy (use the "updated
packages available" icon in the system tray). If you really want to
use the command line:

  sudo apt-get update
  sudo apt-get dist-upgrade

ibeleaf (david-infusini) wrote :

i tried that

is there a sudo command to enable my wireless driver?

Because when i go to the hardware driver utilty screen, i see my wireless driver and i click enable, and the first tiem it got the drivers and installed them, and then it said 'requires computer restart' so i did that, but then when i went back i had to enable it again, and it tells me to restart again. and it just becomes a cycle.

ibeleaf (david-infusini) wrote :

it's a 'Broadcom B43 Wireless' driver btw.

ibeleaf (david-infusini) wrote :

that screen shot was taken after i checked the enable box, before, it had a green light and said "in use" but it wasn't in use. and if i were to check it again while it says "requires computer restart" everything freezes up.

Martin Pitt (pitti) wrote :

ibeleaf, can you please open a new bug report for your problem, and do the following:

  jockey-gtk --list --debug 2>&1 | tee /tmp/debug.txt

and attach /tmp/debug.txt to the new bug report? Thank you!

ibeleaf (david-infusini) wrote :

i've gone back to gutsy gibbon because i really needed my wireless card to be working for school, maybe i'll go back to the beta after exams.

waterguy (hydro-hydromodeling) wrote :

I am also having the same issue with the restricted Broadcom driver. I will open a new bug report if it has not already been done. In the mean time does anyone know of a work around?

moorezilla (mooreweb) wrote :

I can confirm this. I ran into this problem detailed above:

"Because when i go to the hardware driver utilty screen, i see my wireless driver and i click enable, and the first tiem it got the drivers and installed them, and then it said 'requires computer restart' so i did that, but then when i went back i had to enable it again, and it tells me to restart again. and it just becomes a cycle."

AstroMb (matthieu-bachschmidt) wrote :

I've got the same issue too, i've done the following (jockey-gtk --list --debug 2>&1 | tee /tmp/debug.txt) and put it in attachement.

Martin Pitt (pitti) wrote :

moorezilla, AstroMb: please, open a new report for this. This report is fixed and closed.

rlomboy (rlomboy) wrote :

Has this problem been resolved. I'm in the process of downloading 8.04. What is the fix?

Cristian (cristianrosa) wrote :

Today I did a clean install of Ubuntu 8.04 Beta and upgraded to the latest version and I'm still having an issue with jockey and the broadcom driver.
This is the output of jockey-gtk:
cristian@cristian-laptop:~$ jockey-gtk
Traceback (most recent call last):
  File "/usr/bin/jockey-gtk", line 279, in on_handler_changed
    if self.toggle_handler(self.model[path][0]):
  File "/usr/lib/python2.5/site-packages/jockey/ui.py", line 483, in toggle_handler
    handler.enable()
  File "/usr/lib/python2.5/site-packages/jockey/handlers.py", line 679, in enable
    DriverPackageHandler.enable(self)
  File "/usr/lib/python2.5/site-packages/jockey/handlers.py", line 596, in enable
    self.ui.install_package(self.package)
  File "/usr/lib/python2.5/site-packages/jockey/ui.py", line 493, in install_package
    oslib.OSLib.inst.install_package(package, self)
  File "/usr/lib/python2.5/site-packages/jockey/oslib.py", line 186, in install_package
    env.update(os.environ)
NameError: global name 'env' is not defined

I inspected the file oslib.py and it seems the problem arises because the definition of the variable env is missing.
Any suggestion?

fenestrator (valorpart) wrote :

I too have a Broadcom 43 Wireless wifi on my new Dell XPS 1330 laptop. The cycle is maddening! Can Ubuntu's sponsor Canonical not get the functions adjusted for Harday? I mean it worked great under Gutsy so they've got to have the hardware profile somewhere....

I'll keep a close eye on the progress here as I'm still bound by tethered patch-cable.

hardcorelinux (hardcorelinux) wrote :

There a two different issues in discussion here:
(1) jockey-gtk - I recently upgraded to 8.04 from 7.10, for me it works.
(2) driver for Broadcom WiFi card - I'm using b43 proprietary driver, with new firmware found here:http://linuxwireless.org/en/users/Drivers/b43#devicefirmware

nandocaldas (nando1980) wrote :

I am still having problems with my wireles network. The Ubuntu 8 (updated) did not recconized the hardwere. Is just like I did not have a wireless hardwere.
Ps.: I would like to thank the community, you have been very effective fixing bugs for regular users like me.

Ryan Lester (buu700) wrote :

Whether or not the b43 driver works for you, at this point ndiswrapper still gives better performance.

To install the driver through ndiswrapper:

'sudo aptitude install cabextract ndisgtk'
Download the .exe file that installs the driver in Windows.
'cabextract [location of the .exe file]'
This will extract the drivers from the executable.

Now just run ndisgtk from either the main menu or with 'sudo ndisgtk' and browse to the .inf file that was extracted.
OR
'sudo ndiswrapper –i [location of the .inf file]'

'echo ndiswrapper | sudo tee -a /etc/modules && sudo modprobe ndiswrapper'

dark_otaku (thepsyco1) wrote :
  • unnamed Edit (3.0 KiB, text/html; charset=WINDOWS-1252)

i have the wireless working the only thing i did was to go to synaptics
package manager, and reinstall jockey-gtk, after that i just enable the
wireless, this made my laptop crash, but i just restart the laptop and there
it was the blue light and wireless, just check that the fix was released but
you have to reinstall the jockey-gtk manually, just reinstall on synaptics
(don't uninstall it just mark for reinstallation)

On Wed, Apr 16, 2008 at 4:08 PM, buu700 <email address hidden> wrote:

> Whether or not the b43 driver works for you, at this point ndiswrapper
> still gives better performance.
>
> To install the driver through ndiswrapper:
>
> 'sudo aptitude install cabextract ndisgtk'
> Download the .exe file that installs the driver in Windows.
> 'cabextract [location of the .exe file]'
> This will extract the drivers from the executable.
>
> Now just run ndisgtk from either the main menu or with 'sudo ndisgtk' and
> browse to the .inf file that was extracted.
> OR
> 'sudo ndiswrapper –i [location of the .inf file]'
>
> 'echo ndiswrapper | sudo tee -a /etc/modules && sudo modprobe
> ndiswrapper'
>
> --
> jockey-gtk crashed with NameError in enabled()
> https://bugs.launchpad.net/bugs/203958
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Source Package "jockey" in Ubuntu: Fix Released
>
> Bug description:
> - Release:
>
> DISTRIB_ID=Ubuntu
> DISTRIB_RELEASE=8.04
> DISTRIB_CODENAME=hardy
> DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)
>
> - Source package: jockey-gtk
>
> - Version: 0.3.2-0ubuntu2
>
> It is crashed on system boot, unfortunately I was not able to understand
> the reason ... I hope that the information posted can be helpful ...
> Thanks!
>
> ProblemType: Crash
> Architecture: i386
> Date: Wed Mar 19 17:25:19 2008
> DistroRelease: Ubuntu 8.04
> ExecutablePath: /usr/bin/jockey-gtk
> InterpreterPath: /usr/bin/python2.5
> Package: jockey-gtk 0.3.2-0ubuntu2
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python /usr/bin/jockey-gtk --check 60
> ProcEnviron:
>
> PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
> LANG=it_IT.UTF-8
> SHELL=/bin/bash
> PythonArgs: ['/usr/bin/jockey-gtk', '--check', '60']
> SourcePackage: jockey
> Title: jockey-gtk crashed with NameError in enabled()
> Uname: Linux 2.6.24-12-generic i686
> UserGroups: adm admin audio cdrom dialout dip fax floppy fuse lpadmin
> netdev plugdev powerdev scanner tape vboxusers video
>

fenestrator (valorpart) wrote :
  • unnamed Edit (5.4 KiB, text/html; charset=WINDOWS-1252)
Download full text (4.2 KiB)

My wireless now works! Took your advise, deleted jockey as well as fwcutter
and reinstalled..... it worked right away and didn't even require a reboot!

Thanks.

On Fri, Apr 18, 2008 at 2:57 AM, dark_otaku <email address hidden> wrote:

> i have the wireless working the only thing i did was to go to synaptics
> package manager, and reinstall jockey-gtk, after that i just enable the
> wireless, this made my laptop crash, but i just restart the laptop and
> there
> it was the blue light and wireless, just check that the fix was released
> but
> you have to reinstall the jockey-gtk manually, just reinstall on synaptics
> (don't uninstall it just mark for reinstallation)
>
> On Wed, Apr 16, 2008 at 4:08 PM, buu700 <email address hidden> wrote:
>
> > Whether or not the b43 driver works for you, at this point ndiswrapper
> > still gives better performance.
> >
> > To install the driver through ndiswrapper:
> >
> > 'sudo aptitude install cabextract ndisgtk'
> > Download the .exe file that installs the driver in Windows.
> > 'cabextract [location of the .exe file]'
> > This will extract the drivers from the executable.
> >
> > Now just run ndisgtk from either the main menu or with 'sudo ndisgtk'
> and
> > browse to the .inf file that was extracted.
> > OR
> > 'sudo ndiswrapper –i [location of the .inf file]'
> >
> > 'echo ndiswrapper | sudo tee -a /etc/modules && sudo modprobe
> > ndiswrapper'
> >
> > --
> > jockey-gtk crashed with NameError in enabled()
> > https://bugs.launchpad.net/bugs/203958
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> >
> > Status in Source Package "jockey" in Ubuntu: Fix Released
> >
> > Bug description:
> > - Release:
> >
> > DISTRIB_ID=Ubuntu
> > DISTRIB_RELEASE=8.04
> > DISTRIB_CODENAME=hardy
> > DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)
> >
> > - Source package: jockey-gtk
> >
> > - Version: 0.3.2-0ubuntu2
> >
> > It is crashed on system boot, unfortunately I was not able to understand
> > the reason ... I hope that the information posted can be helpful ...
> > Thanks!
> >
> > ProblemType: Crash
> > Architecture: i386
> > Date: Wed Mar 19 17:25:19 2008
> > DistroRelease: Ubuntu 8.04
> > ExecutablePath: /usr/bin/jockey-gtk
> > InterpreterPath: /usr/bin/python2.5
> > Package: jockey-gtk 0.3.2-0ubuntu2
> > PackageArchitecture: all
> > ProcCmdline: /usr/bin/python /usr/bin/jockey-gtk --check 60
> > ProcEnviron:
> >
> >
> PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
> > LANG=it_IT.UTF-8
> > SHELL=/bin/bash
> > PythonArgs: ['/usr/bin/jockey-gtk', '--check', '60']
> > SourcePackage: jockey
> > Title: jockey-gtk crashed with NameError in enabled()
> > Uname: Linux 2.6.24-12-generic i686
> > UserGroups: adm admin audio cdrom dialout dip fax floppy fuse lpadmin
> > netdev plugdev powerdev scanner tape vboxusers video
> >
>
>
> ** Attachment added: "unnamed"
> http://launchpadlibrarian.net/13547352/unnamed
>
> --
> jockey-gtk crashed with NameError in enabled()
> https://bugs.launchpad.net/bugs/203958
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Source Package "jockey" in Ubuntu: Fix R...

Read more...

amazing
i bought 1 apple laptop from this company
now i had receive it , i like it very much
they also have thousands of new original products
hope you like it too
will save more than 30% !!
have a look , sure you will like it
<mmwwt.com>
enjoy yourself here

dear friend
i would like to tell you a very good place
i like it much , with the fast shipping , best service
sure you will like it too
you can find what you like on their site
: <wwmmt.com>
just try , it is very good

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers