Ubuntu

Jockey isn't used from Visual Effects tab

Reported by Scott James Remnant (Canonical) on 2008-02-21
4
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Undecided
Sebastien Bacher
jockey (Ubuntu)
Undecided
Martin Pitt

Bug Description

When I enable Visual Effects on this NVIDIA-based laptop, jockey isn't being used, so the driver isn't installed and changed, etc.

<pitti> ah, we probably need to update it for jockey
 it still calls restricted-manager --check-composite, I figure

Changed in jockey:
milestone: none → ubuntu-8.04-beta
assignee: nobody → pitti
Martin Pitt (pitti) wrote :

g-c-c should just do s/restricted-manager/jockey-gtk/. I'll re-add the --check-composite switch to jockey.

Changed in gnome-control-center:
status: New → Confirmed
Changed in jockey:
status: New → Confirmed
Martin Pitt (pitti) wrote :

Seb kindly agreed to incorporate this patch into the pending g-c-c upload.

Changed in gnome-control-center:
assignee: nobody → seb128
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:2.21.92-0ubuntu2

---------------
gnome-control-center (1:2.21.92-0ubuntu2) hardy; urgency=low

  * debian/control.in:
    - recommends mousetweaks (lp: #190554)
  * debian/patches/95_desktop-effects-integration.patch:
    - update the list of translatables sources (lp: #195255)
    - use jockey now (lp: #193978)

 -- Sebastien Bacher <email address hidden> Mon, 03 Mar 2008 16:59:11 +0100

Changed in gnome-control-center:
status: Confirmed → Fix Released
Martin Pitt (pitti) wrote :

Fixed in trunk bzr head.

Changed in jockey:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.3-0ubuntu1

---------------
jockey (0.3-0ubuntu1) hardy; urgency=low

  * Merge with trunk to update to the 0.3 release. We already had all the new
    features like the KDE interface, so this only imports bug fixes, in
    particular:
    - Update fglrx handler for current upstream version, to actually work
      again at all (DisplayDepth) and declare support for composite. Thanks to
      Sander Jonkes! (LP: #194963)
    - Quiesce backtraces from failed handler instantiation. (LP: #195548)
    - Use regular expressions, not fnmatch for modalias pattern matching,
      since we do not want to treat '[' and ']' specially. (LP: #193521)
    - Port --enable and --disable options from restricted-manager.
      (LP: #181832)
    - Port --check-composite from restricted-manager. (LP: #193978)
  * Fixed Vcs-Bzr field.
  * Remove do-release from this branch, it's only useful for upstream
    developers on trunk and confusing in the package.
  * debian/jockey-common.postinst: Remove --check cache on upgrade from
    << 0.3, since the format changed (much more robust now).

 -- Martin Pitt <email address hidden> Tue, 04 Mar 2008 16:48:50 +0100

Changed in jockey:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers