jockey-text crashes with AttributeError - clean up jockey in upgrades to trusty

Bug #1216193 reported by Ian Nicholson on 2013-08-24
136
This bug affects 25 people
Affects Status Importance Assigned to Milestone
jockey (Ubuntu)
High
Unassigned
ubuntu-drivers-common (Ubuntu)
Medium
Martin Pitt

Bug Description

Running jockey-text either as an unpriviledged user or as root results in the following error:

Traceback (most recent call last):
  File "/usr/bin/jockey-text", line 20, in <module>
    import jockey.ui
  File "/usr/lib/python2.7/dist-packages/jockey/ui.py", line 36, in <module>
    from jockey.oslib import OSLib
  File "/usr/lib/python2.7/dist-packages/jockey/oslib.py", line 27, in <module>
    class _CapturedInstallProgress(apt.InstallProgress):
AttributeError: 'module' object has no attribute 'InstallProgress'

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: jockey-common 0.9.7-0ubuntu13
ProcVersionSignature: Ubuntu 3.11.0-3.8-generic 3.11.0-rc6
Uname: Linux 3.11.0-3-generic x86_64
ApportVersion: 2.12.1-0ubuntu2
Architecture: amd64
Date: Fri Aug 23 22:47:28 2013
EcryptfsInUse: Yes
InstallationDate: Installed on 2013-08-09 (15 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MachineType: TOSHIBA Satellite L875D
MarkForUpload: True
PackageArchitecture: all
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.11.0-3-generic root=/dev/mapper/ubuntu--vg-root ro i8042.nomux=1 i8042.reset quiet splash
SourcePackage: jockey
UpgradeStatus: Upgraded to saucy on 2013-08-09 (15 days ago)
dmi.bios.date: 12/06/2012
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: 6.30
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: PLCSC8
dmi.board.vendor: AMD
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: OEM Chassis Manufacturer
dmi.chassis.version: OEM Chassis Version
dmi.modalias: dmi:bvnInsydeCorp.:bvr6.30:bd12/06/2012:svnTOSHIBA:pnSatelliteL875D:pvrPSKFQU-003034:rvnAMD:rnPLCSC8:rvrBaseBoardVersion:cvnOEMChassisManufacturer:ct10:cvrOEMChassisVersion:
dmi.product.name: Satellite L875D
dmi.product.version: PSKFQU-003034
dmi.sys.vendor: TOSHIBA

Ian Nicholson (imnichol) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in jockey (Ubuntu):
status: New → Confirmed
Changed in jockey (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Martin Pitt (pitti) wrote :

jockey has been removed from Ubuntu 14.04 at last. It's been deprecated in favor of ubuntu-drivers-common and software-properties (KDE has a GUI for it now, too). It should just be removed during dist-upgrade.

summary: - jockey-text crashes with AttributeError: 'module' object has no
- attribute 'InstallProgress'
+ jockey-text crashes with AttributeError - clean up jockey in upgrades to
+ trusty
Changed in jockey (Ubuntu):
status: Triaged → Invalid
Martin Pitt (pitti) wrote :

I uploaded a new u-d-common which should remove jockey on upgrades.

Changed in ubuntu-drivers-common (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → Medium
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-drivers-common - 1:0.2.91.4

---------------
ubuntu-drivers-common (1:0.2.91.4) trusty; urgency=medium

  * Force removal of jockey on upgrades. It has been replaced with
    ubuntu-drivers-common two cycles ago, removed from trusty, and now just
    crashes due to API changes in aptdaemon. (LP: #1216193)
 -- Martin Pitt <email address hidden> Sun, 13 Apr 2014 13:31:11 +0200

Changed in ubuntu-drivers-common (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers