Ubuntu

Jockey should install the linux-$flavour metapackage

Reported by Alberto Milone on 2013-02-12
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
jockey (Ubuntu)
High
Alberto Milone
Precise
Undecided
Alberto Milone
software-properties (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Alberto Milone
ubuntu-drivers-common (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Alberto Milone

Bug Description

Neither binary graphics drivers nor dkms depends on the linux-headers any longer. This means that we need Jockey to at least try to install the correct linux-$flavour metapackage so that users get the correct linux headers together with linux updates.

In raring we already do this in ubuntu-drivers-common and software-properties-gtk. In precise we could build upon what we have thanks to LP: #567699 and reuse the code from u-d-c.

Note: while it's true that Ubiquity already does the right thing, this bug report aims to cover cases in which, for example, the metapackages are not there any more for some reason or because users have installed a different kernel flavour

Changed in jockey (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Alberto Milone (albertomilone)
description: updated
Alberto Milone (albertomilone) wrote :

SRU request:

Please accept jockey into precise-proposed. The new code is all covered by the test suite and is a backport of what we already do in raring.

Changed in jockey (Ubuntu):
status: In Progress → Fix Committed
Adam Conrad (adconrad) on 2013-02-22
Changed in ubuntu-drivers-common (Ubuntu):
status: New → Fix Released
Changed in jockey (Ubuntu Quantal):
status: New → Invalid
Changed in ubuntu-drivers-common (Ubuntu Precise):
status: New → Invalid
Changed in jockey (Ubuntu Precise):
status: New → In Progress
Changed in software-properties (Ubuntu Precise):
status: New → Invalid
Changed in software-properties (Ubuntu Quantal):
assignee: nobody → Alberto Milone (albertomilone)
Changed in ubuntu-drivers-common (Ubuntu Quantal):
assignee: nobody → Alberto Milone (albertomilone)
Changed in software-properties (Ubuntu Quantal):
status: New → In Progress
Changed in ubuntu-drivers-common (Ubuntu Quantal):
status: New → In Progress

Hello Alberto, or anyone else affected,

Accepted jockey into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/jockey/0.9.7-0ubuntu7.8 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in jockey (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Alberto Milone (albertomilone) wrote :

Please also accept ubuntu-drivers-common (1:0.2.71.2) and software-properties (0.92.9.1) in quantal-proposed for the Quantal task.

Brian Murray (brian-murray) wrote :

Hello Alberto, or anyone else affected,

Accepted ubuntu-drivers-common into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ubuntu-drivers-common/1:0.2.71.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntu-drivers-common (Ubuntu Quantal):
status: In Progress → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Alberto, or anyone else affected,

Accepted software-properties into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/software-properties/0.92.9.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in software-properties (Ubuntu Quantal):
status: In Progress → Fix Committed
Brian Murray (brian-murray) wrote :

Reviewing error reports about jockey it appears that the version of jockey in precise-proposed has introduced a regression as seen at:

https://errors.ubuntu.com/bucket/?id=/usr/share/jockey/jockey-backend%3AKeyError%3A/usr/share/jockey/jockey-backend%4066%3A__init__%3Aget_linux_metapackage%3A_get_linux_metapackage%3A__getitem__

The traceback follows:

Traceback (most recent call last):
  File "/usr/share/jockey/jockey-backend", line 66, in <module>
    OSLib.inst = OSLib(target_kernel=argv_options.kernel)
  File "/usr/lib/python2.7/dist-packages/jockey/oslib.py", line 131, in __init__
    self.kernel_header_package = kernel_detection.get_linux_metapackage()
  File "/usr/lib/python2.7/dist-packages/jockey/kerneldetection.py", line 112, in get_linux_metapackage
    return self._get_linux_metapackage(False)
  File "/usr/lib/python2.7/dist-packages/jockey/kerneldetection.py", line 75, in _get_linux_metapackage
    record['Source']
  File "/usr/lib/python2.7/dist-packages/apt/package.py", line 195, in __getitem__
    return self._rec[key]
KeyError: 'Source'

Brian Murray (brian-murray) wrote :

For what it is worth there is not a similar crash from ubuntu-drivers-common in Quantal or Raring.

tags: added: verification-failed
removed: verification-needed
Alberto Milone (albertomilone) wrote :

This shouldn't really happen. I wish I had more details as to how I can reproduce it. I'll try to reproduce it here and, if I can't, I'll simply make sure that Jockey doesn't crash when it fails to retrieve that specific bit of information from APT.

Changed in jockey (Ubuntu Precise):
assignee: nobody → Alberto Milone (albertomilone)
no longer affects: jockey (Ubuntu Quantal)
no longer affects: software-properties (Ubuntu Precise)
no longer affects: ubuntu-drivers-common (Ubuntu Precise)
Changed in jockey (Ubuntu Precise):
status: Fix Committed → In Progress
Alberto Milone (albertomilone) wrote :

I've just uploaded a fix in precise-proposed (0.9.7-0ubuntu7.9) and I've added two test cases for this specific bug. Please accept it into proposed.

Changed in jockey (Ubuntu Precise):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-properties (Ubuntu):
status: New → Confirmed
Brian Murray (brian-murray) wrote :

Hello Alberto, or anyone else affected,

Accepted jockey into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/jockey/0.9.7-0ubuntu7.9 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-failed
tags: added: verification-needed
Alberto Milone (albertomilone) wrote :

I can confirm that 0.9.7-0ubuntu7.9 works correctly. I thought this had already made it into -updates. Please approve it ASAP.

tags: added: verification-done-precise
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.9.7-0ubuntu7.9

---------------
jockey (0.9.7-0ubuntu7.9) precise-proposed; urgency=low

  * jockey/kerneldetection.py:
    - Catch KeyError in get_linux_metapackage() (LP: #1123107).
      Sometimes the "Source" key is not available.
  * tests/kerneldetection.py:
    - Add two tests to make sure that get_linux_metapackage()
      doesn't raise a KeyError when dealing with packages
      without a "Source" field and that the function doesn't
      stop if one or two packages don't have the said field.
 -- Alberto Milone <email address hidden> Tue, 16 Apr 2013 11:19:02 +0200

Changed in jockey (Ubuntu Precise):
status: Fix Committed → Fix Released
Steve Langasek (vorlon) wrote :

This SRU has remained unverified after 247 days in the -proposed queue. I've removed it now from quantal-proposed and am marking the task 'wontfix'.

Changed in ubuntu-drivers-common (Ubuntu Quantal):
status: Fix Committed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers