Comment 0 for bug 1080588

Maarten Lankhorst (mlankhorst) wrote :

None of the nvidia and fglrx drivers can be installed through the gui, because they have a versioned depends on xserver-xorg-core.

For example:

# LANG=C apt-get install nvidia-experimental-304
The following packages have unmet dependencies:
 nvidia-experimental-304 : Depends: xserver-xorg-core (>= 2:1.10.99.901)
E: Unable to correct problems, you have held broken packages.

Furthermore even some packages are shown that cannot be installed on the renamed x server, because the drivers haven't been updated to work on them. For example nvidia-current:

 nvidia-current : Depends: xorg-video-abi-11
                  Depends: xserver-xorg-core (>= 2:1.10.99.901)
E: Unable to correct problems, you have held broken packages.

nvidia-common needs to be updated to hide versions of nvidia drivers that won't work on x 1.13 or later, and make them installable.
I think the xserver-xorg-core version check can be removed, in favor of checking the video abi version.