jockey suggests not installable packages on renamed stack

Bug #1080588 reported by Maarten Lankhorst on 2012-11-19
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
High
James M. Leddy
Precise
High
James M. Leddy
fglrx-installer-experimental-9 (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
fglrx-installer-updates (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
jockey (Ubuntu)
High
Alberto Milone
Precise
High
Alberto Milone
nvidia-graphics-drivers-173-updates (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
nvidia-graphics-drivers-experimental-310 (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
nvidia-graphics-drivers-updates (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

[Impact]

 * Users of the quantal lts backport stack on precise will not be able to install nvidia
   drivers
 * This is because we have not renamed these drivers with the proper changed package
   names in the nvidia drivers

[Test Case]

# LANG=C apt-get install nvidia-experimental-304
The following packages have unmet dependencies:
 nvidia-experimental-304 : Depends: xserver-xorg-core (>= 2:1.10.99.901)
E: Unable to correct problems, you have held broken packages.

[Regression Potential]

Low. The backports stack is new functionality that is coming in 12.04.2, so changes that affect this will have no impact on earlier versions of 12.04

[Original Text]

None of the nvidia and fglrx drivers can be installed through the gui, because they have a versioned depends on xserver-xorg-core.

For example:

# LANG=C apt-get install nvidia-experimental-304
The following packages have unmet dependencies:
 nvidia-experimental-304 : Depends: xserver-xorg-core (>= 2:1.10.99.901)
E: Unable to correct problems, you have held broken packages.

Furthermore even some packages are shown that cannot be installed on the renamed x server, because the drivers haven't been updated to work on them. For example nvidia-current:

 nvidia-current : Depends: xorg-video-abi-11
                  Depends: xserver-xorg-core (>= 2:1.10.99.901)
E: Unable to correct problems, you have held broken packages.

nvidia-common needs to be updated to hide versions of nvidia drivers that won't work on x 1.13 or later, and make them installable.
I think the xserver-xorg-core version check can be removed, in favor of checking the video abi version.

Furthermore drivers should have an alternative dependency on the new xserver

Changed in nvidia-common (Ubuntu):
status: New → Triaged
importance: Undecided → High
Changed in nvidia-common (Ubuntu):
status: Triaged → In Progress
affects: nvidia-common (Ubuntu) → jockey (Ubuntu)
Changed in jockey (Ubuntu):
importance: High → Undecided
status: In Progress → New
status: New → In Progress
importance: Undecided → High
description: updated
Changed in fglrx-installer-updates (Ubuntu):
status: New → In Progress
Changed in nvidia-graphics-drivers-experimental-310 (Ubuntu):
status: New → In Progress
Changed in nvidia-graphics-drivers-updates (Ubuntu):
status: New → In Progress
Alberto Milone (albertomilone) wrote :

SRU request:

please accept the following packages so that 1) Jockey doesn't allow incompatible drivers to be installed with the new X stack 2) some drivers can have support for the new X stack:

jockey (0.9.7-0ubuntu7.6)
fglrx-installer-experimental-9 (2:9.010-0ubuntu0.2)
fglrx-installer-updates (2:9.000-0ubuntu0.3)
nvidia-graphics-drivers-experimental-310 (310.14-0ubuntu0.3)
nvidia-graphics-drivers-updates (304.64-0ubuntu0.2)

Hello Maarten, or anyone else affected,

Accepted jockey into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/jockey/0.9.7-0ubuntu7.6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Stefan Bader (smb) wrote :

After upgrading to the proposed version "jockey-text -l" (for example) starts failing for me. The 0.9.7-0ubuntu7.4 version does work.

tags: added: verification-failed
removed: verification-needed
Download full text (3.2 KiB)

.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu15
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
DistUpgraded: 2012-02-24 11:29:43,553 DEBUG enabling apt cron job
DistroCodename: precise
DistroRelease: Ubuntu 12.04
DistroVariant: ubuntu
DkmsStatus:
 fglrx-updates, 9.000, 3.2.0-34-generic, x86_64: installed
 virtualbox, 4.1.12, 3.2.0-33-generic, x86_64: installed
 virtualbox, 4.1.12, 3.2.0-34-generic, x86_64: installed
EcryptfsInUse: Yes
GraphicsCard:
 Advanced Micro Devices [AMD] nee ATI Cedar PRO [Radeon HD 5450] [1002:68f9] (prog-if 00 [VGA controller])
   Subsystem: PC Partner Limited Device [174b:e157]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110426)
JockeyStatus:
 kmod:fglrx_experimental_9 - Experimental AMD binary Xorg driver and kernel module (Proprietary, Disabled, Not in use)
 xorg:fglrx - ATI/AMD proprietary FGLRX graphics driver (Proprietary, Disabled, Not in use)
 xorg:fglrx_updates - ATI/AMD proprietary FGLRX graphics driver (post-release updates) (Proprietary, Disabled, Not in use)
MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
MarkForUpload: True
NonfreeKernelModules: fglrx
Package: nvidia-graphics-drivers-updates (not installed)
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-34-generic root=UUID=2eab68c5-c6fa-405d-a360-1f6f1690bbb3 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-34.53-generic 3.2.33
Tags: precise running-unity precise running-unity ubuntu referred-by-support compiz-0.9
Uname: Linux 3.2.0-34-generic x86_64
UpgradeStatus: Upgraded to precise on 2012-02-24 (272 days ago)
UserGroups: adm admin cdrom chroot dialout floppy libvirtd lp lpadmin plugdev sambashare sbuild sudo video
dmi.bios.date: 12/21/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P2.00
dmi.board.name: M3A-GLAN
dmi.board.vendor: ASRock
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP2.00:bd12/21/2010:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnM3A-GLAN:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.
version.compiz: compiz 1:0.9.7.8-0ubuntu1.4
version.fglrx-installer: fglrx-installer N/A
version.ia32-libs: ia32-libs 20090808ubuntu36
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.4-0ubuntu0.2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.4-0ubuntu0.2
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10.8
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1.2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-int...

Read more...

tags: added: apport-collected compiz-0.9 precise referred-by-support running-unity ubuntu

apport information

apport information

Stefan Bader (smb) wrote : BootLog.gz

apport information

apport information

apport information

apport information

apport information

apport information

Stefan Bader (smb) wrote : Lspci.txt

apport information

Stefan Bader (smb) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Alberto Milone (albertomilone) wrote :

ok, I've uploaded jockey_0.9.7-0ubuntu7.7 which should fix the problem mentioned by Stefan

Stefan Bader (smb) wrote :

While I did not find the package uploaded to proposed, yet, I took the packages from the link posted in PM and can confirm that it fixes the regression I saw.

Sebastien Bacher (seb128) wrote :

(restoring the tag until the new version which is in the queue is approved by the SRU team...)

tags: added: verification-needed
removed: verification-failed
tags: added: verification-failed
removed: verification-needed
Steve Langasek (vorlon) wrote :

The fglrx-updates package in the queue addresses the dependencies like so:

--- fglrx-installer-updates-9.000/debian/substvars 2012-10-16 15:04:48.000000000 +0000
+++ fglrx-installer-updates-9.000/debian/substvars 2012-11-21 13:48:00.000000000 +0000
@@ -1,2 +1,2 @@
-xviddriver:Depends=xorg-video-abi-11|xorg-video-abi-12|xorg-video-abi-13, xserver-xorg-core (>= 2:1.10.99.901)
+xviddriver:Depends=xorg-video-abi-11|xorg-video-abi-12|xorg-video-abi-13, xserver-xorg-core (>= 2:1.10.99.901)|xserver-xorg-core-lts-quantal (>= 2:1.10.99.901)
 xviddriver:Provides=xorg-driver-video

This is ok, but I think it would have been better to drop the versioned dependency on xserver-xorg-core as suggested in the bug report. oneiric's xserver-xorg-core has a Provides of xorg-video-abi-10, so there's no actual risk of a too-old xserver-xorg-core being pulled in together with fglrx; and by hard-coding xserver-xorg-core | xserver-xorg-core-lts-quantal, you ensure that this will have to be updated again for the next enablement stack in 12.04.3.

Steve Langasek (vorlon) wrote :

BTW, Alberto, please note that fglrx-installer-updates (and probably other packages here) is currently blocked from being accepted into precise-proposed by an existing SRU which is still pending verification (2:9.000-0ubuntu0.1). If you think this needs to be pushed to -proposed before the existing SRU is verified, please reupload with -v2:8.960-0ubuntu1.1 and contact a member of the SRU team directly to have this accepted.

Chris Halse Rogers (raof) wrote :

Alberto - I've rejected the jockey 0.9.7-0ubuntu7.7 upload. The .changes file needs to include the entries for ubuntu7.6 as well.

Additionally - please don't reformat code in SRU uploads. It makes it hard to tell what the active change is.

Colin Watson (cjwatson) on 2013-01-03
Changed in fglrx-installer-updates (Ubuntu Precise):
status: New → In Progress
Changed in jockey (Ubuntu Precise):
status: New → In Progress
Changed in nvidia-graphics-drivers-experimental-310 (Ubuntu Precise):
status: New → In Progress
Changed in nvidia-graphics-drivers-updates (Ubuntu Precise):
status: New → In Progress
Changed in jockey (Ubuntu Precise):
importance: Undecided → High
assignee: nobody → Alberto Milone (albertomilone)
milestone: none → ubuntu-12.04.2
Changed in jockey (Ubuntu):
milestone: ubuntu-12.04.2 → none
Timo Aaltonen (tjaalton) wrote :

The old fglrx-installer-updates version doesn't support the new xserver abi, so the new stack needs at least 9.000. Because of that there's little point in uploading the old version with this change.

Alberto Milone (albertomilone) wrote :

Thanks for reviewing my work, I'll make sure it's fixed soon.

Timo Aaltonen (tjaalton) on 2013-01-07
Changed in fglrx-installer-experimental-9 (Ubuntu Precise):
status: New → In Progress
Timo Aaltonen (tjaalton) wrote :

I've uploaded fglrx-* on jan 3rd, but they're held until the other sru bugs are verified

Hello Maarten, or anyone else affected,

Accepted nvidia-graphics-drivers-173-updates into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-173-updates/173.14.36-0ubuntu0.0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-failed
tags: added: verification-needed
Changed in oem-priority:
status: New → In Progress
assignee: nobody → James M. Leddy (jm-leddy)
Changed in nvidia-graphics-drivers-173-updates (Ubuntu):
status: New → In Progress
Changed in nvidia-graphics-drivers-173-updates (Ubuntu Precise):
status: New → Fix Committed
Changed in oem-priority:
importance: Undecided → High
description: updated
Steve Langasek (vorlon) wrote :

Hello Maarten, or anyone else affected,

Accepted jockey into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/jockey/0.9.7-0ubuntu7.7 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in jockey (Ubuntu Precise):
status: In Progress → Fix Committed
Steve Langasek (vorlon) wrote :

Hello Maarten, or anyone else affected,

Accepted fglrx-installer-updates into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/fglrx-installer-updates/2:9.000-0ubuntu0.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in fglrx-installer-updates (Ubuntu Precise):
status: In Progress → Fix Committed
Maarten Lankhorst (mlankhorst) wrote :

I only tested installability, and fglrx-installer-updates/nvidia-173 install like they should. I can't test jockey yet without the nvidia driver updates.

Adam Conrad (adconrad) wrote :

Hello Maarten, or anyone else affected,

Accepted fglrx-installer-experimental-9 into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/fglrx-installer-experimental-9/2:9.010-0ubuntu0.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in fglrx-installer-experimental-9 (Ubuntu Precise):
status: In Progress → Fix Committed
Changed in nvidia-graphics-drivers-updates (Ubuntu Precise):
status: In Progress → Fix Committed
Adam Conrad (adconrad) wrote :

Hello Maarten, or anyone else affected,

Accepted nvidia-graphics-drivers-updates into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-updates/304.64-0ubuntu0.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nvidia-graphics-drivers-experimental-310 (Ubuntu Precise):
status: In Progress → Fix Committed
Adam Conrad (adconrad) wrote :

Hello Maarten, or anyone else affected,

Accepted nvidia-graphics-drivers-experimental-310 into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-experimental-310/310.14-0ubuntu0.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Robert Hooker (sarvatt) wrote :

Results from a fully updated 12.04.2 install using the X backports stack (xserver-xorg-core-lts-quantal 2:1.13.0-0ubuntu6.1~precise2) with proposed enabled:

ii nvidia-experimental-310 310.14-0ubuntu0.3
Installed fine, verified

ii nvidia-current-updates 304.64-0ubuntu0.2
Installed fine, verified

ii fglrx-experimental-9 2:9.010-0ubuntu0.3
Installed fine, verified

ii fglrx-updates 2:9.000-0ubuntu0.3
Installed fine, verified

ii nvidia-173-updates 173.14.36-0ubuntu0.0.1
Installed fine, verified

tags: added: verification-done
removed: verification-needed
Steve Langasek (vorlon) wrote :

Per Bryce, having the updated versions of the driver packages in -updates without the updated jockey introduces the possibility of wrong drivers being presented that will break the system. So since this SRU has been verified, I'm publishing the new jockey to precise-updates now even though it's only 3 days old. My understanding is that it's safe for the jockey package to be accepted into -updates before the second round of driver packages are accepted.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.9.7-0ubuntu7.7

---------------
jockey (0.9.7-0ubuntu7.7) precise-proposed; urgency=low

  * data/handlers/fglrx.py:
    - Fix typo which caused the handler to fail (LP: #1080588).

jockey (0.9.7-0ubuntu7.6) precise-proposed; urgency=low

  * jockey/oslib.py, jockey/xorg_driver.py:
    - Add some checks for quantal's backported xserver so as not to
      provide drivers which don't support it (LP: #1080588).
  * data/handlers/fglrx.py:
    - Make sure to mark the experimental driver as such (LP: #1078290).
    - Always pass "fglrx" to get the alternative name or jockey will
      fail to set the correct alternative.

jockey (0.9.7-0ubuntu7.5) precise-proposed; urgency=low

  * data/handlers/fglrx.py:
    - Add support for the experimental-9 flavour (LP: #1078290).
 -- Alberto Milone <email address hidden> Mon, 07 Jan 2013 10:55:32 +0100

Changed in jockey (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer-updates - 2:9.000-0ubuntu0.3

---------------
fglrx-installer-updates (2:9.000-0ubuntu0.3) precise-proposed; urgency=low

  * debian/control:
    - Drop all the dependencies on the linux-headers (LP: #1080588).
  * debian/substvars:
    - Add an alternative dependency on xserver-xorg-core-lts-quantal
      (LP: #1080588).

fglrx-installer-updates (2:9.000-0ubuntu0.2) precise-proposed; urgency=low

  * debian/dkms.conf.in,
    replace-VM_RESERVED-with-VM_DONTEXPAND-and-VM_DONTDU.patch:
    - Add support for Linux 3.7 (LP: #1075937).
 -- Alberto Milone <email address hidden> Thu, 17 Jan 2013 12:42:50 +0100

Changed in fglrx-installer-updates (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-173-updates - 173.14.36-0ubuntu0.0.1

---------------
nvidia-graphics-drivers-173-updates (173.14.36-0ubuntu0.0.1) precise-proposed; urgency=low

  * New upstream release:
    - Added support for xserver ABI 13 (xorg-server 1.13)
      (LP: #1064192).
  * debian/substvars:
    - Add an alternative dependency on xserver-xorg-core-lts-quantal
      (LP: #1080588).
  * Add support for Linux 3.7.
 -- Alberto Milone <email address hidden> Thu, 22 Nov 2012 18:22:17 +0100

Changed in nvidia-graphics-drivers-173-updates (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-experimental-310 - 310.14-0ubuntu0.3

---------------
nvidia-graphics-drivers-experimental-310 (310.14-0ubuntu0.3) precise-proposed; urgency=low

  * debian/control{.in}:
    - Drop all the dependencies on the linux-headers (LP: #1080588).
  * debian/substvars:
    - Add an alternative dependency on xserver-xorg-core-lts-quantal
      (LP: #1080588).
  * Replace the old patches for Linux 3.7 with buildfix_kernel_3.7.patch.
 -- Alberto Milone <email address hidden> Thu, 17 Jan 2013 11:46:21 +0100

Changed in nvidia-graphics-drivers-experimental-310 (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer-experimental-9 - 2:9.010-0ubuntu0.3

---------------
fglrx-installer-experimental-9 (2:9.010-0ubuntu0.3) precise-proposed; urgency=low

  * debian/control{.in}:
    - Drop all the dependencies on the linux-headers (LP: #1080588).
  * debian/rules:
    - Remove the watermark from the driver (LP: #1083544).
  * debian/substvars:
    - Remove versioned dependency on the xserver (LP: #1080588).

fglrx-installer-experimental-9 (2:9.010-0ubuntu0.2) precise-proposed; urgency=low

  * debian/substvars:
    - Add alternative dependency on xserver-xorg-core-lts-quantal (LP: #1080588).
 -- Alberto Milone <email address hidden> Fri, 25 Jan 2013 12:50:52 +0100

Changed in fglrx-installer-experimental-9 (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-updates - 304.64-0ubuntu0.2

---------------
nvidia-graphics-drivers-updates (304.64-0ubuntu0.2) precise-proposed; urgency=low

  * debian/control{.in}:
    - Drop all the dependencies on the linux-headers (LP: #1080588).
  * debian/substvars:
    - Add an alternative dependency on xserver-xorg-core-lts-quantal
      (LP: #1080588).
    - Drop versioned dependency on the xserver.
 -- Alberto Milone <email address hidden> Thu, 17 Jan 2013 12:01:32 +0100

Changed in nvidia-graphics-drivers-updates (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in oem-priority:
status: In Progress → Fix Released
Maarten Lankhorst (mlankhorst) wrote :

Marking invalid since it's not a problem upstream, just on precise.

Changed in fglrx-installer-experimental-9 (Ubuntu):
status: New → Invalid
Changed in fglrx-installer-updates (Ubuntu):
status: In Progress → Invalid
Changed in jockey (Ubuntu):
status: In Progress → Invalid
Changed in nvidia-graphics-drivers-173-updates (Ubuntu):
status: In Progress → Invalid
Changed in nvidia-graphics-drivers-experimental-310 (Ubuntu):
status: In Progress → Invalid
Changed in nvidia-graphics-drivers-updates (Ubuntu):
status: In Progress → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers