Add package fglrx-experimental for tracking fglrx beta drivers

Bug #1078290 reported by Alberto Milone on 2012-11-13
76
This bug affects 14 people
Affects Status Importance Assigned to Milestone
fglrx-installer-experimental-9 (Ubuntu)
High
Alberto Milone
Precise
High
Alberto Milone
jockey (Ubuntu)
High
Unassigned
Precise
High
Alberto Milone

Bug Description

[Impact]
AMD posts beta versions of their drivers to be tested over several weeks. These drivers usually include important features and fixes but also sometimes include known issues or regressions that make them unsuitable or too risky for us to consider inclusion in the fglrx-updates package.

However certain commercial Linux games require features/fixes present only in these AMD beta drivers at the time of their release. Ubuntu users who purchase these games currently have to manually install the beta driver (or wait a month or two for it to appear in -updates). Providing these drivers via fglrx-experimental will enable them to install and run the game within the Ubuntu packaging system.

[Fix]
The fglrx-experimental-NNN binary package is established (provided by the fglrx-installer-experimental source package) for quantal 12.10 and precise 12.04. This uses the packaging scripts from fglrx-updates, with the renamed package and new .run files.

The fglrx-experimental-NNN package will be visible to users via Jockey as normal. When a user installs the experimental package, any other fglrx drivers will be disabled. They will remain on the selected fglrx-experimental-NNN until they upgrade to a new Ubuntu release or LTS point release, at which point they'll be returned to fglrx-current. They can of course manually switch from fglrx-experimental-NNN back to fglrx or fglrx-updates (or some newer fglrx-experimental-MMM) if they wish.

The control file for the experimental package proposed for precise has some differences from the one in quantal, and also has some differences against the non-experimental fglrx driver in precise. Here is an explanation of those differences in turn:

* Conflicts/Replaces on fglrx-*-modaliases (from precise's fglrx package) are no longer needed. The modaliases packages were used in previous releases but no longer exist in precise. Since people can't upgrade from those previous versions directly to fglrx*experimental, there is no need to have Conflicts/Replaces.

* Conflicts/Replaces/Provides of various nvidia/fglrx packages (from quantal's fglrx-experimental package) are only needed for quantal forward. These are required by the new restricted drivers UI in quantal. Since that UI is not in precise, we don't need it in precise.

[Regression Potential]
The reason we're adding this package in the first place is because of concerns that beta drivers will have a high risk of regressions. Thus, users need to be aware they are taking these risks when they opt-in to the driver.

As mentioned above, fglrx and fglrx-updates will still be available to them in case they have problems. In a worst case scenario they may need to do this from a recovery session.

Changed in jockey (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → High
status: New → In Progress
Changed in jockey (Ubuntu Quantal):
status: New → Invalid
Changed in jockey (Ubuntu Raring):
status: In Progress → Invalid
Changed in jockey (Ubuntu Precise):
assignee: nobody → Alberto Milone (albertomilone)
status: New → In Progress
importance: Undecided → High
Changed in fglrx-installer (Ubuntu Quantal):
assignee: nobody → Alberto Milone (albertomilone)
Changed in fglrx-installer (Ubuntu Precise):
assignee: nobody → Alberto Milone (albertomilone)
status: New → In Progress
Changed in fglrx-installer (Ubuntu Quantal):
status: New → In Progress
Changed in fglrx-installer (Ubuntu Precise):
importance: Undecided → High
Changed in fglrx-installer (Ubuntu Quantal):
importance: Undecided → High
Changed in jockey (Ubuntu Raring):
assignee: Alberto Milone (albertomilone) → nobody
Bryce Harrington (bryce) on 2012-11-15
Changed in fglrx-installer-experimental-9 (Ubuntu Precise):
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → High
status: New → In Progress

Hello Alberto, or anyone else affected,

Accepted jockey into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/jockey/0.9.7-0ubuntu7.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in jockey (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Adam Conrad (adconrad) wrote :

Hello Alberto, or anyone else affected,

Accepted jockey into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/jockey/0.9.7-0ubuntu7.6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fglrx-installer-experimental-9 (Ubuntu Quantal):
status: New → Confirmed
Changed in fglrx-installer-experimental-9 (Ubuntu):
status: New → Confirmed
Changed in fglrx-installer-experimental-9 (Ubuntu Quantal):
assignee: nobody → Alberto Milone (albertomilone)
Changed in fglrx-installer-experimental-9 (Ubuntu Raring):
assignee: nobody → Alberto Milone (albertomilone)
Nick Andrik (andrikos) wrote :

Alberto, do you need help on this?
I keep building packages from the beta drivers as they come out, so I would be happy to contribute to this.

Timo Jyrinki (timo-jyrinki) wrote :

Putting back to Confirmed, as the SRU failed to verify. Please upload a fixed version. bug #1080588 indicates that the 7.7 upload needs to have the 7.6 changelog entry added.

Changed in jockey (Ubuntu Precise):
status: Fix Committed → Confirmed
Florian W. (florian-will) wrote :

AFAICT, this *-experimental package was uploaded to precise-proposed, but not to quantal-proposed.

I'd like to be able to use this driver on quantal without manually installing it from AMD's web page. The bug description for this bug also states that the package was meant to be available for quantal and precise.

So as a quantal user, I'd vote for "verification-failed" unless the package shows up in quantal-proposed as well. :-)

Florian W. (florian-will) wrote :

This is probably no longer required, because AMD released a stable Catalyst 13.1 yesterday. So now waiting for it to hit fglrx-updates.

Steve Langasek (vorlon) wrote :

Hello Alberto, or anyone else affected,

Accepted jockey into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/jockey/0.9.7-0ubuntu7.7 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in jockey (Ubuntu Precise):
status: Confirmed → Fix Committed
Steve Magoun (smagoun) wrote :

On a ThinkPad E435 running 12.04, I updated to jockey 0.9.7-0ubuntu7.7. I confirmed that the new version of jockey presents fglrx-experimental-9 and installs the package correctly.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer-experimental-9 - 2:9.010-0ubuntu0.1

---------------
fglrx-installer-experimental-9 (2:9.010-0ubuntu0.1) precise-proposed; urgency=low

  * Initial release (LP: #1078290).
 -- Alberto Milone <email address hidden> Tue, 13 Nov 2012 14:52:54 +0100

Changed in fglrx-installer-experimental-9 (Ubuntu Precise):
status: In Progress → Fix Released
Bryce Harrington (bryce) wrote :

I've also double-checked that after installing jockey 0.9.7-0ubuntu7.7, fglrx-experimental-9 installs cleanly and boots up to a usable Unity session. Looks good, I'll close out the jockey task as well.

no longer affects: fglrx-installer (Ubuntu)
no longer affects: fglrx-installer (Ubuntu Precise)
no longer affects: fglrx-installer (Ubuntu Quantal)
no longer affects: fglrx-installer (Ubuntu Raring)
Bryce Harrington (bryce) wrote :

Actually, I take that back. I see that jockey 0.9.7-0ubuntu7.4 is in -updates currently, but fglrx-experimental-9 won't install properly with that version of jockey. It looks like 0.9.7-0ubuntu7.5 or 0.9.7-0ubuntu7.6 are required at a minimum.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.9.7-0ubuntu7.7

---------------
jockey (0.9.7-0ubuntu7.7) precise-proposed; urgency=low

  * data/handlers/fglrx.py:
    - Fix typo which caused the handler to fail (LP: #1080588).

jockey (0.9.7-0ubuntu7.6) precise-proposed; urgency=low

  * jockey/oslib.py, jockey/xorg_driver.py:
    - Add some checks for quantal's backported xserver so as not to
      provide drivers which don't support it (LP: #1080588).
  * data/handlers/fglrx.py:
    - Make sure to mark the experimental driver as such (LP: #1078290).
    - Always pass "fglrx" to get the alternative name or jockey will
      fail to set the correct alternative.

jockey (0.9.7-0ubuntu7.5) precise-proposed; urgency=low

  * data/handlers/fglrx.py:
    - Add support for the experimental-9 flavour (LP: #1078290).
 -- Alberto Milone <email address hidden> Mon, 07 Jan 2013 10:55:32 +0100

Changed in jockey (Ubuntu Precise):
status: Fix Committed → Fix Released
Florian W. (florian-will) wrote :

A fglrx package newer than 12.10 is required in Quantal as well.

Team Fortress 2 (and potentially other Valve/Source Engine games?) appear not to work with fglrx 12.10. IMHO, fixing/releasing this for all supported Ubuntu releases should be a high priority.

Bryce Harrington (bryce) on 2013-02-05
Changed in fglrx-installer-experimental-9 (Ubuntu Quantal):
importance: Undecided → High
Changed in fglrx-installer-experimental-9 (Ubuntu Raring):
importance: Undecided → High
Changed in fglrx-installer-experimental-9 (Ubuntu Quantal):
status: Confirmed → Triaged
Changed in fglrx-installer-experimental-9 (Ubuntu Raring):
status: Confirmed → Triaged
Alberto Milone (albertomilone) wrote :

Please accept fglrx-installer-experimental-12 (2:12.100-0ubuntu0.1) in precise-proposed

no longer affects: fglrx-installer-experimental-9 (Ubuntu Quantal)
no longer affects: jockey (Ubuntu Quantal)
no longer affects: jockey (Ubuntu Raring)
no longer affects: fglrx-installer-experimental-9 (Ubuntu Raring)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers