Cannot uninstall Nvidia drivers

Bug #1062846 reported by Carla Sella on 2012-10-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
jockey (Ubuntu)
Undecided
Unassigned

Bug Description

I have Ubuntu 12.04.1 with 12.10 kernel 3.5.0-17 (installed for testing).
When I go to System Settings, Additional drivers to install Nvidia-173 drivers everything is fine.
For testing purposes I decide to uninstall Nvidia-173 drivers to try out Nvidia-current drivers.
I click on deactivate, it seem deactivated, I reboot, when I logon after reboot and go to Additional drivers I find the situation you see in screenshot1: "the driver is activated but not currently in use", but if I type lsmod in terminal you can see the driver is used, see attached lsmod.txt file.
I should expect that the file is deactivated when I reboot my PC.
This is my hardware: http://wiki.ubuntu-it.org/CarlaSella/lshw.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: jockey-gtk 0.9.7-0ubuntu7.3
ProcVersionSignature: Ubuntu 3.5.0-17.26~precise1-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu13
Architecture: amd64
CurrentDmesg: [ 25.169969] init: plymouth-stop pre-start process (1677) terminated with status 1
Date: Sat Oct 6 15:42:14 2012
ExecutablePath: /usr/bin/jockey-gtk
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
InterpreterPath: /usr/bin/python2.7
MachineType: System manufacturer System Product Name
PackageArchitecture: all
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-17-generic root=UUID=85f8c649-a0b7-4899-8b56-cf85fbe7f8e5 ro quiet splash vt.handoff=7
SourcePackage: jockey
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/28/2007
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0702
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: M2N
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0702:bd05/28/2007:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM2N:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Carla Sella (carla-sella) wrote :
Carla Sella (carla-sella) wrote :
Carla Sella (carla-sella) wrote :

Now, I'm quite sure it's a bug anymore as I clicked on the remove button, rebooted and now the dirver is uninstalled.
I'm quite sure I did this before reporting the bug and the driver was not uninstalled.
I will try again to see what happens.

Carla Sella (carla-sella) wrote :
Carla Sella (carla-sella) wrote :
Carla Sella (carla-sella) wrote :

I reinstalled the Nvidia-173 driver.
After that I removed it and rebooted.
When my PC restarted I got a message that my PC could start only in low graphics mode, and had only a terminal to logon, no desktop session.
I logged on and the output of lsmod is in the attached file lsmod3.txt where as you can see there are no graphics drivers (no nouveau a no Nvidia ones).
I ran a dpkg --list *nvidia* to find Nvidia drivers installed and as you can see in the attached nvidia.txt file, the Nvidia-173 drivers where still installed.
I had to remove them with dpkg -r and after reboot I found myself with the nouveau drivers installed.

This has happened to me quite often testing 12.10 kernel on 12.04.

Carla Sella (carla-sella) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1062846

tags: added: package-qa-testing
Carla Sella (carla-sella) wrote :

Also Nvidia-current drivers seem to not get loaded on boot see bug #101828 comment 83.

summary: - Cannot uninstall Nvidia-173 driver
+ Cannot uninstall Nvidia drivers
Carla Sella (carla-sella) wrote :

I have this problem also with kernel 3.5.0-17.28.

Carla Sella (carla-sella) wrote :

This bug has been solved, see related bug #1011828, so I'm marking it fix committed.

Changed in jockey (Ubuntu):
status: New → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers