Cannot install Nvidia video drivers using "Additional drivers" in "System settings"

Bug #1047843 reported by Carla Sella on 2012-09-08
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
jockey (Ubuntu)
Undecided
Unassigned

Bug Description

I was trying to install Nvidia-current drivers from "Additional drivers" in "System settings" but I keep on getting a message box saying: "Sorry the installation of this driver failed, Please have a look at the log file /var/log/jockey.log", see attached screenshot.
I was doing this using Ubuntu 12.10 kernel 3.5.0-14 on Ubuntu 12.04.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: jockey-gtk 0.9.7-0ubuntu7.1
ProcVersionSignature: Ubuntu 3.5.0-14.15~precise1-generic 3.5.3
Uname: Linux 3.5.0-14-generic x86_64
ApportVersion: 2.0.1-0ubuntu12
Architecture: amd64
CurrentDmesg:
 [ 338.392327] audit_printk_skb: 27 callbacks suppressed
 [ 338.392337] type=1400 audit(1347109427.854:24): apparmor="DENIED" operation="capable" parent=1 profile="/usr/sbin/cupsd" pid=1047 comm="cupsd" pid=1047 comm="cupsd" capability=36 capname="block_suspend"
Date: Sat Sep 8 15:04:02 2012
ExecutablePath: /usr/bin/jockey-gtk
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
InterpreterPath: /usr/bin/python2.7
MachineType: System manufacturer System Product Name
PackageArchitecture: all
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-14-generic root=UUID=85f8c649-a0b7-4899-8b56-cf85fbe7f8e5 ro quiet splash vt.handoff=7
SourcePackage: jockey
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/28/2007
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0702
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: M2N
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0702:bd05/28/2007:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM2N:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Carla Sella (carla-sella) wrote :
Carla Sella (carla-sella) wrote :

Maybe this bug could be related with bug #1011828.

Carla Sella (carla-sella) wrote :

After rebooting I could not logon to my session just as reported in bug #1011828.
So on command line I ran "lsmod" and "dpkg --list *nvidia*" see two files attached.
It seems like nvida-current drivers are installed but not loaded at startup.
I ran dpkg -r nvidia-current* and when I rebooted I could logon to my session but I have nouveau drivers now.

Carla Sella (carla-sella) wrote :
Carla Sella (carla-sella) wrote :

This is lsmod after removing Nvidia drivers with dpkg - see attached file.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1047843

tags: added: package-qa-testing
Carla Sella (carla-sella) wrote :

Same happens with kernel 3.5.0-14.18 on Precise 12.04.

Carla Sella (carla-sella) wrote :

Same happens with kernel 3.5.0-15.20 on Precise 12.04.

Carla Sella (carla-sella) wrote :

Same happens with 3.5.0-16.25.

Carla Sella (carla-sella) wrote :

Same happens with 3.5.0-17.26.

Carla Sella (carla-sella) wrote :

I have this problem also with kernel 3.5.0-17.28.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in jockey (Ubuntu):
status: New → Confirmed
Alberto Milone (albertomilone) wrote :

it looks like nvidia-common is not installed which is why Jockey won't work with the nvidia driver.

Carla Sella (carla-sella) wrote :

I currently have Ubuntu 12.10 installed with kernel 3.5.0-19-generic.
I tried to install nvidia-current drivers using "Additional Drivers" and now installation worked without any error.
I am attaching the output of "dpkg --list *nvidia* and lsmod.?field.comment=I currently have Ubuntu 12.10 installed with kernel 3.5.0-19-generic.
I tried to install nvidia-current drivers using "Additional Drivers" and now installation worked without any error.
I am attaching the output of "dpkg --list *nvidia* and lsmod.

Carla Sella (carla-sella) wrote :
Carla Sella (carla-sella) wrote :

After nvidia-graphics-drivers has been put into -proposed repository (http://launchpad.net/ubuntu/+source/nvidia-graphics-drivers/295.40-0ubuntu1.2 ) see bug #1011828, I tested the install and removal of both nvidia-current and nvidia-173 drivers on Precise Pangolin kernel 3.5.0-21 and had no problem so I can say the bug is fixed.

Changed in jockey (Ubuntu):
status: Confirmed → Fix Released
status: Fix Released → Fix Committed
dino99 (9d9) on 2013-07-10
Changed in jockey (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers