jigdo-lite uses ubuntu mirrors when downloading debian iso

Bug #296480 reported by Przemek K. on 2008-11-10
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
jigdo (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: jigdo

jigdo-lite uses ubuntu mirrors when downloading debian iso. This is wrong, jigdo should use debian mirrors.
I'm using Hardy with latest updates. (10/11/2008)
-----
$ jigdo-lite debian-testing-sparc-xfce-CD-1.jigdo

Jigsaw Download "lite"
Copyright (C) 2001-2005 | jigdo@
Richard Atterer | atterer.net
Getting mirror information from /etc/apt/sources.list

-----------------------------------------------------------------
Images offered by `debian-testing-sparc-xfce-CD-1.jigdo':
  1: 'Debian GNU/Linux testing "Lenny" - Official RC sparc xfce-CD Binary-1 20081104-21:39 (20081104)' (debian-testing-sparc-xfce-CD-1.iso)

Further information about `debian-testing-sparc-xfce-CD-1.iso':
Generated on Tue, 04 Nov 2008 22:41:20 +0100

-----------------------------------------------------------------
If you already have a previous version of the CD you are
downloading, jigdo can re-use files on the old CD that are also
present in the new image, and you do not need to download them
again. Mount the old CD ROM and enter the path it is mounted under
(e.g. `/mnt/cdrom').
Alternatively, just press enter if you want to start downloading
the remaining files.
Files to scan:

-----------------------------------------------------------------
The jigdo file refers to files stored on Ubuntu mirrors. Please
choose an Ubuntu mirror as follows: Either enter a complete URL
pointing to a mirror (in the form
`http://archive.ubuntu.com/archive/'), or enter any regular expression
for searching through the list of mirrors: Try a two-letter
country code such as `de', or a country name like `United
States', or a server name like `sunsite'.
Ubuntu mirror [http://pl.archive.ubuntu.com/ubuntu/]:
-----

Przemek K. (azrael) on 2008-11-10
description: updated
Revision history for this message
Onkar Shinde (onkarshinde) wrote :

Jigdo does not download mirror list from any server. Rather the mirror list is part of the package and can be found at /usr/share/jigdo/debian-mirrors.jigdo. It is intentional change to have Ubuntu mirrors in this file.

Marking as invalid. Please free to reopen.

Changed in jigdo:
status: New → Invalid
John Moser (nigelenki) on 2012-06-07
Changed in jigdo (Ubuntu):
status: Invalid → New
Revision history for this message
John Moser (nigelenki) wrote :

This is essentially the reverse of #64743

The major bug here is that Jigdo is unaware of what it's looking for: it was created with the assumption of downloading Debian CDs from Debian mirrors, and isn't aware of a local cache of a mirror set or a remote copy of that mirror set.

Essentially, Jigdo knows there's mirror information in /usr/share/jigdo/debian-mirrors.jigdo as an absolute fact. On Ubuntu, we predict that the Ubuntu alternatives CDs will be downloaded with Jigdo if anything, and thus that file has Ubuntu mirrors. Jigdo doesn't know or care of any of this. If we leave Debian mirrors there, it breaks on Ubuntu CDs; Ubuntu mirrors, breaks on Debian CDs; try to use Jigdo for anything else and it fails.

The fix is to have Jigdo look for a mirror file referenced by the .jigdo, which is currently not a feature. Then of course you must get Debian to use it, or guess if the file is 'debian-*.jigdo' then use the Debian mirror list.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in jigdo (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers