Activity log for bug #1286779

Date Who What changed Old value New value Message
2014-03-02 11:17:16 Hans Joachim Desserud bug added bug
2014-03-02 11:18:18 Hans Joachim Desserud bug watch added http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=686876
2014-03-02 11:18:18 Hans Joachim Desserud bug task added jetty (Debian)
2014-03-02 11:22:14 Hans Joachim Desserud description libjetty-extra-java still depends on libtomcat6-java which prevents it from being installed alongside other programs which depend on tomcat7. ProblemType: Bug DistroRelease: Ubuntu 14.04 Package: libjetty-extra-java 6.1.26-1ubuntu1 ProcVersionSignature: Ubuntu 3.13.0-6.23-generic 3.13.0 Uname: Linux 3.13.0-6-generic i686 ApportVersion: 2.13.2-0ubuntu2 Architecture: i386 CurrentDesktop: Unity Date: Sun Mar 2 11:48:27 2014 InstallationDate: Installed on 2013-10-26 (127 days ago) InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release i386 (20131021.1) PackageArchitecture: all SourcePackage: jetty UpgradeStatus: No upgrade log present (probably fresh install) libjetty-extra-java still depends on libtomcat6-java which prevents it from being installed alongside other programs which depend on tomcat7. (For instance gradle cannot currently be installed at the same time as tomcat7. Bug 997743 removed the explicit dependency for gradle on tomcat6 which should have fixed it, but since gradle also depends on libjetty-extra-java the issue is still present) ProblemType: Bug DistroRelease: Ubuntu 14.04 Package: libjetty-extra-java 6.1.26-1ubuntu1 ProcVersionSignature: Ubuntu 3.13.0-6.23-generic 3.13.0 Uname: Linux 3.13.0-6-generic i686 ApportVersion: 2.13.2-0ubuntu2 Architecture: i386 CurrentDesktop: Unity Date: Sun Mar 2 11:48:27 2014 InstallationDate: Installed on 2013-10-26 (127 days ago) InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release i386 (20131021.1) PackageArchitecture: all SourcePackage: jetty UpgradeStatus: No upgrade log present (probably fresh install)
2014-03-02 11:26:58 Hans Joachim Desserud description libjetty-extra-java still depends on libtomcat6-java which prevents it from being installed alongside other programs which depend on tomcat7. (For instance gradle cannot currently be installed at the same time as tomcat7. Bug 997743 removed the explicit dependency for gradle on tomcat6 which should have fixed it, but since gradle also depends on libjetty-extra-java the issue is still present) ProblemType: Bug DistroRelease: Ubuntu 14.04 Package: libjetty-extra-java 6.1.26-1ubuntu1 ProcVersionSignature: Ubuntu 3.13.0-6.23-generic 3.13.0 Uname: Linux 3.13.0-6-generic i686 ApportVersion: 2.13.2-0ubuntu2 Architecture: i386 CurrentDesktop: Unity Date: Sun Mar 2 11:48:27 2014 InstallationDate: Installed on 2013-10-26 (127 days ago) InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release i386 (20131021.1) PackageArchitecture: all SourcePackage: jetty UpgradeStatus: No upgrade log present (probably fresh install) libjetty-extra-java still depends on libtomcat6-java which prevents it from being installed alongside other programs which depend on tomcat7. According to the Debian bug report, Eclipse is among these programs. (Another it causes problems for is gradle which cannot currently be installed at the same time as tomcat7. Bug 997743 removed the explicit dependency for gradle on tomcat6 which should have fixed it, but since gradle also depends on libjetty-extra-java the issue is still present. ) ProblemType: Bug DistroRelease: Ubuntu 14.04 Package: libjetty-extra-java 6.1.26-1ubuntu1 ProcVersionSignature: Ubuntu 3.13.0-6.23-generic 3.13.0 Uname: Linux 3.13.0-6-generic i686 ApportVersion: 2.13.2-0ubuntu2 Architecture: i386 CurrentDesktop: Unity Date: Sun Mar 2 11:48:27 2014 InstallationDate: Installed on 2013-10-26 (127 days ago) InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release i386 (20131021.1) PackageArchitecture: all SourcePackage: jetty UpgradeStatus: No upgrade log present (probably fresh install)
2014-03-02 11:31:27 Hans Joachim Desserud description libjetty-extra-java still depends on libtomcat6-java which prevents it from being installed alongside other programs which depend on tomcat7. According to the Debian bug report, Eclipse is among these programs. (Another it causes problems for is gradle which cannot currently be installed at the same time as tomcat7. Bug 997743 removed the explicit dependency for gradle on tomcat6 which should have fixed it, but since gradle also depends on libjetty-extra-java the issue is still present. ) ProblemType: Bug DistroRelease: Ubuntu 14.04 Package: libjetty-extra-java 6.1.26-1ubuntu1 ProcVersionSignature: Ubuntu 3.13.0-6.23-generic 3.13.0 Uname: Linux 3.13.0-6-generic i686 ApportVersion: 2.13.2-0ubuntu2 Architecture: i386 CurrentDesktop: Unity Date: Sun Mar 2 11:48:27 2014 InstallationDate: Installed on 2013-10-26 (127 days ago) InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release i386 (20131021.1) PackageArchitecture: all SourcePackage: jetty UpgradeStatus: No upgrade log present (probably fresh install) libjetty-extra-java still depends on libtomcat6-java which prevents it from being installed alongside other programs which depend on tomcat7. According to the Debian bug report, Eclipse is among these programs. (Another it causes problems for is gradle which cannot currently be installed at the same time as tomcat7. Gradle's explicit dependency on tomcat6 has been removed (see bug 997743for details) and should have fixed it, but since gradle also depends on libjetty-extra-java the issue is still present. ) ProblemType: Bug DistroRelease: Ubuntu 14.04 Package: libjetty-extra-java 6.1.26-1ubuntu1 ProcVersionSignature: Ubuntu 3.13.0-6.23-generic 3.13.0 Uname: Linux 3.13.0-6-generic i686 ApportVersion: 2.13.2-0ubuntu2 Architecture: i386 CurrentDesktop: Unity Date: Sun Mar 2 11:48:27 2014 InstallationDate: Installed on 2013-10-26 (127 days ago) InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release i386 (20131021.1) PackageArchitecture: all SourcePackage: jetty UpgradeStatus: No upgrade log present (probably fresh install)
2014-03-02 11:31:33 Hans Joachim Desserud tags apport-bug i386 trusty apport-bug i386 saucy trusty
2014-03-02 12:52:41 Bug Watch Updater jetty (Debian): status Unknown New
2014-03-03 09:18:10 Launchpad Janitor jetty (Ubuntu): status New Confirmed
2014-03-23 23:39:03 Alberto Salvia Novella jetty (Ubuntu): importance Undecided Critical
2014-03-23 23:39:15 Alberto Salvia Novella jetty (Ubuntu): status Confirmed Triaged
2014-03-23 23:39:38 Alberto Salvia Novella bug task added hundredpapercuts
2014-03-23 23:39:44 Alberto Salvia Novella hundredpapercuts: status New Triaged
2014-03-23 23:39:47 Alberto Salvia Novella hundredpapercuts: importance Undecided Critical
2014-04-14 18:38:58 Bug Watch Updater jetty (Debian): status New Fix Released
2014-05-04 09:19:09 Artur Rona jetty (Ubuntu): status Triaged Fix Released
2014-05-18 11:55:55 Alberto Salvia Novella hundredpapercuts: status Triaged Fix Released
2014-09-24 18:17:49 Hans Joachim Desserud attachment added debdiff.patch https://bugs.launchpad.net/ubuntu/+source/jetty/+bug/1286779/+attachment/4213842/+files/debdiff.patch
2014-09-24 18:18:16 Hans Joachim Desserud description libjetty-extra-java still depends on libtomcat6-java which prevents it from being installed alongside other programs which depend on tomcat7. According to the Debian bug report, Eclipse is among these programs. (Another it causes problems for is gradle which cannot currently be installed at the same time as tomcat7. Gradle's explicit dependency on tomcat6 has been removed (see bug 997743for details) and should have fixed it, but since gradle also depends on libjetty-extra-java the issue is still present. ) ProblemType: Bug DistroRelease: Ubuntu 14.04 Package: libjetty-extra-java 6.1.26-1ubuntu1 ProcVersionSignature: Ubuntu 3.13.0-6.23-generic 3.13.0 Uname: Linux 3.13.0-6-generic i686 ApportVersion: 2.13.2-0ubuntu2 Architecture: i386 CurrentDesktop: Unity Date: Sun Mar 2 11:48:27 2014 InstallationDate: Installed on 2013-10-26 (127 days ago) InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release i386 (20131021.1) PackageArchitecture: all SourcePackage: jetty UpgradeStatus: No upgrade log present (probably fresh install) libjetty-extra-java still depends on libtomcat6-java which prevents it from being installed alongside other programs which depend on tomcat7. According to the Debian bug report, Eclipse is among these programs. (Another it causes problems for is gradle which cannot currently be installed at the same time as tomcat7. Gradle's explicit dependency on tomcat6 has been removed (see bug 997743for details) and should have fixed it, but since gradle also depends on libjetty-extra-java the issue is still present. ) SRU for 14.04: [Impact] It is very hard to use this package in conjuction with relevant development tools because they depend on different versions on tomcat which means you can't install both. [Test case] For instance `sudo apt-get install eclipse libjetty-extra` will fail because eclipse wants tomcat7, but libjetty-extra-java currently needs tomcat6. [Regression potential] ProblemType: Bug DistroRelease: Ubuntu 14.04 Package: libjetty-extra-java 6.1.26-1ubuntu1 ProcVersionSignature: Ubuntu 3.13.0-6.23-generic 3.13.0 Uname: Linux 3.13.0-6-generic i686 ApportVersion: 2.13.2-0ubuntu2 Architecture: i386 CurrentDesktop: Unity Date: Sun Mar 2 11:48:27 2014 InstallationDate: Installed on 2013-10-26 (127 days ago) InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release i386 (20131021.1) PackageArchitecture: all SourcePackage: jetty UpgradeStatus: No upgrade log present (probably fresh install)
2014-10-21 19:51:25 Philippe Latulippe bug added subscriber Philippe Latulippe
2015-01-15 17:00:56 Juan Sotuyo bug added subscriber Juan Sotuyo
2015-02-09 13:50:24 Vlad Orlov tags apport-bug i386 saucy trusty apport-bug i386 trusty
2015-02-09 14:11:44 Vlad Orlov bug added subscriber Monsta
2015-02-15 16:19:59 Hans Joachim Desserud tags apport-bug i386 trusty apport-bug i386 patch trusty
2015-02-15 16:20:12 Hans Joachim Desserud bug added subscriber Ubuntu Review Team
2015-02-27 06:59:02 Timo Jyrinki nominated for series Ubuntu Trusty
2015-02-27 06:59:02 Timo Jyrinki bug task added jetty (Ubuntu Trusty)
2015-02-27 07:01:31 Alberto Mardegan bug added subscriber Ubuntu Sponsors Team
2015-02-27 07:02:36 Timo Jyrinki description libjetty-extra-java still depends on libtomcat6-java which prevents it from being installed alongside other programs which depend on tomcat7. According to the Debian bug report, Eclipse is among these programs. (Another it causes problems for is gradle which cannot currently be installed at the same time as tomcat7. Gradle's explicit dependency on tomcat6 has been removed (see bug 997743for details) and should have fixed it, but since gradle also depends on libjetty-extra-java the issue is still present. ) SRU for 14.04: [Impact] It is very hard to use this package in conjuction with relevant development tools because they depend on different versions on tomcat which means you can't install both. [Test case] For instance `sudo apt-get install eclipse libjetty-extra` will fail because eclipse wants tomcat7, but libjetty-extra-java currently needs tomcat6. [Regression potential] ProblemType: Bug DistroRelease: Ubuntu 14.04 Package: libjetty-extra-java 6.1.26-1ubuntu1 ProcVersionSignature: Ubuntu 3.13.0-6.23-generic 3.13.0 Uname: Linux 3.13.0-6-generic i686 ApportVersion: 2.13.2-0ubuntu2 Architecture: i386 CurrentDesktop: Unity Date: Sun Mar 2 11:48:27 2014 InstallationDate: Installed on 2013-10-26 (127 days ago) InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release i386 (20131021.1) PackageArchitecture: all SourcePackage: jetty UpgradeStatus: No upgrade log present (probably fresh install) libjetty-extra-java still depends on libtomcat6-java which prevents it from being installed alongside other programs which depend on tomcat7. According to the Debian bug report, Eclipse is among these programs. (Another it causes problems for is gradle which cannot currently be installed at the same time as tomcat7. Gradle's explicit dependency on tomcat6 has been removed (see bug 997743for details) and should have fixed it, but since gradle also depends on libjetty-extra-java the issue is still present. ) SRU for 14.04: [Impact] It is very hard to use this package in conjuction with relevant development tools because they depend on different versions on tomcat which means you can't install both. [Test case] For instance `sudo apt-get install eclipse libjetty-extra` will fail because eclipse wants tomcat7, but libjetty-extra-java currently needs tomcat6. [Regression potential] See analysis in comment #15 - there should not be regression potential. ProblemType: Bug DistroRelease: Ubuntu 14.04 Package: libjetty-extra-java 6.1.26-1ubuntu1 ProcVersionSignature: Ubuntu 3.13.0-6.23-generic 3.13.0 Uname: Linux 3.13.0-6-generic i686 ApportVersion: 2.13.2-0ubuntu2 Architecture: i386 CurrentDesktop: Unity Date: Sun Mar 2 11:48:27 2014 InstallationDate: Installed on 2013-10-26 (127 days ago) InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release i386 (20131021.1) PackageArchitecture: all SourcePackage: jetty UpgradeStatus: No upgrade log present (probably fresh install)
2015-02-27 07:04:41 Timo Jyrinki jetty (Ubuntu Trusty): status New Triaged
2015-02-27 07:05:00 Timo Jyrinki jetty (Ubuntu Trusty): importance Undecided High
2015-02-27 07:06:15 Timo Jyrinki description libjetty-extra-java still depends on libtomcat6-java which prevents it from being installed alongside other programs which depend on tomcat7. According to the Debian bug report, Eclipse is among these programs. (Another it causes problems for is gradle which cannot currently be installed at the same time as tomcat7. Gradle's explicit dependency on tomcat6 has been removed (see bug 997743for details) and should have fixed it, but since gradle also depends on libjetty-extra-java the issue is still present. ) SRU for 14.04: [Impact] It is very hard to use this package in conjuction with relevant development tools because they depend on different versions on tomcat which means you can't install both. [Test case] For instance `sudo apt-get install eclipse libjetty-extra` will fail because eclipse wants tomcat7, but libjetty-extra-java currently needs tomcat6. [Regression potential] See analysis in comment #15 - there should not be regression potential. ProblemType: Bug DistroRelease: Ubuntu 14.04 Package: libjetty-extra-java 6.1.26-1ubuntu1 ProcVersionSignature: Ubuntu 3.13.0-6.23-generic 3.13.0 Uname: Linux 3.13.0-6-generic i686 ApportVersion: 2.13.2-0ubuntu2 Architecture: i386 CurrentDesktop: Unity Date: Sun Mar 2 11:48:27 2014 InstallationDate: Installed on 2013-10-26 (127 days ago) InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release i386 (20131021.1) PackageArchitecture: all SourcePackage: jetty UpgradeStatus: No upgrade log present (probably fresh install) libjetty-extra-java still depends on libtomcat6-java which prevents it from being installed alongside other programs which depend on tomcat7. According to the Debian bug report, Eclipse is among these programs. (Another it causes problems for is gradle which cannot currently be installed at the same time as tomcat7. Gradle's explicit dependency on tomcat6 has been removed (see bug 997743for details) and should have fixed it, but since gradle also depends on libjetty-extra-java the issue is still present. ) SRU for 14.04, debdiff in comment #11: [Impact] It is very hard to use this package in conjuction with relevant development tools because they depend on different versions on tomcat which means you can't install both. [Test case] For instance `sudo apt-get install eclipse libjetty-extra` will fail because eclipse wants tomcat7, but libjetty-extra-java currently needs tomcat6. [Regression potential] See analysis in comment #15 - there should not be regression potential. ProblemType: Bug DistroRelease: Ubuntu 14.04 Package: libjetty-extra-java 6.1.26-1ubuntu1 ProcVersionSignature: Ubuntu 3.13.0-6.23-generic 3.13.0 Uname: Linux 3.13.0-6-generic i686 ApportVersion: 2.13.2-0ubuntu2 Architecture: i386 CurrentDesktop: Unity Date: Sun Mar 2 11:48:27 2014 InstallationDate: Installed on 2013-10-26 (127 days ago) InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release i386 (20131021.1) PackageArchitecture: all SourcePackage: jetty UpgradeStatus: No upgrade log present (probably fresh install)
2015-04-07 06:38:14 Timo Jyrinki bug added subscriber Ubuntu Stable Release Updates Team
2015-04-07 06:49:54 Timo Jyrinki jetty (Ubuntu Trusty): assignee Timo Jyrinki (timo-jyrinki)
2015-04-07 07:29:41 Timo Jyrinki jetty (Ubuntu Trusty): status Triaged In Progress
2015-04-08 19:43:37 Chris J Arges jetty (Ubuntu Trusty): status In Progress Fix Committed
2015-04-08 19:43:40 Chris J Arges bug added subscriber SRU Verification
2015-04-08 19:43:43 Chris J Arges tags apport-bug i386 patch trusty apport-bug i386 patch trusty verification-needed
2015-04-08 19:59:44 Launchpad Janitor branch linked lp:~ubuntu-branches/ubuntu/trusty/jetty/trusty-proposed
2015-04-14 10:47:35 Vlad Orlov tags apport-bug i386 patch trusty verification-needed apport-bug i386 patch trusty verification-done
2015-04-16 16:56:18 Brian Murray removed subscriber Ubuntu Sponsors Team
2015-04-16 16:56:55 Launchpad Janitor jetty (Ubuntu Trusty): status Fix Committed Fix Released
2015-04-16 16:57:15 Brian Murray removed subscriber Ubuntu Stable Release Updates Team
2015-06-12 20:37:38 Vlad Orlov removed subscriber Monsta