Jenkins won't start on a fresh Oneiric install

Bug #901810 reported by Steve Conklin on 2011-12-08
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
jenkins (Ubuntu)
Low
James Page

Bug Description

I installed jenkins - it didn't start.

/var/log/jenkins/jenkins.log is empty

No messages in syslog related to jenkins

The service is stuck in stop/waiting state:

root@Ivy:~# service jenkins status
jenkins stop/waiting
root@Ivy:~# service jenkins stop
stop: Unknown instance:
root@Ivy:~# service jenkins start
jenkins start/running, process 2052
root@Ivy:~# service jenkins stop
stop: Unknown instance:
root@Ivy:~# service jenkins status
jenkins stop/waiting

I thought perhaps it was a java dependency that wasn't correctly defined, so I installed openjre, there was no change

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: jenkins 1.409.1-0ubuntu4.1
ProcVersionSignature: Ubuntu 3.0.0-13.22-generic-pae 3.0.6
Uname: Linux 3.0.0-13-generic-pae i686
ApportVersion: 1.23-0ubuntu4
Architecture: i386
Date: Thu Dec 8 12:15:57 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: jenkins
UpgradeStatus: No upgrade log present (probably fresh install)

Steve Conklin (sconklin) wrote :
Steve Conklin (sconklin) wrote :

I found a fix, although not the root cause.

Apparently there is a problem with install order of jenkins and the java packages, or with the dependencies.

The problem was that in /etc/init/jenkins.conf:

env JAVA_HOME="/usr/lib/jvm/default-java"

But the default-java symlink wasn't there.

To solve the problem I did the following (as root):

cd /usr/lib/jvm
ln -s java-6-openjdk default-java

James Page (james-page) wrote :

The default-jre-headless | java6-runtime-headless dependency is the cause of the problem

The upstart script needs to work harder to figure out where JAVA_HOME is.

I'll work this into the precise release; workaround for the time being on Oneiric is to install default-jre-headless.

Changed in jenkins (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → James Page (james-page)
James Page (james-page) wrote :

The latest version of Jenkins in precise no longer relies on JAVA_HOME - it simply uses /usr/bin/java so this bug should be resolved.

As the workaround (install default-jre-headless) is easy I'd propose not fixing this in Oneiric.

Changed in jenkins (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers