Jclic hangs on exit with openjdk

Bug #1002280 reported by Luisa Ravelli on 2012-05-21
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
jclic (Ubuntu)
Undecided
Unassigned

Bug Description

In every Ubuntu version from 10.04 to 12.04, tried on several machines.

Package installed:
* jclic
* openjdk

Jclic works perfectly until I try to close it, the application hangs and the only way to terminate it is going on a terminal and kill the java process.

Workaround until 12.04:

Installing the sun-java6-jdk and with update-alternatives make it the default jdk

Workaround modification in 12.04:

Since the sun jre is no longer distributable with Ubuntu, I had to install the Oracle jdk.
I decide to use a ppa to mantain the package updated easily so I use these commands:
sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-java7-installer
The script also provide to make the new jdk the default one.
When launching jclic nothing happens so I launch it from a terminal and I discovered that it couldn't find the jdk because it was searching it in the wrong path (error in line 36).

So I had to modify the script /usr/bin/jclic this way:

if [ -z $JAVA_HOME ] ; then
 ALTERNATIVE=`ls -l /etc/alternatives/java|grep sun`
 if [ -z "$ALTERNATIVE" ]; then
  ALTERNATIVE=`ls -l /etc/alternatives/java|grep openjdk`
 fi

 if [ -z "$ALTERNATIVE" ]; then
         t=/usr/lib/jvm/java-1.5.0-sun && test -d $t && JAVA_HOME=$t
         t=/usr/lib/jvm/java-6-sun && test -d $t && JAVA_HOME=$t
         t=/usr/lib/jvm/java-7-icedtea && test -d $t && JAVA_HOME=$t
         JAVA=${JAVA_HOME}/jre/bin/java
 fi
# lines added
        if [ -z "$ALTERNATIVE" ]; then
         t=/usr/lib/jvm/java-7-oracle && test -d $t && JAVA_HOME=$t
         JAVA=${JAVA_HOME}/jre/java
 fi
# end added lines
        fi

Now Jclic works fine but I know that an update will remove my lines, is it possibile to fix jclic to work with openjdk or to link the correct path for java-7-oracle?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in jclic (Ubuntu):
status: New → Confirmed

This bug was solved in JClic 0.2.3.4

See:
https://launchpad.net/jclic (JClic project in Launchpad)
https://launchpad.net/~jclic/+archive/ubuntu/master (PPA with updated JClic packages)
https://github.com/projectestac/jclic (main repository for JClic sources)

ftoledo (ftoledo) wrote :

can you paste a commit url of the patch?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers