jbossas4 version 4.2.3.GA-6 FTBFS on i386 in precise

Bug #935198 reported by Andreas Moog on 2012-02-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
jbossas4 (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

This is a semi-automatic report based on the latest archive rebuild results [1].
Apologies if it reaches you in error.

Excerpt from the buildlog:

    [javac] TreeCacheProviderHook.java:52: cannot find symbol
    [javac] symbol : class TreeCacheProvider
    [javac] location: package org.hibernate.cache
    [javac] extends org.hibernate.cache.TreeCacheProvider
    [javac] ^
    [javac] TreeCacheProviderHook.java:68: cannot find symbol
    [javac] symbol : method getClass()
    [javac] location: class org.jboss.ejb3.entity.TreeCacheProviderHook
    [javac] protected Logger log = Logger.getLogger(getClass());
    [javac] ^
    [javac] Note: Some input files use or override a deprecated API.
    [javac] Note: Recompile with -Xlint:deprecation for details.
    [javac] Note: Some input files use unchecked or unsafe operations.
    [javac] Note: Recompile with -Xlint:unchecked for details.
    [javac] 2 errors
    [javac] 6 warnings

BUILD FAILED
/build/buildd/jbossas4-4.2.3.GA/debian/build.xml:340: Compile failed; see the compiler error output for details.

Total time: 56 seconds
make: *** [debian/stamp-ant-build] Error 1
dpkg-buildpackage: error: debian/rules build gave error exit status 2
******************************************************************************
Build finished at 20120206-1559
FAILED [dpkg-buildpackage died]

The full buidlog can be found at https://launchpad.net/ubuntu/+archive/test-rebuild-20120201/+build/3151889/+files/buildlog_ubuntu-precise-i386.jbossas4_4.2.3.GA-6_FAILEDTOBUILD.txt.gz.

[1] http://people.ubuntuwire.org/~wgrant/rebuild-ftbfs-test/test-rebuild-20120201-precise.html

Andreas Moog (ampelbein) on 2012-02-18
Changed in jbossas4 (Ubuntu):
importance: Undecided → High
James Page (james-page) wrote :

This is actually caused by libhibernate-jbosscache-java not providing some legacy classes

The latest release in Debian unstable looks to resolve this issue.

James Page (james-page) wrote :

I synced over latest libhibernate-jbosscache-java which will fix this issue and the latest packaging update for this package from Debian unstable.

jbossas4 (4.2.3.GA-7) unstable; urgency=low

  * Team upload.
  * Replace dependencies on Servlet 2.4 library with 2.5 one. (Closes: #658802).
  * Bump Standards-Version to 3.9.3. No changes were needed.

Marking 'Fix Released'

Changed in jbossas4 (Ubuntu Precise):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers