Circular build-depends, needs initial bootstrapping on the buildds

Bug #184557 reported by Michael Bienia on 2008-01-20
10
Affects Status Importance Assigned to Milestone
jbossas4 (Ubuntu)
Medium
Unassigned
libjboss-remoting-java (Ubuntu)
Undecided
Unassigned
libjboss-xml-binding-java (Ubuntu)
Undecided
Unassigned

Bug Description

jbossas4 is currently in depwait on libjboss-xml-binding-java and libjboss-remoting-java.

libjboss-xml-binding-java is in depwait on libjboss-test-java (source package is jbossas4).
libjboss-remoting-java is in depwait on libjboss-jmx-java (source package is jbossas4).

Matthias Klose (doko) wrote :

confirmed; requires help of a buildd admin

Changed in jbossas4:
assignee: nobody → adconrad
importance: Undecided → Medium
status: New → Confirmed
jerico (jerico-dev) wrote :

I am currently working on this package, trying to resolve the remaining issues and dependencies. (There are more than just missing dependencies, e.g. build script does not compile all necessary classes, stubs and parsers, init script is missing, even when completely built, run-script will not yet start.) AFAICS this will take some time still as the package seems to be in an early unstable phase. See http://lists.debian.org/debian-java/2008/06/msg00016.html

Onkar Shinde (onkarshinde) wrote :

@Michael,

I worked on this package yesterday and I think I have made some progress. It is possible to built some packages from jbossas4 source that do not have circular dependencies. Thus we get kind of bootstraping we need.

Following binary packages will be built from jbossas4 source -
1. libjboss-ejb3x-java
2. libjboss-j2ee-java
3. libjboss-jmx-java
4. libjboss-naming-java
5. libjboss-test-java
Other packages will still be built but not having any jar files in them. This will push all the other jboss related packages out of DEPWAIT and we will at least know what other problems we might have.

Depending on the packages mentioned above followed external packages shouldn't have any build problem now.
1. libjboss-xml-binding-java
2. libjboss-integration-java
3. libjboss-remoting-java

Once first round is done I will rework the package, readding the build deps and evaluating what other binaries can be produced.

Please find attached debdiff.

Michael Bienia (geser) wrote :

jbossas4_4.2.2.GA-5ubuntu1 uploaded, let's see how far we get.

Onkar Shinde (onkarshinde) wrote :

Please find attached next debdiff. Should solve FTBFS for libjboss-cache1-java and subsequently libhibernate*.

Michael Bienia (geser) wrote :

Thanks again, Onkar. jbossas4 4.2.2.GA-5ubuntu2 uploaded.

Michael Bienia (geser) wrote :

libjboss-remoting-java finally build in intrepid now.

Changed in libjboss-remoting-java:
status: New → Fix Released
Michael Bienia (geser) wrote :

libjboss-xml-binding-java finally build in intrepid now.

Changed in libjboss-xml-binding-java:
status: New → Fix Released
Onkar Shinde (onkarshinde) wrote :

jbossas4 is completely built in jaunty now.

Changed in jbossas4:
status: Confirmed → Fix Released
assignee: adconrad → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers