Current Oracle Java 8 installation path is not in jvm-list.sh

Bug #1487209 reported by Michael Kuefner on 2015-08-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
java-wrappers (Ubuntu)
Undecided
Unassigned

Bug Description

I have a problem in Ubuntu 15.04 with the newest Oracle Java 8 (and have not installed any other Open JDK) starting the application "freemind" which uses java-wrappers to get a suitable java runtime.

I found a problem in java-wrappers file which determines the available Java installations:
In file "/usr/lib/java-wrappers/jvm-list.sh":

=> added /usr/lib/jvm/java-8-oracle on line 35 at the beginning

__jvm_oracle8="/usr/lib/jvm/java-8-oracle /usr/lib/jvm/jdk-8-oracle-* /usr/lib/jvm/jre-8-oracle-*"

As the current installation of Oracle 8 Java is installed in this added path.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: java-wrappers 0.1.28 [modified: usr/share/java-wrappers/jvm-list.sh]
Uname: Linux 4.0.0-040000-generic x86_64
ApportVersion: 2.17.2-0ubuntu1.3
Architecture: amd64
CurrentDesktop: GNOME
Date: Thu Aug 20 23:20:04 2015
InstallationDate: Installed on 2015-06-21 (60 days ago)
InstallationMedia: Ubuntu-GNOME 15.04 "Vivid Vervet" - Release amd64 (20150422)
PackageArchitecture: all
SourcePackage: java-wrappers
UpgradeStatus: No upgrade log present (probably fresh install)

Michael Kuefner (herrminni) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers