java-gnome: FTBFS: org.freedesktop.DBus.Error.ServiceUnknown: The name org.a11y.Bus was not provided by any .service files

Bug #1277944 reported by Andreas Moog on 2014-02-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
java-gnome (Ubuntu)
High
Guillaume Mazoyer

Bug Description

 affects ubuntu/java-gnome
 importance high
 tag ftbfs trusty
 done

Hi there,

the package java-gnome fails to build in current Ubuntu.

(Hopefully) Relevant part of the log:
--------------------------------------

MKDIR tmp/locale/es/LC_MESSAGES
MSGFMT tmp/locale/es/LC_MESSAGES/example.mo
MKDIR tmp/locale/en_US/LC_MESSAGES
MSGFMT tmp/locale/en_US/LC_MESSAGES/unittest.mo
JAVADOC doc/api/*.html
warning: [options] bootstrap class path not set in conjunction with -source 1.5
src/bindings/org/freedesktop/cairo/Operator.java:82: warning - Tag @link: reference not found: org.gnome.gdk.Drawable Drawable
src/bindings/org/gnome/gtk/Widget.java:1739: warning - @return tag has no arguments.
src/bindings/org/gnome/gtk/Action.java:436: warning - Tag @link: can't find activate() in org.gnome.gtk.Action
src/bindings/org/gnome/gtk/Application.java:159: warning - Tag @link: can't find isValidID(String) in org.gnome.glib.Application
src/bindings/org/gnome/gtk/Application.java:142: warning - Tag @link: can't find isValidID(String) in org.gnome.glib.Application
src/bindings/org/gnome/gtk/Box.java:103: warning - Tag @link: can't find packEnd(Widget) in org.gnome.gtk.Box
src/bindings/org/gnome/gtk/ButtonBox.java:68: warning - Tag @link: can't find packStart(Widget) in org.gnome.gtk.Box
src/bindings/org/gnome/gtk/ButtonBox.java:68: warning - Tag @link: can't find packEnd(Widget) in org.gnome.gtk.Box
src/bindings/org/gnome/gtk/ButtonBox.java:116: warning - Tag @link: can't find setDirection(TextDirection) in org.gnome.gtk.Widget
src/bindings/org/gnome/gtk/CheckButton.java:61: warning - Tag @link: reference not found: ToggleButton.TOGGLED TOGGLED
src/bindings/org/gnome/gtk/ComboBox.java:83: warning - Tag @link: reference not found: TextComboBox
src/bindings/org/gnome/gtk/HBox.java:49: warning - Tag @link: can't find packStart(Widget) in org.gnome.gtk.Box
src/bindings/org/gnome/gtk/ProgressBar.java:100: warning - Tag @link: missing '#': "setText(String)"
src/bindings/org/gnome/gtk/RadioButton.java:113: warning - Tag @link: reference not found: org.gnome.gtk.ToggleButton.TOGGLED TOGGLED
src/bindings/org/gnome/gtk/Scrollbar.java:59: warning - Tag @link: reference not found: VScrollBar
src/bindings/org/gnome/gtk/Statusbar.java:121: warning - Tag @link: can't find setHasResizeGrip(boolean) in org.gnome.gtk.Statusbar
src/bindings/org/gnome/gtk/TextBuffer.java:715: warning - Tag @link: can't find moveMark() in org.gnome.gtk.TextBuffer
src/bindings/org/gnome/gtk/TextView.java:231: warning - Tag @link: can't find modifyFont(FontDescription) in org.gnome.gtk.TextView
src/bindings/org/gnome/gtk/ToggleAction.java:211: warning - Tag @link: can't find toggled() in org.gnome.gtk.ToggleAction
src/bindings/org/gnome/gtk/ToggleToolButton.java:63: warning - Tag @link: reference not found: ToggleToolButton.TOGGLED TOGGLED
src/bindings/org/gnome/gtk/VBox.java:55: warning - Tag @link: can't find packStart(Widget) in org.gnome.gtk.Box
src/bindings/org/gnome/gtk/Widget.java:82: warning - Tag @link: reference not found: org.gnome.glade.Glade Glade
src/bindings/org/gnome/gtk/Widget.java:82: warning - Tag @link: reference not found: org.gnome.glade.XML#getWidget(String) getWidget()
src/bindings/org/gnome/gdk/Cursor.java:81: warning - Tag @link: can't find getToplevels() in org.gnome.gdk.Window
src/bindings/org/gnome/gdk/Rectangle.java:49: warning - Tag @link: reference not found: EventExpose#getArea() getArea()
src/bindings/org/gnome/notify/Notification.java:91: warning - Tag @link: can't find Notification(String,String,String,Widget) in org.gnome.notify.Notification
JAVA Harness
EXEC Xvfb
EXEC metacity
DANGER: (null)-WARNING, Error retrieving accessibility bus address: org.freedesktop.DBus.Error.ServiceUnknown: The name org.a11y.Bus was not provided by any .service files
KILL Xvfb
KILL metacity
Exception in thread "main" org.gnome.glib.FatalError: (null)-WARNING
Error retrieving accessibility bus address: org.freedesktop.DBus.Error.ServiceUnknown: The name org.a11y.Bus was not provided by any .service files
 at org.gnome.gtk.GtkMain.gtk_init(Native Method)
 at org.gnome.gtk.GtkMain.init(GtkMain.java:54)
 at org.gnome.gtk.Gtk.init(Gtk.java:95)
 at Harness.main(Harness.java:149)
make[1]: *** [doc] Error 1
make[1]: Leaving directory `/build/buildd/java-gnome-4.1.2'
make: *** [debian/stamp-makefile-build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2
******************************************************************************
Build finished at 20140201-1519
FAILED [dpkg-buildpackage died]

A full buildlog is available at https://launchpadlibrarian.net/164548643/buildlog_ubuntu-trusty-i386.java-gnome_4.1.2-1build1_FAILEDTOBUILD.txt.gz

Thanks for your time!

Regards,
  Andreas

--
PGP-encrypted mails preferred
PGP Fingerprint: 74CD D9FE 5BCB FE0D 13EE 8EEA 61F3 4426 74DE 6624

Guillaume Mazoyer (respawneral) wrote :

Bug reported in Debian too.
It should be fixed there and then the package be synced here.

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=748565

Changed in java-gnome (Ubuntu):
assignee: nobody → Guillaume Mazoyer (respawneral)
Guillaume Mazoyer (respawneral) wrote :

Since the sync with the debian package the fix has been released in utopic.
Should it be backported to trusty?

Changed in java-gnome (Ubuntu):
status: New → Confirmed
status: Confirmed → Fix Committed
Andreas Moog (ampelbein) wrote :

This is fixed in the current Ubuntu development release.

Changed in java-gnome (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.