Eclipse unusable in Kubuntu Saucy (almost immediate JVM segfault)

Bug #1205452 reported by Matt Ruffalo on 2013-07-26
226
This bug affects 45 people
Affects Status Importance Assigned to Milestone
gtk+2.0 (Ubuntu)
High
Unassigned
java-common (Ubuntu)
High
Unassigned

Bug Description

Steps to reproduce:

1. Perform clean install of Kubuntu 13.10 amd64 from 2013-07-24 media.
2. apt-get update; apt-get install eclipse
3. Run eclipse, see "Workspace Launcher" window that suggests ~/workspace as a location
4. Click OK.

JVM segfaults; error log file contains

# Problematic frame:
# C [libgobject-2.0.so.0+0x19838] g_object_get_qdata+0x18

This also occurs with saucy Eclipse on Oracle JRE 7u25, but I ensured that this occurs on a clean install with supported packages before submitting this bug report.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: eclipse 3.8.1-1ubuntu1
ProcVersionSignature: Ubuntu 3.10.0-5.14-generic 3.10.2
Uname: Linux 3.10.0-5-generic x86_64
ApportVersion: 2.11-0ubuntu1
Architecture: amd64
Date: Fri Jul 26 13:40:09 2013
InstallationDate: Installed on 2013-07-26 (0 days ago)
InstallationMedia: Kubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130724)
MarkForUpload: True
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: eclipse
UpgradeStatus: No upgrade log present (probably fresh install)

Matt Ruffalo (mruffalo) wrote :
Matt Ruffalo (mruffalo) on 2013-07-26
summary: - Crashes when clicking OK in workspace location selection
+ Eclipse crashes when clicking OK in workspace location selection

Eclipse doesn't seem like the right package for this, now that I've thought about it more. It isn't doing anything exotic; it's the JVM that's segfaulting in libgobject-2.0.so. I'm undecided whether I think I should change this to 'openjdk-7-jre' or a 'libglib2.0' package, and more-or-less arbitrarily chose between those two. Sorry for the extra triage work.

affects: eclipse (Ubuntu) → openjdk-7 (Ubuntu)
Matt Ruffalo (mruffalo) on 2013-08-16
summary: - Eclipse crashes when clicking OK in workspace location selection
+ Eclipse unusable in Kubuntu Saucy (almost immediate JVM segfault)
Matt Ruffalo (mruffalo) wrote :

There have been some recent updates to libglib2.0 (from 2.37.3-1ubuntu2 to 2.37.5-1ubuntu1 that I installed on 2013-08-13) and the openjdk packages (from 7u25-2.3.12-1ubuntu1 to 7u25-2.3.12-4ubuntu1, installed today), but Eclipse still causes the JVM to segfault very consistently. It's very hard to avoid this crash, too; the "workspace selection" dialog is the first thing a user sees after installing and running Eclipse. The net result is that Eclipse is unusable in the current state of Kubuntu Saucy.

The old JVM dump attachment probably doesn't apply anymore, since the JVM segfault now occurs at a different address in libgobject-2.0.so. I've attached a new JVM dump that contains

# C [libgobject-2.0.so.0+0x19908] g_object_get_qdata+0x18

Matt Ruffalo (mruffalo) wrote :

From the Java stack trace, it doesn't seem like this is the JVM's fault. It looks like the SWT GTK wrappers are calling native code, according to this part of the JVM dump:

Stack: [0x00007fe32161f000,0x00007fe321720000], sp=0x00007fe32171cad0, free space=1014k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
C [libgobject-2.0.so.0+0x19908] g_object_get_qdata+0x18

[error occurred during error reporting (printing native stack), id 0xb]

Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
j org.eclipse.swt.internal.gtk.OS._g_object_get_qdata(JI)J+0
j org.eclipse.swt.internal.gtk.OS.g_object_get_qdata(JI)J+9
j org.eclipse.swt.widgets.Display.removeWidget(J)Lorg/eclipse/swt/widgets/Widget;+19
j org.eclipse.swt.widgets.Combo.deregister()V+21
...

affects: openjdk-7 (Ubuntu) → eclipse (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in eclipse (Ubuntu):
status: New → Confirmed
Matt Ruffalo (mruffalo) wrote :

I followed the JVM's suggestion about creating a core dump, and it's available at http://giygas.case.edu/kubuntu-saucy-eclipse/core.xz (GPG signature at http://giygas.case.edu/kubuntu-saucy-eclipse/core.xz.asc). I'm not sure how useful this is, but I'm guessing that it can't hurt.

Gus Bourg (gus-bourg) wrote :

This appears to be the same as eclipse bug 317763. The work around for that bug works for this:

1) Open System Settings
2) Select Application Appearance
3) Select GTK
4) Change the GTK2 theme to anything but oxygen-gtk

It then opens the workspace.

Damyan Yordanov (damyanyo) wrote :

The problem disappeared for me after I'd done a (huge) apt-get upgrade. Unfortunalety I cannot tell which was the package causing the exception.

David Masover (ninja-slaphack) wrote :

Problem still exists for me. Changing the GTK theme does not help.

David Masover (ninja-slaphack) wrote :

...and for what it's worth, a fresh download of Eclipse Kepler from eclipse.org works fine. Why is Ubuntu's Eclipse held back to 3.8? Maybe an upgrade would solve this?

Torsten Casselt (blu2lz) wrote :

Same problem here with 13.10 upgraded since 12.04.

With upgrading eclipse was updated to 3.8 and all my plugins were gone so I tried to reinstalled it but it crashed.

Checked everything - deleted config, tried different plugins in different order. Sometimes I had one install successful, but next install: crash again.

Finally I searched the web – switched GTK2 style to Raleigh. Everything works – but looks awkward.

This is NO solution because every program using GTK2 looks strange after that, e.g. thunderbird. I wanted to stick with the eclipse version from the repositories but maybe I'll try an update to Kepler if it is fixed there. The look and feel is really bad.

Maybe you can just update the eclipse version in this release. I saw that 3.8.1 is also planned for trusty, so please address this bug!

I attached a crash report.

Quinn Balazs (qbalazs) wrote :

This will in all likelihood be marked as a dupe of bug #1241101. Just checking logs here for differences. Take a look at the eclipse-bugs report that should be relevant for all of these issues. https://bugs.eclipse.org/bugs/show_bug.cgi?id=419729.

affects: eclipse (Ubuntu) → java-common (Ubuntu)
Alexander (etc9053) wrote :

I can confirm this behavor. Kubuntu 13.10. Changing GTK2 theme to ancient Raleigh helped me, now eclipse looks stable.
Plz, fix it.

Andreas Ntaflos (daff) wrote :

"Same here." Freshly updated from Kubuntu 13.04 to Kubuntu 13.10. Eclipse, or in my case Apache Directory Studio, which is basically Eclipse, can't be started as the JVM segfaults after a few seconds. Happens with both OpenJDK 7 and Oracle Java 7.

Changing GTK2 theme to Raleigh makes Eclipse (Apache Directory Studio) start correctly, but this theme offends my sense of aesthetics :)

Martin Bohacek (bohacekm) wrote :

Got the same issue after update from 13.04 x86 to 13.10 x86.
Using Oracle Java 1.7.0_25.
Changing GTK2 theme helped, but fixing of this would be really appreciated.

Keith Baker (keibak) wrote :

Changing the GTK2 theme globally makes everything look terrible. I'd suggest to set the theme only for the affected application using the corresponding environment variable:
 $ GTK2_RC_FILES=/usr/share/themes/Raleigh/gtk-2.0/gtkrc ./eclipse-or-eclipse-app

Oren Gampel (oren-2) wrote :

@Keith, can you elaborate on your suggestion? I would like to try it.

Keith Baker (keibak) wrote :

@Oren

Just start the programm within a terminal with the above command. Leave out the $ and replace ./eclipse-or-eclipse-app with eclipse/smartsvn/jameica or any other affected tool.

Quinn Balazs (qbalazs) on 2013-11-06
Changed in gtk+2.0 (Ubuntu):
status: New → Confirmed
Holger Joukl (jholg) wrote :

@Keith, thanks a lot I can confirm your workaround does the trick for me for jameica:

$ GTK2_RC_FILES=/usr/share/themes/Raleigh/gtk-2.0/gtkrc /opt/jameica/jameica.sh

This avoids the crash so at least my app is usable, looking pretty oldschool ;-)

Changed in gtk+2.0 (Ubuntu):
importance: Undecided → High
Changed in java-common (Ubuntu):
importance: Undecided → High
Changed in gtk+2.0 (Ubuntu):
status: Confirmed → Invalid
Changed in java-common (Ubuntu):
status: Confirmed → Triaged
jstammi (jstammi) wrote :

I spent this morning on analyzing our application SIGSEGV'ing since having upgraded my os (openSuSE 13.1, KDE). Though this is actually no ubuntu, I think that this bug is related: IMHO with the symptoms that an eclipse RCP application fails

1) within libgobject-2.0.so./g_object_get_qdata
2) from a java stack trace that includes org.eclipse.swt.widgets.Combo.deregister

and switching the theme the GTK2_RC_FILES= way as given above prevents from crashing. Then I'm quite sure that you will be able to stop crashing also by
disabling the GtkComboBox::appears-as-list
within the oxygen-gtk theme (/usr/share/themes/oxygen-gtk/gtk-2.0/gtkrc).
This makes comboboxes appear a little bit different, but the general l&f stays as before.

You can force this bug with any other theme by enabling this option there - so the oxygen can only be blamed for using this option, it is not the root cause of it AFAIS at the moment,

I filed a related GNOME bug https://bugzilla.gnome.org/show_bug.cgi?id=736323, an oxygen bug that looks related very much is available at https://bugs.kde.org/show_bug.cgi?id=329814.

Ohadcn (ohadcn) wrote :

this bug may affect another java based programs, today i had similar bug using idl

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.