Merge jasperreports 3.7.3+dfsg-1 (universe) from Debian unstable (main)

Bug #605959 reported by Artur Rona on 2010-07-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
jasperreports (Ubuntu)
Undecided
Unassigned

Bug Description

 jasperreports (3.7.3+dfsg-1) unstable; urgency=low

   * New upstream release:
     - Refresh all patches
   * Bump Standards-Version to 3.9.0 (no changes needed)

 -- Damien Raude-Morvan <email address hidden> Thu, 08 Jul 2010 02:23:43 +0200
jasperreports (3.7.2+dfsg-1) unstable; urgency=low

   [ Torsten Werner ]
   * Change maintainers into Maintainers.

   [ Damien Raude-Morvan ]
   * New upstream release:
     - Drop d/patches/01_exclude_jpa.diff
     - Drop d/patches/03_use_pngencoder_from_jcommon.diff
     - Refresh others patches
   * Switch to 3.0 (quilt) source format:
     - d/source/format: Set 3.0 (quilt)
     - d/rules: Remove /usr/share/cdbs/1/rules/patchsys-quilt.mk
     - d/control: Remove B-D on quilt
     - d/README.source: Removed
   * Replace d/patches/11_pom.diff by some d/maven.ignoreRules

 -- Damien Raude-Morvan <email address hidden> Tue, 20 Apr 2010 23:50:28 +0200
jasperreports (3.7.1+dfsg-2) unstable; urgency=low

   * Fix FTBFS: (Closes: #571398)
     - debian/control: Build-Depends on rhino
       (since OpenJDK now only Recommends it)
     - debian/rules: add js.jar to classpath

 -- Damien Raude-Morvan <email address hidden> Fri, 26 Feb 2010 00:13:25 +0100
jasperreports (3.7.1+dfsg-1) unstable; urgency=low

   * New upstream release
     - Remove debian/patches/12_itext.diff (merged upstream)
     - Refresh others patches
   * Enable OLAP components:
     - Update debian/patches/01_exclude_olap_and_jpa.diff
     - debian/control: Build-Depends on libmondrian-java, libolap4j-java,
       libantlr-java
     - debian/rules: add those libs into DEB_JARS
   * Bump Standards-Version to 3.8.4 (no changes needed)

 -- Damien Raude-Morvan <email address hidden> Sat, 06 Feb 2010 22:03:56 +0100

Artur Rona (ari-tczew) wrote :
Changed in jasperreports (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jasperreports - 3.7.3+dfsg-1ubuntu1

---------------
jasperreports (3.7.3+dfsg-1ubuntu1) maverick; urgency=low

  * Merge from Debian unstable, remaining changes
    to fix FTBFS: (LP: #605959):
    - debian/control: Drop Build-Depends on libspring-core-2.5-java,
      libspring-beans-2.5-java and libmondrian-java
    - debian/patches/13_fix_ftbfs.diff: Modify build.xml so that
      build continues in case of compilation error.

jasperreports (3.7.3+dfsg-1) unstable; urgency=low

  * New upstream release:
    - Refresh all patches
  * Bump Standards-Version to 3.9.0 (no changes needed)

jasperreports (3.7.2+dfsg-1) unstable; urgency=low

  [ Torsten Werner ]
  * Change maintainers into Maintainers.

  [ Damien Raude-Morvan ]
  * New upstream release:
    - Drop d/patches/01_exclude_jpa.diff
    - Drop d/patches/03_use_pngencoder_from_jcommon.diff
    - Refresh others patches
  * Switch to 3.0 (quilt) source format:
    - d/source/format: Set 3.0 (quilt)
    - d/rules: Remove /usr/share/cdbs/1/rules/patchsys-quilt.mk
    - d/control: Remove B-D on quilt
    - d/README.source: Removed
  * Replace d/patches/11_pom.diff by some d/maven.ignoreRules

jasperreports (3.7.1+dfsg-2) unstable; urgency=low

  * Fix FTBFS: (Closes: #571398)
    - debian/control: Build-Depends on rhino
      (since OpenJDK now only Recommends it)
    - debian/rules: add js.jar to classpath

jasperreports (3.7.1+dfsg-1) unstable; urgency=low

  * New upstream release
    - Remove debian/patches/12_itext.diff (merged upstream)
    - Refresh others patches
  * Enable OLAP components:
    - Update debian/patches/01_exclude_olap_and_jpa.diff
    - debian/control: Build-Depends on libmondrian-java, libolap4j-java,
      libantlr-java
    - debian/rules: add those libs into DEB_JARS
  * Bump Standards-Version to 3.8.4 (no changes needed)
 -- Artur Rona <email address hidden> Thu, 15 Jul 2010 18:33:35 +0200

Changed in jasperreports (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers