ubuntu-omap4-extras from the TI PPA is not installable in natty

Bug #759817 reported by Oliver Grawert on 2011-04-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
jasper-initramfs (Ubuntu)
Medium
Ricardo Salveti
Natty
Medium
Ricardo Salveti

Bug Description

clicking the TI icon on pandaboard images properly enables the PPA and tries to install ubuntu-omap4-extras from there. currently the dependencies of that package for natty seem to be broken and the installation fails.

Oliver Grawert (ogra) wrote :

@nicolas, can that be fixed before release ? the postinist will also need updating to handle the unity-2d favorites system.

if you need help, i'm happy to do the changes ...

tags: added: armel
Changed in jasper-initramfs (Ubuntu Natty):
assignee: nobody → Nicolas Dechesne (ndec)
milestone: none → ubuntu-11.04
importance: Undecided → Medium
status: New → Triaged
tags: added: iso-testing
Ricardo Salveti (rsalveti) wrote :

I can fix this by copying the current SGX packages to the release PPA. I plan to release another SGX version until the end of this week, and should also be released at the release PPA.

Changed in jasper-initramfs (Ubuntu Natty):
assignee: Nicolas Dechesne (ndec) → Ricardo Salveti (rsalveti)
Ricardo Salveti (rsalveti) wrote :

I tested using the described postinst script and it worked fine. I pushed the package to the builders, but a bug in launchpad is currently blocking me, as it's building already for more than 3 hours, and a meta-package like this one should take just a few minutes.

Once launchpad is back again, I'll close this bug.

postinst:
"""
case "$1" in
  configure|upgrade)
    if [ -e /usr/share/gconf/unity-2d/default/25_jasper-favorites-override ] ; then
        rm /usr/share/gconf/unity-2d/default/25_jasper-favorites-override || true
        update-gconf-defaults --source /usr/share/gconf/unity-2d/default \
            --destination /var/lib/gconf/unity-2d.default --no-signal || true
    fi
    if [ -e /usr/share/applications/ti-ppa.desktop ] ; then
        rm /usr/share/applications/ti-ppa.desktop || true
    fi
    if [ -e /usr/share/pixmaps/ti-ppa.svg ] ; then
        rm /usr/share/pixmaps/ti-ppa.svg || true
    fi
  ;;
esac
"""

Ricardo Salveti (rsalveti) wrote :

After updating my rootfs and applying jasper hacks by hand I tested with the new extras package upload and it worked fine.

Changed in jasper-initramfs (Ubuntu Natty):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers