Universe & multiverse are not enabled on OMAP4 preinstalled image

Bug #659754 reported by Vincent Stehlé on 2010-10-13
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
jasper-initramfs (Ubuntu)
High
Canonical ARM Developers
Maverick
Undecided
Unassigned
Natty
High
Canonical ARM Developers
ubuntu-netbook-efl-default-settings (Ubuntu)
Undecided
Unassigned
Maverick
Medium
Unassigned
Natty
Undecided
Unassigned

Bug Description

After installing the preinstalled maverick image for OMAP4, universe & multiverse are not enabled in the sources.list.

This makes installing ubuntu-omap4-extras a bit more difficult due to dependencies on multiverse/universe packages (e.g. faac, gstreamer...)

Emmet Hikory (persia) wrote :

This is a failure of jasper-initramfs to update the enabled software-sources at install time. Given that no new images are being produced, fixing this in jasper is insufficient to help maverick users. As a result, the following strategy shall be employed.

1) jasper-initramfs shall be updated to update the software-sources during the first-boot experience for natty
2) this will be listed as a required feature for the planned rewrite of jasper-initramfs
3) Some *other* package needs to get a stable-release-update in order to enable the software sources OR every user will need to be asked to do so manually.

For item 3, the suggestion is to use ubuntu-netbook-efl-default-settings as this is only enabled by default for armel Ubuntu Netbook images, and two of the three images are affected by this bug, therefore the potential for regression for other users is minimised. Such regression potential may be further minimised by checking the architecture and subarchitecture of the updating platform in the updated postinst script prior to asking for universe and multiverse to be enabled in software-sources, so that only subarchitectures for which images were built with the buggy jasper-initramfs are updated.

Note that this only addresses the Ubuntu Netbook armel images: it may be that other target packages must be selected to address any other flavours that may have issues.

Oliver Grawert (ogra) on 2010-10-13
Changed in jasper-initramfs (Ubuntu Maverick):
status: New → Invalid
Emmet Hikory (persia) on 2010-10-13
Changed in ubuntu-netbook-efl-default-settings (Ubuntu Natty):
status: New → Invalid
Changed in jasper-initramfs (Ubuntu Maverick):
status: Invalid → Won't Fix
Changed in jasper-initramfs (Ubuntu Natty):
importance: Undecided → High
Changed in ubuntu-netbook-efl-default-settings (Ubuntu Maverick):
importance: Undecided → Medium
tags: added: natty omap omap4
Nicolas Dechesne (ndec) wrote :

@emmet: i think this only affects OMAP4 UNE image, not even OMAP3. Since our OMAP PPA is for OMAP4 only. I don't know if it helps you, but having the fix for -omap4 image is enough

Emmet Hikory (persia) on 2010-10-13
Changed in jasper-initramfs (Ubuntu Natty):
status: New → Triaged
Changed in ubuntu-netbook-efl-default-settings (Ubuntu Maverick):
status: New → Triaged
milestone: none → maverick-updates
Emmet Hikory (persia) wrote :

I realise that whilst I'm fussing with the cleanest way to integrate this with jasper and oem-config, someone else might want to actually test it :) So, I've attached the short python script that enables universe in a mirror-clean way using the python API. Feel free to play with it, or toss it in the ubuntu-netbook-efl-default-properties postinst (setting appropriately expanded dependencies) to test that as well (ought be trivial, either as something in /usr/share or as a here document passed into python). Proper patches pending completion of the investigation into when the apt-cache is updated and how during first boot for the jasper side (given that we need to sort this in future distributions before fixing in past, and the ubuntu-netbook-efl-default-properties way to solve it being unforgiveably bad as a proper solution, plus potentially not working properly when run as part of a livecd-rootfs build).

Oliver Grawert (ogra) wrote :

ubuntu-netbook-efl-default-settings fix uploaded to maverick-proposed

Accepted ubuntu-netbook-efl-default-settings into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ubuntu-netbook-efl-default-settings (Ubuntu Maverick):
status: Triaged → Fix Committed
tags: added: verification-needed
Steve Langasek (vorlon) wrote :

The ubuntu-netbook-efl-default-settings package that was uploaded to maverick-proposed is uninstallable, failing with this error:

Setting up ubuntu-netbook-efl-default-settings (0.8) ...
/var/lib/dpkg/info/ubuntu-netbook-efl-default-settings.postinst: 39: /usr/share/ubuntu-netbook-efl-default-settings/enable_additional_repos.py: Permission denied
dpkg: error processing ubuntu-netbook-efl-default-settings (--configure):
 subprocess installed post-installation script returned error exit status 126

The script in question is never installed executable. Please note that this script is not marked executable in the package. Perhaps you test-built from a bzr working directory where the file was marked executable, and this was not carried over when building the package?

Because this package is currently completely uninstallable and breaks linaro netbook-efl builds, which are to be released shortly after UDS, I am removing this broken package from maverick-proposed. Please reupload when you have a (fixed, install-tested) package available.

BTW, should this version check be "le-nl 0.7" rather than "le 0.7"? I don't see any reason to run this script on a new install, do you?

Changed in ubuntu-netbook-efl-default-settings (Ubuntu Maverick):
status: Fix Committed → Triaged
tags: added: rmel
removed: armel verification-needed
Oliver Grawert (ogra) wrote :

yes, you are right, i built from an exported bzr tree which seems to have removed the executable bits.
the script needs to run on *every* install, since livecd-rootfs leaves us without universe and multiverse by default, both are essential for the omap4 images so the addon pack installation works.

the repo addition should rather happen from jasper but since jasper changes would require new image builds we cant do it there for maverick (in natty we will)

On Sat, Oct 23, 2010 at 09:31:06AM -0000, Oliver Grawert wrote:
> the script needs to run on *every* install, since livecd-rootfs leaves us
> without universe and multiverse by default, both are essential for the
> omap4 images so the addon pack installation works.

Yes, but if the user doesn't already have this package installed, why should
installation of this package be a trigger for changing sources.list? I
presume you're using this package to fix up sources.list because it's one
that's installed by default on all of the affected images, so I don't see
why this applies to new installs of the package at all.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Oliver Grawert (ogra) wrote :

livecd-rootfs does not enable universe and multiverse by default, i am assuming there are reasons for this. would you recommend changing it in livecd-rootfs instead ? that way we would not need to do it on new installs at all.

Colin Watson (cjwatson) wrote :

Well, consider the case where somebody installs ubuntu-netbook-efl-default-settings on a system that has nothing to do with these preinstalled images. It clearly shouldn't edit sources.list in this situation.

The difference between le-nl and le is that the former happens when you install the package and it wasn't already installed, while the latter happens when upgrading the package from a previous version.

Is the miscommunication here that when Steve says "install" he means "dpkg -i ubuntu-netbook-efl-default-settings.deb", but when you (Oliver) say "install" you mean "install entire system that contains ubuntu-netbook-efl-default-settings"?

Tobin Davis (gruemaster) on 2010-11-23
tags: added: armel
removed: rmel
tags: added: iso-testing
Changed in jasper-initramfs (Ubuntu Natty):
assignee: nobody → Canonical ARM Developers (canonical-arm-dev)
Jani Monoses (jani) wrote :

should universe and multiverse be enabled in livecd-rootfs for the omap4 case?

Oliver Grawert (ogra) wrote :

no, we should not add another special for teh arm images, this should be eithe enabled by jasper or by oem-config during first boot (i'm not sure we can preseed apt-setup or if it is even executed if you use oem-config, but this seems like the best option)

Oliver Grawert (ogra) wrote :

(that was supposed to read "special case" above)

Changed in jasper-initramfs (Ubuntu Natty):
milestone: none → ubuntu-11.04-beta
Tobin Davis (gruemaster) on 2011-03-01
tags: added: bitesize
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jasper-initramfs - 0.44

---------------
jasper-initramfs (0.44) natty; urgency=low

  * enable universe and multiverse in the target rootfs (LP: #659754)
 -- Oliver Grawert <email address hidden> Thu, 17 Mar 2011 13:04:32 +0100

Changed in jasper-initramfs (Ubuntu Natty):
status: Triaged → Fix Released
Tobin Davis (gruemaster) on 2012-02-24
Changed in ubuntu-netbook-efl-default-settings (Ubuntu Maverick):
status: Triaged → Won't Fix
milestone: maverick-updates → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers