jackdbus fails to start: cannot allocate memory

Bug #1832651 reported by Ben Davis on 2019-06-12
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
systemd
Fix Released
Unknown
jackd2 (Ubuntu)
Undecided
Unassigned
Eoan
Undecided
Unassigned
systemd (Ubuntu)
High
Unassigned
Eoan
High
Unassigned

Bug Description

The `.log/jack/jackdbus.log` shows the following after trying to start/restart jack using "Ubuntu Studio Controls" (also tried using `jack_control start`):

    ERROR: Cannot lock down 82280346 byte memory area (Cannot allocate memory)

This is a fresh install of Ubuntu Studio 19.04, installed via USB. The first thing I did after installing was check to see if jack was running, but unfortunately it's not working. The error would seem to indicate that I'm not in the `audio` group, however checking `groups` shows that I am in the audio group.

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: jackd2 1.9.12~dfsg-2build1
ProcVersionSignature: Ubuntu 5.0.0-13.14-lowlatency 5.0.6
Uname: Linux 5.0.0-13-lowlatency x86_64
ApportVersion: 2.20.10-0ubuntu27
Architecture: amd64
CurrentDesktop: GNOME
Date: Wed Jun 12 18:13:25 2019
InstallationDate: Installed on 2019-06-12 (0 days ago)
InstallationMedia: Ubuntu-Studio 19.04 "Disco Dingo" - Release amd64 (20190416)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: jackd2
UpgradeStatus: No upgrade log present (probably fresh install)

Ben Davis (bendavis78) wrote :
Erich Eickmeyer (eeickmeyer) wrote :

Looks as though this was reported [1], and turns out is actually a bug in systemd <=240 [2]. Shows as fixed in systemd 241 [3].

[1] https://github.com/jackaudio/jack2/issues/429
[1] https://github.com/systemd/systemd/issues/11386
[2] https://github.com/systemd/systemd/pull/11448

no longer affects: jack
Changed in jackd2 (Ubuntu):
status: New → Invalid
Changed in systemd (Ubuntu):
status: New → Confirmed
Ben Davis (bendavis78) wrote :

How does one upgrade to systemd-241 in ubuntu?

Changed in systemd:
status: Unknown → Fix Released
Erich Eickmeyer (eeickmeyer) wrote :

@bendavis78 It's currently not possible. However, if you watch the natural progression of things, it's likely to land in Ubuntu 19.10 if the pattern of the past few releases holds.

Ben Davis (bendavis78) wrote :

Is there a workaround? This is currently breaking my entire audio setup (using Ubuntu Studio, where jackd is crucial)

tags: added: rls-ee-incoming
Changed in systemd (Ubuntu):
importance: Undecided → High
tags: removed: rls-ee-incoming
tags: added: id-5d0babe141a9fa1a8a1210f7
Hauke Wintjen (hwintjen) wrote :

I am also affected by this bug as it seems. I am also unable to start jackd2:

Thu Jul 4 08:17:50 2019: JACK server starting in realtime mode with priority 99
Thu Jul 4 08:17:50 2019: self-connect-mode is "Don't restrict self connect requests"
Thu Jul 4 08:17:50 2019: ERROR: Cannot lock down 82280346 byte memory area (Cannot allocate memory)

My systemd is:
hcw@nvidion:~$ dpkg -l systemd
+++-==============-==============-============-=================================
ii systemd 240-6ubuntu5.1 amd64 system and service manager

So is there a workaround / upgrade path? I dont want do wait 4 months before i can start podcasting..... 8-<

Kind regards

Hauke

Brian Murray (brian-murray) wrote :

I was unable to recreate this on an installation of Eoan, which will become Ubuntu 19.10, using systemd version 241-7ubuntu1 and jackd2 version 1.9.12~dfsg-2build1 subsequently I'm setting the Eoan task to Fix Released.

Changed in systemd (Ubuntu Eoan):
status: Confirmed → Fix Released
John Sweeney (john-sweeney) wrote :

This bug also affects me with jackdbus. I too need a workaround

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.