Jackd doesnt start on ARM Beagle board clone IGEPv2

Bug #643626 reported by Ricardo Lameiro
This bug affects 1 person
Affects Status Importance Assigned to Milestone
jackd-defaults (Ubuntu)

Bug Description

Runnig Jackd doesnt start the server, it hangs in there and if I execute the ps command the jackd pid is alive.

The command I ran was jackd -d alsa -p 256 -n 4 -P hw:0 -S -r 48000
I tried to run jackd_lsp resulting on a "hang situation" solved with crtl+c.
I run the jack with gdb to see if captured some inportant info about the problem.
attached will be the gdb output

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: jackd 5
Uname: Linux armv7l
Architecture: armel
Date: Mon Sep 20 16:10:34 2010
PackageArchitecture: all
SourcePackage: jackd-defaults

Revision history for this message
Ricardo Lameiro (rlameiro) wrote :
Revision history for this message
Ricardo Lameiro (rlameiro) wrote :

forgot to add the jack verbose output

tags: added: arm
Revision history for this message
munbi (gabriele) wrote :

Same problem here with origina BeagleBoard rev C2.

Revision history for this message
munbi (gabriele) wrote :

I've downloaded an image of Lucid from here:

and running jackd with the options in the bug description (i.e. jackd -d alsa -p 256 -n 4 -P hw:0 -S -r 48000) works well.

I've noticed that for enabling sound output in in Lucid you have to set the volumes relative to DAC1 (and Headset obviously) BUT in Maverick you have to adjust the DAC2 controls (because adjusting DAC1 control produces no effects).

Could this be related to jackd not starting in Maverick?

Revision history for this message
munbi (gabriele) wrote :

Attached some more debug info in one file (uname + package versions + strace + ltrace)

Revision history for this message
Ricardo Lameiro (rlameiro) wrote :

maybe it is because in maverick, the jack used is JACK2... i think JACK1 is available on maverick. i dont have time to test it right now, but i will check it in the future

Revision history for this message
munbi (gabriele) wrote :

Thanks Ricardo. I've replaced jackd2 with jackd1 package.
Now jackd starts ok with command "jackd -m -d alsa -p 256 -n 4 -P hw:0 -r -S 48000" but when I start fluidsynth I get this error on jackd log:

subgraph starting at fluidsynth timed out (subgraph_wait_fd=9, status = 0, state = Triggered, pollret = 0 revents = 0x0)

and fluidsynth seems to start but whenever I try to play a midifile it will not play anything because it's unable to allocate synthesis processes.

Starting jackd in non-realtime mode (jackd -r -m -d alsa -p 256 -n 4 -P hw:0 -r 48000) allows fluidsynth to connect, but then when I play some midifile I only get mono sound on the right channel! (note that this is not a mixer/muting issue because when playing a wav with aplay without jackd I get stero sound. Moreover everything works well in Lucid).

For the moment I will stay with Lucid, but can someone with more experience than me with jackd/fluidsynth on the Beagle post a working example for Maverick or give some suggestions on how I can help to debug the problem?

Btw, this is what works for me in Lucid.
jackd -m -d alsa -p 256 -n 4 -P hw:0 -S -r 48000
fluidsynth -a jack -r 48000 -c 16 -C 0 -R 0 -m alsa_seq -z 64 -j -l -o synth.polyphony=16 Unison.sf2

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.