jack-rack open file hangs

Bug #211798 reported by Steve MacDonald on 2008-04-04
34
Affects Status Importance Assigned to Milestone
jack-rack (Ubuntu)
Low
Unassigned
Nominated for Hardy by sole
Nominated for Intrepid by sole

Bug Description

Binary package hint: jack-rack

The open file dialog (gtk-2? glib?) for jack-rack hangs. Dialog window is responsive (you can press the cancel button to close the window, etc), but the busy mouse-cursor is present and no filenames are loaded into the window. Also, in the left-hand panel which shows the connected disk drives, there are two "blank spots" above my drives, where my home folder and desktop should be present.

I've attached a screenshot comparing the open-dialog from another gtk-2 app (Gnomebaker) which works fine, and the open-dialog from jack-rack.

Steve MacDonald (sjmacd) wrote :
Steve MacDonald (sjmacd) wrote :

This is actually a Hardy bug. Previous versions are ok.

Steve MacDonald (sjmacd) wrote :

the save and save as dialogs exhibit similar behaviour, as described in <a href="https://bugs.launchpad.net/ubuntu/+source/jack-rack/+bug/218789">bug 218789</a>.

Everything seems to work as per normal when compiled from the source package.

Eric Hedekar (stochastic) wrote :

I can confirm this bug. Are any attempts being made to resolve it?

Prot (euphobos) wrote :

Confirm. Because of it I cannot save my settings in jack-rack.

Prot (euphobos) on 2008-07-14
Changed in jack-rack:
status: New → Confirmed
qduaty (qduaty) wrote :

In order for this thing to work, Jack Rack has to be compiled with libgnomeui-dev installed in the system. This implies an additional dependency for libgnomeui-2.0 in the DEBIAN/control file.

shuste73 (shuste73+launchpad) wrote :

I disagree with Steve MacDonald - I experienced this same bug on Gutsy.

For Prot: my workaround has been to install the older version and lock it in Synaptic so it doesn't get overwritten... though it eventually will and you'll have to yank it out and install your (hopefully) saved older .deb and re-lock it.

This has been an issue for a long time, actually.

variona (variona) wrote :

I have this bug since Hardy.
My workaround:
About loading a preset you can use the commandline. (See jack-rack --?).
You can also save the changes you make. (Pressing Save). To emulate 'Save As' you have to make a copy of an existing preset, load it via commandline and after making changes press Save

HTH until this annoying bug is fixed.

I confirm that compiling from source with libgnomeui-dev is the correct fix for this: The package in repository should be recompiled with dependency on libgnomeui-dev.

I took a quick glance at the jack-rack code and the it seems that the problem is probably not explicitly in the jack-rack. The open and save dialogs used in the code are GtkFileChooserDialogs, so I'd guess that the Ubuntu version of GtkFileChooserDialog is dependent on libgnomeui...

bleakapathy (bleakapathy) wrote :

So... I'm a bit new to this, but I tried to do what you guys suggested and just get an older version of jack rack... But There is no listing for it in the synaptic package manager... Is there some sort of third party repository that I can get a previous version through/ Because I'm finding nothing and getting quite frustrated. It doesn't help that I'm a complete newb and have no idea despite reading help files as to how to compile the .trz for the version 1.4.4 that I did manage to find.

uhg.. any advice?

shuste73 (shuste73+launchpad) wrote :

You can download an old .deb and install it. Version 1.4.4-4 should work just fine. I haven't tried recompiling. Just grab it from the old Debian "Sid" repositories.

http://packages.debian.org/unstable/jack-rack

In other news, this still isn't fixed in Intrepid Ibex. But, like I said, haven't tried recompiling because it's easier to stick with the old version unless there have been significant enough fixes in 1.7 to warrant the upgrade.

randomas (randomas) wrote :

Confirmed for hardy 64 bit.

Still no fix?

Steve MacDonald (sjmacd) wrote :

I'd like to start maintaining this package, if nobody minds. I just have to figure out how to do that. Hopefully, I'll have a day to figure that out by the weekend, and put something together.

Eric Hedekar (stochastic) wrote :

This is my first attempt at making a patch, hopefully it takes care of this bug.

Luca Falavigna (dktrkranz) wrote :

Sponsored, thanks!

Changed in jack-rack:
importance: Undecided → Low
status: Confirmed → Fix Committed
Luca Falavigna (dktrkranz) wrote :

jack-rack (1.4.7-0ubuntu2) jaunty; urgency=low

  * Added libgnomeui-dev to build dep (closes: #211798)

 -- Eric Hedekar <email address hidden> Mon, 12 Jan 2009 22:48:21 -0800

Changed in jack-rack:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers