erroneous text in jack daemon init script

Bug #366978 reported by J G Miller on 2009-04-25
2
Affects Status Importance Assigned to Milestone
jack-audio-connection-kit (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: jackd

The init startup script jackd contains the following text

# Short-Description: init-Script for system wide fetchmail daemon
### END INIT INFO
#
# A fetchmailrc file containg hosts and passwords for all local users should be
# placed in /etc/fetchmailrc. Remember to make the /etc/fetchmailrc mode 600
# to avoid disclosing the users' passwords.
#
# This script will NOT start or stop fetchmail if the /etc/fetchmailrc file
# does not exist or /etc/default/fetchmail is set to no.

This text describes the action of fetchmail which has nothing whatsoever to do with jackd.

Description: Ubuntu 9.04
Release: 9.04
Source: jack-audio-connection-kit
Version: 0.116.1-3ubuntu3

What one expects to happen: The above text is replaced with a meaningful summary of the function of the jackd startup script.

I think bug #421467 is caused by this bug (#366978).

a_flj_ (flj-mail) wrote :

Also present in 9.10/karmic koala, but I suspect its source is the jack codebase, and the script is not edited by the ubuntu packagers.

Emmet Hikory (persia) wrote :

This is indeed completely wrong :) jackd no longer shipts any init file, so no longer needs to have useful information there. There's no reason to bother attempting a stable release update, as this is entirely cosmetic: the body of the script actually does the right thing, even if the author copied it from fetchmail as a template.

Changed in jack-audio-connection-kit (Ubuntu):
importance: Undecided → Wishlist
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers