Jack has loads of xruns after upgrading from Ubuntu Studio 19.04 to 19.10

Bug #1870630 reported by Lassi on 2020-04-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
jack-audio-connection-kit (Ubuntu)
Undecided
Unassigned

Bug Description

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=19.10
DISTRIB_CODENAME=eoan
DISTRIB_DESCRIPTION="Ubuntu 19.10"

Used software:
QJackCtl
Guitarix

Before upgrading there were no xruns experienced with the exact same QJackCtl configuration. After upgrading from 19.04 to 19.10 there is a flood of xruns every second.

Starting Jack from QJackCtl, the Messages window shows Jack is started with the following command line:

creating alsa driver ... hw:USB|hw:USB|128|3|48000|0|0|nomon|swmeter|-|32bit
configuring for 48000Hz, period = 128 frames (2.7 ms), buffer = 3 periods

Then moving windows, mouse or similar causes xruns. When enabling Xfce compositing from Window Manager Tweaks, the xruns are coming in like crazy.

So looks like this is potentially related to graphics drivers, perhaps?

Disabling compositing relieves the issue somewhat, but still moving windows etc. creates xruns fairly easily. There were no similar issues in Ubuntu Studio 19.04.

$ dmesg |grep nouveau
[ 3.725494] nouveau 0000:02:00.0: NVIDIA MCP77/MCP78 (0aa480a2)
[ 3.738960] nouveau 0000:02:00.0: bios: version 62.77.35.00.00
[ 3.772469] nouveau 0000:02:00.0: fb: 512 MiB stolen system memory
[ 4.200225] nouveau 0000:02:00.0: DRM: VRAM: 512 MiB
[ 4.200227] nouveau 0000:02:00.0: DRM: GART: 1048576 MiB
[ 4.200230] nouveau 0000:02:00.0: DRM: TMDS table version 2.0
[ 4.200231] nouveau 0000:02:00.0: DRM: DCB version 4.0
[ 4.200234] nouveau 0000:02:00.0: DRM: DCB outp 00: 01000300 0000001e
[ 4.200236] nouveau 0000:02:00.0: DRM: DCB outp 01: 01011332 00020010
[ 4.200237] nouveau 0000:02:00.0: DRM: DCB conn 00: 00000000
[ 4.200238] nouveau 0000:02:00.0: DRM: DCB conn 01: 00003161
[ 4.204148] nouveau 0000:02:00.0: DRM: MM: using M2MF for buffer copies
[ 4.243766] nouveau 0000:02:00.0: DRM: allocated 1920x1080 fb: 0x50000, bo 0000000008947388
[ 4.243854] fbcon: nouveaufb (fb0) is primary device
[ 4.289493] nouveau 0000:02:00.0: fb0: nouveaufb frame buffer device
[ 4.296591] [drm] Initialized nouveau 1.3.1 20120801 for 0000:02:00.0 on minor 0

Lassi (lassi-vaatamoinen) wrote :

A sort of workaround seems to be using the Studio Controls: https://help.ubuntu.com/community/UbuntuStudio/UbuntuStudioControls

And at the same time disabling compositing from Window Manager Tweaks. But in Ubuntu Studio 19.04 the it was OK to leave compositing on.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1870630/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → jack-audio-connection-kit (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers