Jabberd2 fails to install (cannot create directory `':)

Bug #147157 reported by emil.s
4
Affects Status Importance Assigned to Milestone
jabberd2 (Ubuntu)
Medium
Lionel Porcheron

Bug Description

Binary package hint: jabberd2-mysql

When i tried to install it, i got this message:

root@Megaleif:~# LANG="C" apt-get --reinstall install jabberd2-mysql
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 0B of archives.
After unpacking 0B of additional disk space will be used.
Do you want to continue [Y/n]?
Setting up jabberd2-mysql (2.0s11-1ubuntu1) ...
mkdir: cannot create directory `': No such file or directory
invoke-rc.d: initscript jabberd2-mysql, action "start" failed.
dpkg: error processing jabberd2-mysql (--configure):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 jabberd2-mysql
E: Sub-process /usr/bin/dpkg returned an error code (1)

Related branches

Revision history for this message
emil.s (emil.s) wrote :

And after that i had removed it, and tried to install it again, i get more errors... (see apt-get errors).

Revision history for this message
Miles Elam (nospamelam) wrote :

I'm getting the same thing with the jabberd2-pgsql package. After a failed install, it appears locked. I cannot remove it, purge it, or reinstall it.

Removing jabberd2-pgsql . ..
mkdir: cannot create directory `': No such file or directory
invoke-rc.d: initscript jabberd2-pgsql, action "stop" failed.
dpkg: error processing jabber2d-pgsql (--remove):
 subprocess pre-removal script returned error exit status 1
mkdir: cannot create directory `': No such file or directory
invoke-rc.d: initscript jabberd2-pgsql, action "start" failed.
dpkg: error while cleaning up:
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 jabber2d-pgsql
E: Sub-process /usr/bin/dpkg returned an error code (1)

Revision history for this message
Miles Elam (nospamelam) wrote :

Haven't figured out the cause, but anyone wanting to clean up the blockage can remove all files and directories listed in /var/lib/dpkg/info/jabberd2-pgsql.list

After they're all removed, use aptitude, apt-get, or synaptic to remove the package. I would assume this would work for jabberd2-mysql as well.

Revision history for this message
Lionel Porcheron (lionel.porcheron) wrote :

Thanks for taking time to report this bug. I can confirm this bug and I can confirm this is my fault :). I'm preparing a new upload which should reach archive tomorrow.

Changed in jabberd2:
assignee: nobody → lionel.porcheron
importance: Undecided → Medium
status: New → Confirmed
Revision history for this message
Lionel Porcheron (lionel.porcheron) wrote :

jabberd2 (2.0s11-1ubuntu2) gutsy; urgency=low

  * debian/jabberd2.init: correct typo in pid directory creation
      (LP: #147157)
  * really modify Maintainer value to match Debian-Maintainer-Field Spec

 -- Lionel Porcheron <email address hidden> Mon, 08 Oct 2007 00:53:24 +0200

Changed in jabberd2:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers