Please update iwd to >=v2.3 (sync with Debian)

Bug #2012071 reported by Matthieu Baerts
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
iwd (Ubuntu)
New
Undecided
Unassigned

Bug Description

Hello,

Thank you for maintaining IWD package in Ubuntu.

I just noticed the version in lunar is out of sync with Debian: v1.30 vs 2.3.

The v2.3 has a few interesting bug fixes:

  https://git.kernel.org/pub/scm/network/wireless/iwd.git/tree/ChangeLog

There are some modifications specific to Ubuntu in the Ubuntu package. I guess that's why it has not been sync with Debian because I don't see it in the "update excuses" webpage.

  https://ubuntu-archive-team.ubuntu.com/proposed-migration/lunar/update_excuses.html#iwd

Revision history for this message
Hans Joachim Desserud (hjd) wrote :

Thanks for reporting.

>There are some modifications specific to Ubuntu in the Ubuntu package. I guess that's why it has not been sync with Debian

Correct. Whenever there's an Ubuntu delta, those packages are no longer synced automatically from Debian. Instead newer versions are either manually merged to get the newer version with the Ubuntu-specific changes or if the changes have been incorporated in Debian or upstream a sync is requested.

In this case, I see bug 2012081 has some discussion on whether to get a freeze exception in order to upgrade this package before Lunar release. I've therefore marked this as a duplicate.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.