"power down" request fails on 9.04; logout instead

Bug #367960 reported by gennaker on 2009-04-27
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
italc (Ubuntu)
Medium
vaasusk

Bug Description

Issuing a power down request to an italc client (1.0.9) running on jaunty (9.04) causes the system only to arrive at the gdm login screen.

This is reproducible through either clean install of jaunty and italc 1.0.9 or by updating from intrepid (shutdown request works on intrepid client, fails after upgrade to jaunty). It does not matter whether the shutdown request comes from italc-master on 8.10 or 9.04.

Related branches

defishguy (mkfischer) wrote :

I can confirm. Ubuntu 9.04 with a lab of 20 machines. My symptoms are the same as the reported bug.

toogreen (toogreen-hotmail) wrote :

I can also confirm this. Worked fine under intrepid in my 29 computers lab, now doesn't work anymore after upgrading to Jaunty. :-(

Does anyone at least have a workaround/fix/patch or any tricks to make it work? School starts next week so it'd be nice to have this working somehow!

Thanks!

ericlesoll (ericlesoll) wrote :

I can also confirm. We tried also with a fresh install.

Dimitrios Dalagiorgos (dimndal) wrote :

I can also confirm this bug. Ubuntu 9.04 with a lab of 1 server and 12 clients.

Alkis Georgopoulos (alkisg) wrote :

The relevant source code line is:
  QProcess::startDetached( "gdm-signal -h" ); // Gnome shutdown

The first problem with that is that gdm-signal in the "powermanagement-interface" package, which isn't preinstalled in a standard Ubuntu installation.
The second problem is that even if one installs that package, gdm-signal -h seems to no longer work.

A simple workaround is to not install the powermanagement-interface package, but to create a /usr/bin/gdm-signal script instead with the following contents:
#!/bin/sh
gnome-power-cmd shutdown
(don't forget to chmod +x the script)

Unfortunately, gnome-power-cmd is no longer there in Karmic.
Someone should ask the gnome people for a stable way to poweroff without having sudo priviledges and without modifying the sudoers file. :)

Changed in italc (Ubuntu):
status: New → Confirmed
vaasusk (3000vasu) wrote :

Good work

Changed in italc (Ubuntu):
assignee: nobody → vaasusk (3000vasu)
Stéphane Graber (stgraber) wrote :

Can you confirm it's still happening in Karmic ?
I'd suspect that with the new gdm it's probably even worse but would appreciate confirmation of that.

Changed in italc (Ubuntu):
status: Confirmed → Incomplete
importance: Undecided → Medium
Alkis Georgopoulos (alkisg) wrote :

I think I found a better method, via d-bus.

The attached "reboot.py" works for me on Karmic/Gnome, could someone report if it works on other versions/DEs?
(i.e. if "python reboot.py" reboots the PC without needing root privileges).

If it works, I'll try to send a debdiff for iTalc.

Alkis Georgopoulos (alkisg) wrote :

Better yet, try the following on a client:

1) Ensure that you *don't* have the package "powermanagement-interface" installed (which provides `gdm-signal`).

2) Copy the attached file to /usr/bin/gdm-signal, and make it executable:
sudo cp ~/gdm-signal /usr/bin
sudo chmod +x /usr/bin/gdm-signal

3) *Temporarily*, remove the executable attribute from gnome-session-save, which is called by iTalc and overrides the shutdown command (remember to restore it after the test):
sudo chmod -x /usr/bin/gnome-session-save

4) Then start iTalc normally on the server and try to reboot or shutdown the client. Hopefully it should work (it does for me).

Alkis Georgopoulos (alkisg) wrote :

Sending the attachement, which I forgot... :(

Alkis Georgopoulos (alkisg) wrote :

I'm attaching a patch which makes iTalc call the gnome SessionManager via dbus for logout / reboot / shutdown. Now iTalc works properly for me on Ubuntu Karmic (and it should also work for at least Jaunty and Lucid).

If anyone wants to try the patch, I've uploaded a Karmic package in this ppa: https://launchpad.net/~ts.sch.gr/+archive/proposed

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package italc - 1:1.0.9.1-0ubuntu18

---------------
italc (1:1.0.9.1-0ubuntu18) lucid; urgency=low

  * Add patch to iTalc to use DBUS calls for gnome (LP: #367960)
 -- Stephane Graber <email address hidden> Tue, 09 Feb 2010 09:38:13 -0500

Changed in italc (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments