Import Error: No module named ltihooks

Bug #68321 reported by kenc on 2006-10-26
22
Affects Status Importance Assigned to Milestone
Istanbul
Unknown
Critical
istanbul (Ubuntu)
Medium
Unassigned

Bug Description

I'm on Edgy, and I get this:

Traceback (most recent call last):
  File "/usr/bin/istanbul", line 30, in ?
    from istanbul.main import main
  File "/usr/lib/python2.4/site-packages/istanbul/main/main.py", line 25, in ?
  File "/usr/lib/python2.4/site-packages/PIL/__init__.py", line 21, in ?

ImportError: No module named ltihooks

When I run istanbul. Note, I was able to compile it from official source ...

Peter Lundqvist (peterl) wrote :

I haven't had time to look into it, but this seems to hold a clue:

http://webcvs.freedesktop.org/gstreamer/gst-python/ltihooks.py?view=log

Revision 1.3
Fri Sep 29 09:53:11 2006 UTC (5 weeks, 1 day ago) by bilboed
Branch: MAIN
CVS Tags: HEAD
Changes since 1.2: +0 -0 lines
FILE REMOVED

* ltihooks.py:
Removed
* testsuite/common.py:
ltihooks is dead, long live gstltihooks. This should complete thomas'
fix of #357310.

Erik Bågfors (zindar) wrote :

For me in edgy, this is caused by an old installation of istanbul, where the .pyc and .pyo files was not removed correctly. The .py files was gone...

I did the following
sudo apt-get remove --purge istanbul

found that I still had files under /usr/lib/python2.4/site-packages/istanbul/ with extensions .pyc and .pyo.
sudo rm -rf /usr/lib/python2.4/site-packages/istanbul/

sudo apt-get install istanbul

Now it works... (well, at least starts, haven't tried it yet)

/Erik

Andrew Jorgensen (ajorg) wrote :

Bug exists, analysis is correct, workaround works for me.

Changed in istanbul:
status: Unconfirmed → Confirmed
Changed in istanbul:
importance: Undecided → Medium
sog (sogrady) wrote :

same error, same fix.

Changed in istanbul:
status: Unknown → Rejected

Why is this bug rejected? It's very much a legitimate bug in the packaging system. Purging the package, then removing /usr/lib/python2.4/site-packages/istanbul fixes it. This directory doesn't get recreated on reinstall, so apparently it's left over from some previous version, and the packaging scripts failed to properly clean up during some upgrade.

Note that I initially installed Istanbul while running Dapper. Now, I'm running Edgy.

pablodiazgutierrez (pablo-ics) wrote :

I believe only the upstream bug report has been rejected. This means that the problem is not related to the software itself, but only with the packaging. Therefore, Istanbul developers need not be bothered with it.

BTW, the workaround seems to work for me too.

Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10 alpha?

Changed in istanbul:
status: Confirmed → Incomplete
Javier Jardón (jjardon) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in istanbul:
status: Incomplete → Invalid
Changed in istanbul:
importance: Unknown → Critical
status: Invalid → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.