cdrom/codename and suite no longer set in debconf

Bug #839830 reported by Sylvain Dansereau on 2011-09-02
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
iso-scan (Debian)
Fix Released
Undecided
Unassigned
iso-scan (Ubuntu)
Undecided
Unassigned

Bug Description

Hello,

When installing oneiric beta 1 with the hd-media image, the iso-scan udeb is searching for an iso on a disk but when one is selected, the script does not try to update the cdrom/codename and cdrom/suite properties in debconf as dit previous versions like 1.31ubuntu1.
The installation later stops on error base-installer/no_codename when installing the base system.

I would think that the debian package has the same problem as the ubuntu package was recently updated from the debian package.

I have incuded a proposed patch for iso-scan.postinst that gets the values and update debconf.
This might not be the best way to fix this but it works for me and the installer can move past installing the base system.

The installer boot image I am using is from
archive.ubuntu.com/ubuntu/dists/oneiric/main/installer-amd64/beta-1/images/hd-media/
the udeb.list file says that the package version of iso-scan is 1.35ubuntu1

description: updated
Sérgio Faria (sergio91pt) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.
Confirmed as upstream v1.36 fixes this bug.

Changed in iso-scan (Debian):
status: New → Fix Released
Changed in iso-scan (Ubuntu):
status: New → Confirmed

The attachment "set codename and suite for selected iso" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers