Unable to load isight firmware after extraction

Bug #762128 reported by robin.nightingale on 2011-04-15
This bug affects 11 people
Affects Status Importance Assigned to Milestone
isight-firmware-tools (Ubuntu)

Bug Description

Binary package hint: isight-firmware-tools

After succesfull installation and extraction of the isight-firmware-tools my macbook is unable to load the firmware.
So iam unable to use the cam.

here the terminal
pirate@ship:~$ lsusb
Bus 002 Device 003: ID 05ac:8300 Apple, Inc. Built-in iSight (no firmware loaded)

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: isight-firmware-tools 1.4.2-4
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: wl
Architecture: amd64
Date: Fri Apr 15 21:31:36 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64+mac (20110410)
SourcePackage: isight-firmware-tools
UpgradeStatus: No upgrade log present (probably fresh install)

Michael Schmid (mschmid-gmx) wrote :

I think I have the same problem:

-> Isight firmware is in /lib/firmware/isight.fw
-> ls usb says: Bus 001 Device 003: ID 05ac:8300 Apple, Inc. Built-in iSight (no firmware loaded)
-> i get a message like: unable to load isight firmware or so

--> I have natty stable on a Macbook 2,1

--> Installed and deinstalled isight-firmware-tools several times. Had no errors. On 10.10 my isight worked well

--> Can I help to solve the problem (if it is one)?

Hello Michael,
untill now iam unable to fix this problem.
I reinstalled the firmware several times but without sucess.
Stil the same problems.

Lennart Regebro (regebro-gmail) wrote :

This also affects me. I've tried with isight-firware-tools 1.6 from source, and there was no difference.

I have a Macbook 4,1.
This worked under 10.04, but not 11.04.

Bus 002 Device 003: ID 05ac:8300 Apple, Inc. Built-in iSight (no firmware loaded)

ls -l /lib/firmware/isight.fw:
-rw-r--r-- 1 root root 10871 2011-05-06 11:43 /lib/firmware/isight.fw

Michael Schmid (mschmid-gmx) wrote :

After an update of insight-firmware-tools 1.4 I can use Skype, Cheese and Other by preloading "LD_PRELOAD=/usr/lib32/libv4l/v4l2convert.so"

Example with Skype: "LD_PRELOAD=/usr/lib32/libv4l/v4l2convert.so skype"

Strangely enough, VLC works without preloading...

Alan Aversa (aversa) wrote :

Yes, I have the same problem on a MacBook 2,1.

ferriol (ostres) wrote :

I have the same problem, I have one macbook 2.1 and one macbook 3.1 both with this problem.
I execute:
LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so skype

Lennart Regebro (regebro-gmail) wrote :

My "/usr/local/etc/udev/rules.d/isight.rules" files had idProduct set to 8300, while lsusb showed that the product id is 8501. Modifying isight.rules to

ACTION=="add", ATTRS{idVendor}=="05ac", ATTRS{idProduct}=="8501", RUN+="/usr/local/lib/udev/ift-load --firmware /lib/firmware/isight.fw"

Fixed the problem for me. This is probably a bug in the tools that sets the wrong product id.

Lennart Regebro (regebro-gmail) wrote :

(I still have to do the LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so skype thingy, but that is a different bug.)

andresimi (andresimi) wrote :

In my case, a macbook 5,1

I am able to see Buil-in-ishight on gstreamer-properties. Like Mikael Schmid, it works perfectly on VLC. But when using cheese or skype, the green light turns on and the only thing I see it is a total black where it suposed to be the image.

The sugestion made by Lennart didn't worked too

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in isight-firmware-tools (Ubuntu):
status: New → Confirmed
Andy Barnes (kurgol) wrote :

for me a iMac 5,2 get the same issue.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers