Macbook Pro 15 Haswell/Retina 11.1 Webcam/iSight Does Not Work (Ubuntu 13.10)

Bug #1247476 reported by Krzysztof Janowicz on 2013-11-02
114
This bug affects 20 people
Affects Status Importance Assigned to Milestone
isight-firmware-tools (Ubuntu)
Undecided
Unassigned

Bug Description

On the new Macbook Pro 15 Haswell/Retina 11.1 Webcam/iSight does not work (Ubuntu 13.10). I tried installing isight-firmware-tools and selected the right firmware. The installation was successful but the camera does not work. Gstreamer-properties reports that /dev/video0 is missing.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1247476/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → isight-firmware-tools (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in isight-firmware-tools (Ubuntu):
status: New → Confirmed
Craig Magina (craig.magina) wrote :

I can report that this issue also occurs on the 13" Macbook Pro 11,1.

Chris Kankiewicz (phlak) wrote :

I don't even see the camera with 'lsusb':

$ sudo lsusb
Bus 002 Device 002: ID 05ac:8406 Apple, Inc.
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 011: ID 05ac:8289 Apple, Inc.
Bus 001 Device 004: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Bus 001 Device 008: ID 05ac:0304 Apple, Inc. Optical USB Mouse [Mitsumi]
Bus 001 Device 007: ID 05ac:0220 Apple, Inc. Aluminum Keyboard (ANSI)
Bus 001 Device 006: ID 0bc2:3320 Seagate RSS LLC SRD00F2 [Expansion Desktop Drive]
Bus 001 Device 003: ID 05ac:1006 Apple, Inc. Hub in Aluminum Keyboard
Bus 001 Device 005: ID 05ac:0262 Apple, Inc.
Bus 001 Device 002: ID 051d:0002 American Power Conversion Uninterruptible Power Supply
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

psanford (pms-mail) wrote :

The camera doesn't show up with `lsusb` because it uses a PCIe interface in the new Pro Retina models. In `lspci` the device looks like this:

02:00.0 Multimedia controller: Broadcom Corporation Device 1570

It doesn't look like there are any linux drivers for this webcam yet.

Dharm (dharmveer-jha) wrote :

Hi,
Have tried installing Ubuntu12.04,13.10 on Macbook Pro 11.1 but in-built camera doesn't work at all .cheese and similar apps reports /dev/video0 is missing .

Have try to mount the HD and got iSight.fm as well using isight-firmware-tools successfully but no luck ,please suggest how we can fix this issue .

Thanks
Dharm

Dharm (dharmveer-jha) wrote :

On the other hand External WebCam works :)

rebroad (rebroad) wrote :

What is happening regarding this? Is it being progressed?

Krzysztof Janowicz (janowicz) wrote :

Not that I would know of :-(.

benhuan (benhuan) wrote :

ubuntu 14.04.1 MacBook Pro 11.3
also have this problem

medb (medb) wrote :

Ubuntu 15.04 has the same problem

Ivo Xavier (ivoxavier) wrote :

Same happens on the macbook pro retina mid 2014, both 14.04.2 and 15.04.

Seth (sethniels) wrote :

As mentioned in the bugzilla link above, there is no driver for the new PCIe camera, but someone is working on it. It is a slow difficult reverse engineering job.

To find out more about the effort to resolve this, go to https://github.com/patjak/bcwc_pcie. Or if you want to see what you can do to help, go straight to https://github.com/patjak/bcwc_pcie/wiki#how-can-i-help.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.