[intrepid] Can not stop iscsitarget

Bug #278625 reported by Christian Roessner on 2008-10-05
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
iscsitarget (Ubuntu)
Medium
Dustin Kirkland 
Intrepid
Medium
Dustin Kirkland 
linux (Ubuntu)
Medium
Stefan Bader
Intrepid
Medium
Stefan Bader

Bug Description

Binary package hint: iscsitarget

I have a very trivial iscsitarget setup:

cat /etc/ietd.conf
# iscsi target configuration
#

Target iqn.2008-09.de.roessner-net:storage.disk0
 IncomingUser iscsitest XXXX
 OutgoingUser iscsitest XXXX
 Lun 0 Path=/dev/vg01/lv_iscsi,Type=fileio

/etc/init.d/iscsitarget stop
Removing iSCSI enterprise target devices: succeeded.
Stopping iSCSI enterprise target service: succeeded.
Removing iSCSI enterprise target modules: FATAL: Module iscsi_trgt is in use.
failed.

ps auxc | grep ist
root 6876 0.0 0.0 0 0 ? S< 16:48 0:00 istd1
root 6877 0.0 0.0 0 0 ? S< 16:48 0:00 istiod1
root 6878 0.0 0.0 0 0 ? S< 16:48 0:00 istiod1
root 6879 0.0 0.0 0 0 ? S< 16:48 0:00 istiod1
root 6880 0.0 0.0 0 0 ? S< 16:48 0:00 istiod1
root 6881 0.0 0.0 0 0 ? S< 16:48 0:00 istiod1
root 6882 0.0 0.0 0 0 ? S< 16:48 0:00 istiod1
root 6883 0.0 0.0 0 0 ? S< 16:48 0:00 istiod1
root 6884 0.0 0.0 0 0 ? S< 16:48 0:00 istiod1

lsb_release -rd
Description: Ubuntu intrepid (development branch)
Release: 8.10

dpkg -l iscsitarget
Gewünscht=Unbekannt/Installieren/R=Entfernen/P=Vollständig Löschen/Halten
| Status=Nicht/Installiert/Config/U=Entpackt/Fehlgeschl. Konfiguration/
         Halb installiert/Trigger erWartet/Trigger anhängig
|/ Fehler?=(kein)/Halten/R=Neuinst notw/X=beide (Status, Fehler: GROSS=schlecht)
||/ Name Version Beschreibung
+++-=============================-=============================-==========================================================================
pi iscsitarget 0.4.15+svn148-2.1ubuntu2 iSCSI Enterprise Target userland tools

Expected normal stop

rhalff (rhalff) wrote :

I can confirm the same with a similar configuration

Stefan Bader (smb) wrote :

Currently investigating some missing bits compared to previous versions. I will put in some updates as soon as those have been resolved.

Changed in iscsitarget:
assignee: nobody → stefan-bader-canonical
importance: Undecided → Medium
status: New → In Progress
Tuomas Jormola (tjormola) wrote :

I can confirm this also. I had a working iSCSI target setup with hardy. Also very simple configuration, no authentication or anything special, just some LVM2 LVs exported as blockio. But after upgrading to intrepid, it stopped working.

Tuomas Jormola (tjormola) wrote :

The Debian iscsitarget package version 0.4.16+svn162-2 (http://packages.debian.org/lenny/iscsitarget) seems to work fine. I downloaded the source package from a Debian mirror, created binary packages on the Intrepid system from the source, installed newly produced debs, compiled new iscsi_trgt module against linux-headers-2.6.27-7-server, replaced the stock Ubuntu iscsi_trgt module of linux-image-2.6.27-7-server with the new one, rebooted and the iSCSI service is now working again. Please upload fixed iscsitarget to intrepid-proposed. Thanks.

Dustin Kirkland  (kirkland) wrote :

I added a linux-image task.

It appears to me that the iscsi_trgt.ko provided by the Ubuntu kernel is buggy, and won't unload properly.

This is causing a nasty problem on package upgrade of iscsitarget in Jaunty (I'm working on the merge), because the initscript is "stopped" in the prerm, but this *always* fails if the module isn't unloaded.

:-Dustin

Changed in linux-meta:
importance: Undecided → Medium
status: New → Confirmed
Dustin Kirkland  (kirkland) wrote :

Also, I just merged iscsitarget_0.4.16+svn162-2ubuntu1 for Jaunty.

But package upgrades will fail until we get the module unloading working properly.

As a workaround in the meantime in Jaunty, you can:
 $ sudo service iscsitarget stop
 $ sudo mv /etc/init.d/iscitarget /tmp
 $ sudo apt-get update
 $ sudo apt-get upgrade iscsitarget
 (Accept the package maintainer's new init script)

:-Dustin

Dustin Kirkland  (kirkland) wrote :

And using the new, Jaunty init script, module unload failures are reported by the init script, but are not FATAL. ie, they do not exit 1.

:-Dustin

Stefan Bader (smb) wrote :

The updated iscsidriver has been added to Intrepid (not yet included in 10.20)
UBUNTU: iscsitarget: Update to official 0.4.16 driver
also one additional patch, since the driver from upstream fails to compile in Intrepid:
UBUNTU: Fix compile error after updating iscsitarget

Changed in iscsitarget:
status: In Progress → Fix Committed
Steve Langasek (vorlon) wrote :

Accepted into intrepid-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Can confirm: Update fixed the bug here

BTY: Please consider changes to the init-script, to load an optional /etc/default/iscsitarget. Because DAEMON_OPTS are missing, therefor a iscstarget may not be bound to a specific ip address. I do not want to open a new bug for such a little thing. Thx.

Věroš Kaplan (veros-kaplan) wrote :

Can confirm: bug fixed also on amd64.

X.Y. (fixy67) wrote :

I tried to use the proposed update but I didn't find the new version. I found only 0.4.15+svn148-2.1ubuntu2. (Currently I'm using intrepid amd64)
Is it my fault or something gone wrong?

Steve Beattie (sbeattie) on 2009-01-22
Changed in linux-meta:
status: New → Invalid
Changed in iscsitarget:
assignee: nobody → stefan-bader-canonical
importance: Undecided → Medium
status: New → Fix Committed
Steve Beattie (sbeattie) wrote :

Sorry for the noise, I'd assumed there was actually a package in intrepid-proposed, based on Steve Langasek's comment. Is there going to be one? If not, please close out the intrepid task. Thanks.

Changed in iscsitarget:
status: Fix Committed → In Progress
Stefan Bader (smb) wrote :

The actual bug was part of the kernel source.

Changed in linux-meta:
assignee: nobody → stefan-bader-canonical
status: Confirmed → In Progress
Stefan Bader (smb) wrote :

In Jaunty (current trunk) the iscsitarget code is 0.4.17.

Changed in linux:
status: In Progress → Invalid
Stefan Bader (smb) wrote :

In Intrepid the fix was released with 2.6.27-11.21.

Changed in linux:
assignee: nobody → stefan-bader-canonical
importance: Undecided → Medium
status: Invalid → Fix Released
Stefan Bader (smb) wrote :

Dustin, I am assigning the iscsitarget package task to you since I don't know the exact status.

Changed in iscsitarget:
assignee: stefan-bader-canonical → kirkland
status: Fix Committed → Triaged
assignee: stefan-bader-canonical → kirkland
status: In Progress → Triaged
Changed in iscsitarget (Ubuntu Intrepid):
status: Triaged → Won't Fix
Changed in iscsitarget (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers