[Trusty] iscsitarget-dkms 1.4.20.3+svn499-0ubuntu2.1 fails to build on linux-generic-lts-xenial kernel

Bug #1612627 reported by fmyoen on 2016-08-12
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
iscsitarget (Ubuntu)
Undecided
Unassigned
Trusty
High
Unassigned

Bug Description

[Impact]

 * The iscsitarget-dkms package was not updated to be compatible with the Xenial HWE stack (4.4 kernel) and the driver fails to build.

[Test Case]

 * Install iscsitarget-dkms. If it successfully builds and the module is loadable, the package is fixed.

[Regression Potential]

 * Given that the package currently does not function for the Xenial stack, I believe the regression potential is low. However, the one case would be breaking existing 3.13.x deployments of 14.04; in my testing, the DKMS package successfully builds there as well.

---

1) The release of Ubuntu you are using, via 'lsb_release -rd' or System -> About Ubuntu
# lsb_release -rd
Ubuntu 14.04.5 LTS
Release: 14.04

2) The version of the package you are using, via 'apt-cache policy pkgname' or by checking in Software Center
# apt-cache policy iscsitarget-dkms
iscsitarget-dkms:
  Installed: 1.4.20.3+svn499-0ubuntu2.1
  Candidate: 1.4.20.3+svn499-0ubuntu2.1
  Version table:
*** 1.4.20.3+svn499-0ubuntu2.1 0
        500 http://...archive.ubuntu.com/ubuntu/ trusty-updates/universe amd64 Packages
        100 /var/lib/dpkg/status
     1.4.20.3+svn499-0ubuntu2 0
        500 http://...archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages

3) What you expected to happen
iscsitarget-dkms module should build successfully. iscsitarget service should start.

4) What happened instead
iscsitarget-dkms module fail to build. iscsitarget service fail to start:

# service iscsitarget restart
* Removing iSCSI enterprise target devices: [ OK ]
* Starting iSCSI enterprise target service
modprobe: FATAL: Module iscsi_trgt not found.
                                                    [fail]

fmyoen (fmyoen) wrote :
fmyoen (fmyoen) wrote :
Robie Basak (racb) on 2016-08-12
tags: added: hwe-dkms
Robie Basak (racb) on 2016-08-12
Changed in iscsitarget (Ubuntu):
assignee: nobody → Ryan Harper (raharper)
Nish Aravamudan (nacc) on 2016-10-27
Changed in iscsitarget (Ubuntu):
assignee: Ryan Harper (raharper) → Nish Aravamudan (nacc)
Nish Aravamudan (nacc) wrote :

Thank you for reporting this bug! It seems we need to add/backport the Xenial changes for 4.3/4.4 compatibility. I'm working on that now.

Nish Aravamudan (nacc) on 2016-10-27
Changed in iscsitarget (Ubuntu):
status: New → In Progress
Nish Aravamudan (nacc) wrote :

Hello, I have provided a build of iscsitarget at: https://launchpad.net/~nacc/+archive/ubuntu/lp1612627 which I believe has the correct fixes backported. If you could give it a test and report back the results, that would be great!

Thanks,
Nish

Nish Aravamudan (nacc) on 2016-10-27
Changed in iscsitarget (Ubuntu):
status: In Progress → Invalid
Changed in iscsitarget (Ubuntu Trusty):
status: New → In Progress
assignee: nobody → Nish Aravamudan (nacc)
Changed in iscsitarget (Ubuntu):
assignee: Nish Aravamudan (nacc) → nobody
description: updated
Changed in iscsitarget (Ubuntu Trusty):
importance: Undecided → High
Saeed (msa1) wrote :

How long before the fix is available through repositories?

Nish Aravamudan (nacc) wrote :

@msa1: no one has reported back if the issue is fixed by testing my PPA, so no timeline until that is done.

Nish Aravamudan (nacc) wrote :

@msa1: I setup a VM and tested it and have uploaded the necessary fix for SRU.

Hello fmyoen, or anyone else affected,

Accepted iscsitarget into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/iscsitarget/1.4.20.3+svn499-0ubuntu2.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in iscsitarget (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed

Set up a 14.04.5 VM. Installed iscistarget-dkms from universe and got the build failure as described in this bug. Installed 1.4.20.3+svn499-0ubuntu2.2 from trusty-proposed and the modules successfully built.

tags: added: verification-done
removed: verification-needed
Changed in iscsitarget (Ubuntu Trusty):
assignee: Nish Aravamudan (nacc) → nobody
Robie Basak (racb) on 2017-03-28
summary: - iscsitarget-dkms 1.4.20.3+svn499-0ubuntu2.1 fails to build on linux-
- generic-lts-xenial kernel
+ [Trusty] iscsitarget-dkms 1.4.20.3+svn499-0ubuntu2.1 fails to build on
+ linux-generic-lts-xenial kernel
tags: added: triage
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package iscsitarget - 1.4.20.3+svn499-0ubuntu2.2

---------------
iscsitarget (1.4.20.3+svn499-0ubuntu2.2) trusty; urgency=medium

  * Backport compat changes to allow DKMS compiles for kernels up to 4.4
    (LP: #1612627).
    - d/p/fix-build-4.3.patch: Fix source to compile with 4.3+
      kernels. Thanks to Stefan Bader <email address hidden>.
    - d/p/add-4.3-compat.patch: Add compat-4.3.patch to DKMS patches.
      Thanks to Stefan Bader <email address hidden>.
    - d/p/enable-4.3-compat.patch: Enable compat-4.3 patch for DKMS
      builds. Thanks to Stefan Bader <email address hidden>.

 -- Nishanth Aravamudan <email address hidden> Mon, 20 Mar 2017 17:07:43 -0700

Changed in iscsitarget (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for iscsitarget has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers