iscsitarget-dkms fails to build on 14.04

Bug #1483415 reported by Axel on 2015-08-10
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
iscsitarget (Ubuntu)
High
Stefan Bader
Trusty
High
Stefan Bader

Bug Description

#aptitude install iscsitarget iscsitarget-dkms

[...]

------------------------------
Deleting module version: 1.4.20.3+svn499
completely from the DKMS tree.
------------------------------
Done.
Entpacken von iscsitarget-dkms (1.4.20.3+svn499-0ubuntu2) über (1.4.20.3+svn499-0ubuntu2) ...
Trigger für ureadahead (0.100.0-16) werden verarbeitet ...
Trigger für man-db (2.6.7.1-1ubuntu1) werden verarbeitet ...
iscsitarget (1.4.20.3+svn499-0ubuntu2) wird eingerichtet ...
 * iscsitarget not enabled in "/etc/default/iscsitarget", not starting...
iscsitarget-dkms (1.4.20.3+svn499-0ubuntu2) wird eingerichtet ...

Creating symlink /var/lib/dkms/iscsitarget/1.4.20.3+svn499/source ->
                 /usr/src/iscsitarget-1.4.20.3+svn499

DKMS: add completed.

Kernel preparation unnecessary for this kernel. Skipping...

Building module:
cleaning build area....
make KERNELRELEASE=3.19.0-25-generic -C /lib/modules/3.19.0-25-generic/build M=/var/lib/dkms/iscsitarget/1.4.20.3+svn499/build....(bad exit status: 2)
Error! Bad return status for module build on kernel: 3.19.0-25-generic (x86_64)
Consult /var/lib/dkms/iscsitarget/1.4.20.3+svn499/build/make.log for more information.

#cat /var/lib/dkms/iscsitarget/1.4.20.3+svn499/build/make.log

DKMS make.log for iscsitarget-1.4.20.3+svn499 for kernel 3.19.0-25-generic (x86_64)
Mo 10. Aug 23:28:38 CEST 2015
make: Verzeichnis »/usr/src/linux-headers-3.19.0-25-generic« wird betreten
  LD /var/lib/dkms/iscsitarget/1.4.20.3+svn499/build/built-in.o
  LD /var/lib/dkms/iscsitarget/1.4.20.3+svn499/build/kernel/built-in.o
  CC [M] /var/lib/dkms/iscsitarget/1.4.20.3+svn499/build/kernel/tio.o
  CC [M] /var/lib/dkms/iscsitarget/1.4.20.3+svn499/build/kernel/iscsi.o
/var/lib/dkms/iscsitarget/1.4.20.3+svn499/build/kernel/iscsi.c: In function ‘cmnd_skip_pdu’:
/var/lib/dkms/iscsitarget/1.4.20.3+svn499/build/kernel/iscsi.c:492:16: error: ‘struct msghdr’ has no member named ‘msg_iov’
  conn->read_msg.msg_iov = conn->read_iov;
                ^
/var/lib/dkms/iscsitarget/1.4.20.3+svn499/build/kernel/iscsi.c:493:16: error: ‘struct msghdr’ has no member named ‘msg_iovlen’
  conn->read_msg.msg_iovlen = ++i;
                ^
/var/lib/dkms/iscsitarget/1.4.20.3+svn499/build/kernel/iscsi.c: In function ‘cmnd_recv_pdu’:
/var/lib/dkms/iscsitarget/1.4.20.3+svn499/build/kernel/iscsi.c:721:16: error: ‘struct msghdr’ has no member named ‘msg_iov’
  conn->read_msg.msg_iov = conn->read_iov;
                ^
/var/lib/dkms/iscsitarget/1.4.20.3+svn499/build/kernel/iscsi.c:733:18: error: ‘struct msghdr’ has no member named ‘msg_iovlen’
    conn->read_msg.msg_iovlen = ++i;
                  ^
/var/lib/dkms/iscsitarget/1.4.20.3+svn499/build/kernel/iscsi.c:740:18: error: ‘struct msghdr’ has no member named ‘msg_iovlen’
    conn->read_msg.msg_iovlen = i;
                  ^
/var/lib/dkms/iscsitarget/1.4.20.3+svn499/build/kernel/iscsi.c: In function ‘nop_out_start’:
/var/lib/dkms/iscsitarget/1.4.20.3+svn499/build/kernel/iscsi.c:921:17: error: ‘struct msghdr’ has no member named ‘msg_iov’
   conn->read_msg.msg_iov = conn->read_iov;
                 ^
/var/lib/dkms/iscsitarget/1.4.20.3+svn499/build/kernel/iscsi.c:949:17: error: ‘struct msghdr’ has no member named ‘msg_iovlen’
   conn->read_msg.msg_iovlen = i;
                 ^
/var/lib/dkms/iscsitarget/1.4.20.3+svn499/build/kernel/iscsi.c: In function ‘scsi_cmnd_start’:
/var/lib/dkms/iscsitarget/1.4.20.3+svn499/build/kernel/iscsi.c:989:7: error: ‘SERVICE_ACTION_IN’ undeclared (first use in this function)
  case SERVICE_ACTION_IN:
       ^
/var/lib/dkms/iscsitarget/1.4.20.3+svn499/build/kernel/iscsi.c:989:7: note: each undeclared identifier is reported only once for each function it appears in
make[2]: *** [/var/lib/dkms/iscsitarget/1.4.20.3+svn499/build/kernel/iscsi.o] Fehler 1
make[1]: *** [/var/lib/dkms/iscsitarget/1.4.20.3+svn499/build/kernel] Fehler 2
make: *** [_module_/var/lib/dkms/iscsitarget/1.4.20.3+svn499/build] Fehler 2
make: Verzeichnis »/usr/src/linux-headers-3.19.0-25-generic« wird verlassen

#lsb_release -rd

Description: Ubuntu 14.04.3 LTS
Release: 14.04

#apt-cache policy iscsitarget-dkms

iscsitarget-dkms:
  Installiert: 1.4.20.3+svn499-0ubuntu2
  Installationskandidat: 1.4.20.3+svn499-0ubuntu2
  Versionstabelle:
 *** 1.4.20.3+svn499-0ubuntu2 0
        500 http://de.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
        100 /var/lib/dpkg/status

Axel (a-schneider-9) on 2015-08-10
description: updated
Axel (a-schneider-9) on 2015-08-10
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in iscsitarget (Ubuntu):
status: New → Confirmed
Robie Basak (racb) on 2015-08-11
tags: added: hwe-dkms
zoff99 (zoff) wrote :

is there any workaround until this is fixed?

zoff99 (zoff) wrote :

if you replace all
"struct msghdr"
with
"struct user_msghdr"
it will compile, but it won't work ...

Robie Basak (racb) wrote :

Unless you specifically need an HWE kernel (default with 14.04.3), you could downgrade to the 14.04.1 kernel and then it might work. See https://wiki.ubuntu.com/Kernel/LTSEnablementStack for an explanation of what's going on. We could do with instructions documented for this specific case, but I think we're lacking in this right now.

Stefan Bader (smb) wrote :

Could you try updating the HWE kernel. This should be fixed in 3.19.0-26* onwards.

zoff99 (zoff) wrote :

i am running:
3.19.0-25-generic #26~14.04.1-Ubuntu

are you iscsi target is working with 3.19.0-26 ? can you give the source of your information?

Stefan Bader (smb) wrote :

Right you are runnint 3.19.0-25* not 3.19.0-26*. Cannot give you a link, but internal testing has this version as working:

iscsitarget, 1.4.20.3+svn502, 3.19.0-26-generic, x86_64: installed

Steve R (sdeve) wrote :

I have the same build error on 3.19.0-28.

It's frustrating there is no workaround.

zoff99 (zoff) wrote :

now i am using this now instead:

https://github.com/bvanassche/scst/archive/master.zip

download, make, install. it works great.

why ubunutu would release without working iscsitarget support is bejond me :-(

Stefan Bader (smb) wrote :

Unfortunately there are a lot of variations with HWE kernels, so I also got hit by not noticing there is the correct testing missing for 14.04 userspace/dkms with the 3.19 kernel. Sorry about that. Only good here is that iscsitarget is universe, so it is not part of the iso. Just that a fix needs to be done for the archive. Could someone give the two debs a go before I try to get the source uploaded?

Stefan Bader (smb) wrote :
Galip Ermis (galip) wrote :

Nice workaround Stefan. At least I can go on now.

root@file01:~# dpkg -i iscsitarget-dkms_1.4.20.3+svn499-0ubuntu2.1_all.deb
(Reading database ... 101359 files and directories currently installed.)
Preparing to unpack iscsitarget-dkms_1.4.20.3+svn499-0ubuntu2.1_all.deb ...

------------------------------
Deleting module version: 1.4.20.3+svn499
completely from the DKMS tree.
------------------------------
Done.
Unpacking iscsitarget-dkms (1.4.20.3+svn499-0ubuntu2.1) over (1.4.20.3+svn499-0ubuntu2) ...
Setting up iscsitarget-dkms (1.4.20.3+svn499-0ubuntu2.1) ...

Creating symlink /var/lib/dkms/iscsitarget/1.4.20.3+svn499/source ->
                 /usr/src/iscsitarget-1.4.20.3+svn499

DKMS: add completed.

Kernel preparation unnecessary for this kernel. Skipping...

Building module:
cleaning build area....
make KERNELRELEASE=3.19.0-28-generic -C /lib/modules/3.19.0-28-generic/build M=/var/lib/dkms/iscsitarget/1.4.20.3+svn499/build........
cleaning build area....

DKMS: build completed.

iscsi_trgt:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.19.0-28-generic/updates/dkms/

depmod...............

DKMS: install completed.

Andy Whitcroft (apw) on 2015-09-16
Changed in iscsitarget (Ubuntu Trusty):
assignee: nobody → Stefan Bader (smb)
importance: Undecided → High
status: New → In Progress
Changed in iscsitarget (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → High
assignee: nobody → Andy Whitcroft (apw)
assignee: Andy Whitcroft (apw) → Stefan Bader (smb)
Chris J Arges (arges) on 2015-09-16
Changed in iscsitarget (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package iscsitarget - 1.4.20.3+svn502-2ubuntu2

---------------
iscsitarget (1.4.20.3+svn502-2ubuntu2) wily; urgency=low

  * Fix the compat-3.13.patch to not touch the top-level makefile. Will
    allow to backport this version into older (kernel 3.13 and older)
    releases (LP: #1483415).
  * Add a check for the DKMS kernel module to d/tests/daemon dep-8 test
    (LP: #1496057)

 -- Stefan Bader <email address hidden> Wed, 16 Sep 2015 13:28:21 +0200

Changed in iscsitarget (Ubuntu):
status: Fix Committed → Fix Released

Hello Axel, or anyone else affected,

Accepted iscsitarget into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/iscsitarget/1.4.20.3+svn499-0ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in iscsitarget (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Stefan Bader (smb) wrote :

I checked the ADT logs and the 1.4.20.3+svn499-0ubuntu2.1 package in trusty was successfully compiling for both 3.13 and 3.19 (plus positive feedback for the test package which was the same except the additional changes for testing).

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package iscsitarget - 1.4.20.3+svn499-0ubuntu2.1

---------------
iscsitarget (1.4.20.3+svn499-0ubuntu2.1) trusty; urgency=low

  * Backport compat changes to allow DKMS compiles for kernels up to 3.19
    (LP: #1483415).
    - d/p/fix-build-3.19: Modifies source to compile with 3.19
    - d/p/add-compat-3.19: Adds compat patches without enabling them
    - d/p/enable-compat-3.19: Enables compat patches in the DKMS config
  * Add a check for the DKMS kernel module to d/tests/daemon dep-8 test
    (LP: #1496057)

 -- Stefan Bader <email address hidden> Wed, 16 Sep 2015 13:29:48 +0200

Changed in iscsitarget (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for iscsitarget has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers