[UNMETDEPS] iscsitarget has unmet dependencies; build from source fails

Bug #145539 reported by Andrew Mitchell on 2007-09-27
30
Affects Status Importance Assigned to Milestone
iscsitarget (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: iscsitarget

Installing iscsitarget results with the following error:

=======================
iscsitarget: Depends: iscsitarget-module but it is not installable
E: Broken packages
=======================

This is due to the fact that the binary package iscsitarget-module is not available in the Ubuntu repositiries at the moment.

Building iscsitarget-source to produce an iscsitarget-module package fails as follows (originally reported by Todd Deshane
in bug #137107 ):

=======================
sudo apt-get install iscsitarget-source
sudo module-assistant
*prepare*
*select*
   --> Select iscsitarget
*build*
   --> Build will fail; review build logs.
=======================

The original buildlog from bug #137107 as provided by Todd Deshane can be seen here: http://launchpadlibrarian.net/9102605/iscsitarget-source.buildlog.2.6.22-10-generic.1188844553

Michael Bienia (geser) wrote :

Package iscsitarget version 0.4.15-2 has an unmet dep:
 Depends: iscsitarget-module

Rouben (rouben) on 2007-10-23
description: updated
Rouben (rouben) on 2007-10-23
Changed in iscsitarget:
status: New → Confirmed
Rouben (rouben) wrote :

The above behaviours have been confirmed on Ubuntu Gutsy 7.10 with all the latest updates at the time of this post.

Rouben (rouben) wrote :

According to the iscsitarget project devel mailing list, one needs to build the SVN trunk of the source in order to build this kernel module successfully: http://sourceforge.net/mailarchive/forum.php?thread_name=46F96917.4080108%40forrie.com&forum_name=iscsitarget-devel Therefore, it appears that upstream the developers of the iscsitarget project are aware of this issue and that it will be resolved in the next stable release.

description: updated
Rouben (rouben) wrote :

This seems to have been fixed in Hardy, the package has been upgraded to 0.4.15-4 from 0.4.15-2 according to this page: https://edge.launchpad.net/ubuntu/+source/iscsitarget

Chuck Short (zulcss) wrote :

Fixed for hardy.

Changed in iscsitarget:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers