[Natty] isc-dhcp update breaks network connection

Bug #724556 reported by Harry on 2011-02-24
104
This bug affects 23 people
Affects Status Importance Assigned to Milestone
isc-dhcp (Ubuntu)
Critical
Kees Cook
Natty
Critical
Kees Cook

Bug Description

The newest update (v. 4.1.1-P1-15ubuntu4) to the package isc-dhcp breaks totally networking connections.
After reboot not even network-manager applet gets loaded.
Downgrading to the previous version (v. 4.1.1-P1-15ubuntu3) solves the issue completely.
I have these packages installed:
 - isc-dhcp-client
 - isc-dhcp-common

Although I believe this is very easy to reproduce, here is some info of my setup:
Natty-alfa2 (64-bit) fully upgraded/updated.
Gigabyte GA-MA790XT-UD4P -motherboard.
Realtek 8111DL Gigabit Ethernet.

Related branches

Kees Cook (kees) wrote :

Thanks for the report! Do you see any warnings in dmesg about apparmor?

Jason Reusch (jason-reusch) wrote :

I noticed that the file /sbin/dhclient is a broken symlink. I copied the /sbin/dhclient file from an installation disk I had handy and it fixed it. At least for my LAN card, wireless still busted.

Paul White (paulw2u) on 2011-02-24
tags: added: natty
Harry (harry33) wrote :

Hi Kees,
I do not find any such warnings in dmesq.
But, then again, I do not even have apparmor package installed.

Kees Cook (kees) wrote :

Looks like the symlinks weren't updated for the new isc package and I failed to notice when I re-enabled dh_link. I've got a new package tested, uploading now. Sorry about the glitch!

Changed in isc-dhcp (Ubuntu):
importance: Undecided → Critical
assignee: nobody → Kees Cook (kees)
status: New → Fix Committed
Benoit Grégoire (benoitg) wrote :

Same symtoms as Jason. The actual dhclient binary can't be found anywhere! There is a symlink /sbin/dhclient ->dhclient3

dhclient3 is nowhere to be found (I ran updatedb to try and find). Most likely the packaging script is broken.

Kees Cook (kees) on 2011-02-24
Changed in isc-dhcp (Ubuntu Natty):
milestone: none → natty-alpha-3
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package isc-dhcp - 4.1.1-P1-15ubuntu5

---------------
isc-dhcp (4.1.1-P1-15ubuntu5) natty; urgency=low

  * debian/isc-dhcp-client.links: fix symlink ordering for new ISC package
    (LP: #724556).
 -- Kees Cook <email address hidden> Thu, 24 Feb 2011 14:16:30 -0800

Changed in isc-dhcp (Ubuntu Natty):
status: Fix Committed → Fix Released
Kees Cook (kees) wrote :

It should be available in the archive shortly. You can check build status and fetch .deb files directly from here:

https://launchpad.net/ubuntu/+source/isc-dhcp/4.1.1-P1-15ubuntu5

Harry (harry33) wrote :

Confirming, the issue is solved, bug fixed.
Thanks Kees.

Jean-Philippe Orsini (jfi) wrote :

Without network it is not possible to update to the fixed version, anyway it is possible to downgrade to the previous version:
cd /var/cache/apt
debpkg -i ./isc-dhcp-client_4.1.1-P1-15ubuntu3*deb ./isc-dhcp-common_4.1.1-P1-15ubuntu3*deb

then reboot.

Its also possible to chroot into your natty from a live disc and update from there.

Peter Belew (peterbe) wrote :

Actually, networking works, but network-manager etc aren't working, so you don't get an IP or netmask or default gateway. See bug #724594 - manually set the network up, for example:

ifconfig eth0 192.168.2.43 netmask 255.255.255.0
route add default gw 192.168.2.2

This works for an Ethernet port. You may have to set up /etc/resolv.conf.

It may work for wireless, but that's a bit more complicatd.

Peter Belew (peterbe) wrote :

The duplicate Bug #724594, which I created, seems to have been fixed, both for Ethernet and wi-fi.

Hi on my system with Marvell 88E8053 Gigabit LAN controller with this version (4.1.1-P1-15ubuntu5) sometimes happens that there is no communication between the "PC"and "modem " (Netgear DM111P) and I need to reboot to make it all work while with version 4.1.1-P1-15ubuntu3 I never had this problem. I confirm that with version 4.1.1-P1-15ubuntu4 not working

Update to isc-dchp (client and common) (4.1.ESV-R4-0Ubuntu5.6, 4.1.ESV-R4-0Ubuntu5.8) on Ubuntu 12.04 LTS also appears to break ethernet (can't get IP address and cycles trying to set up ethernet) but wifi is still working. This is a production install (hence why I am using LTS) so I don't want to mess about trying manual fixes. I will downgrade to previous version and wait for a fix.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers