Latest isc-dhcp-server rejects proper dhcpd.conf

Bug #1930917 reported by bls
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
isc-dhcp (Ubuntu)
Critical
Marc Deslauriers
Hirsute
Critical
Marc Deslauriers
Impish
Critical
Marc Deslauriers

Bug Description

Ubuntu 21.04 on Raspberry Pi. isc-dhcp-server was working just fine with version V4.4.1-2.2-ubuntu6.

I got updated to V4.4.1-2.2ubuntu6.1 and now isc-dhcp-server refuses to start with the error "Can't clone pool group".

I backed off to the prior version and it's working as before, so something in the V4.4.1-2.2ubuntu6.1 update has broken config file parsing.

Here's the subnet section of the failing config. Removing the "pool" declaration from the subnet declaration eliminates the error, but of course, that's not a working configuration.

subnet 192.168.92.0 netmask 255.255.255.0 {
    option domain-search "foo.com", "dyn.foo.com";
    option broadcast-address 192.168.92.255;
    allow duplicates;
    ddns-updates off;
    pool {
        ddns-updates on;
        allow unknown-clients;
        option domain-name "dyn.foo.com";
        ddns-rev-domainname "dhcp";
        default-lease-time 86400;
        max-lease-time 86400;
        range 192.168.92.101 192.168.92.127;
    }
}

This was also noted at least twice in the Ubuntu forums: https://ubuntuforums.org/showthread.php?t=2462984 and https://ubuntuforums.org/showthread.php?t=2462930

Thanks

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in isc-dhcp (Ubuntu):
status: New → Confirmed
Revision history for this message
Marc Deslauriers (mdeslaur) wrote :

I can confirm the update introduced a regression on Hirsute (and Impish I presume). Focal and Groovy work properly. Unfortunately, it's not related to the security patch, but it stems from the package being rebuilt with the newer toolchain in Hirsute, so removing the patch won't fix the issue.

I am currently investigating how to fix this.

Changed in isc-dhcp (Ubuntu Hirsute):
status: New → Confirmed
assignee: nobody → Marc Deslauriers (mdeslaur)
Changed in isc-dhcp (Ubuntu Impish):
assignee: nobody → Marc Deslauriers (mdeslaur)
Changed in isc-dhcp (Ubuntu Hirsute):
importance: Undecided → Critical
Changed in isc-dhcp (Ubuntu Impish):
importance: Undecided → Critical
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package isc-dhcp - 4.4.1-2.2ubuntu6.2

---------------
isc-dhcp (4.4.1-2.2ubuntu6.2) hirsute-security; urgency=medium

  * Fix regression caused by rebuild with newer toolchain (LP: #1930917)
    - debian/rules: build with -fno-strict-aliasing.

 -- Marc Deslauriers <email address hidden> Mon, 07 Jun 2021 08:08:56 -0400

Changed in isc-dhcp (Ubuntu Hirsute):
status: Confirmed → Fix Released
Revision history for this message
bls (bls3427) wrote :

Tested and confirmed that 4.4.1-2.2ubuntu6.2 corrects this. Thank you!

Revision history for this message
Marc Deslauriers (mdeslaur) wrote :

Thanks for reporting the issue!

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package isc-dhcp - 4.4.1-2.2ubuntu8

---------------
isc-dhcp (4.4.1-2.2ubuntu8) impish; urgency=medium

  * Fix regression caused by rebuild with newer toolchain (LP: #1930917)
    - debian/rules: build with -fno-strict-aliasing.

 -- Marc Deslauriers <email address hidden> Mon, 07 Jun 2021 08:25:03 -0400

Changed in isc-dhcp (Ubuntu Impish):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers