DHCP server incorrectly handling VLAN tagged packets

Bug #1167614 reported by Kevin Otte on 2013-04-10
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Debian
Fix Released
Unknown
isc-dhcp (Ubuntu)
High
Unassigned

Bug Description

Upon receipt of a VLAN tagged packet, the DHCP server is processing it as though it was received without a VLAN tag.

Steps to reproduce:
- Send a DHCPDISCOVER packet to the broadcast address with a VLAN tag

Expected results:
- None. The DHCP server should ignore this packet.

Actual results:
- The DHCP server interprets the packet as though it were received untagged and transmits a response accordingly.

Comments:
- I believe this to be an instance of Debian bug #643564

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: isc-dhcp-server 4.1.ESV-R4-0ubuntu5.6
ProcVersionSignature: Ubuntu 3.2.0-40.64-generic 3.2.40
Uname: Linux 3.2.0-40-generic x86_64
ApportVersion: 2.0.1-0ubuntu17.1
Architecture: amd64
Date: Wed Apr 10 18:42:30 2013
MarkForUpload: True
ProcEnviron:
 TERM=screen
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: isc-dhcp
UpgradeStatus: Upgraded to precise on 2012-09-01 (221 days ago)
modified.conffile..etc.dhcp.dhcpd.conf: [modified]
mtime.conffile..etc.dhcp.dhcpd.conf: 2012-12-14T11:32:45

Kevin Otte (nivex) wrote :
Changed in debian:
status: Unknown → New
Kevin Otte (nivex) wrote :

I think this may have had something to do with the way I was tagging packets. I had eth0 as a member of br0 and then a tagged interface br.120 on top of that. I switched it around so the tagged interface was directly on eth0 and it seems to be behaving itself now.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in isc-dhcp (Ubuntu):
status: New → Confirmed
Changed in isc-dhcp (Ubuntu):
importance: Undecided → High
Tony Maro (tonymaro) wrote :

In my situation I've got for example the following;

eth0 (root device)
eth0.100 (vlan 100)
eth0.1024 (vlan 1024)

To even get ISC to start, I have to assign a scope to the eth0 device. It refuses to use either VLAN interface as a valid interface. If I place a DHCP pool and an IP of 192.168.2.0/24 on the eth0 device, ISC will start. Creating pools for 192.168.3.0 and 192.168.4.0 on the VLANS is fine, however if a device on one of the VLAN's requests DHCP, you can see the request packets arrive on both eth0 and eth0.100 for instance, and it gets answered on eth0.

If you don't give an IP to eth0, ISC will completely refuse to start saying there's no adapters, despite having static IP's on the eth0.100 and eth0.1024.

You would expect the packets to arrive on the root device, but apparently ISC will only talk on the root device.

I've confirmed that setting a static IP for a device on the VLAN works perfectly - sending it's packets in on the VLAN tagged virtual interface. It's just that ISC won't look on those interfaces for where to apply a scope.

according to the changelog, this should be fixed in upstream since isc-dhcp 4.3.2b1. see
ftp://ftp.isc.org/isc/dhcp/4.3.2/dhcp-4.3.2-RELNOTES

So all we'd need is a new package with the new upstream released

Changed in debian:
status: New → Fix Released
Nick Minkler (nick-minkler) wrote :

Is there any chance of getting this fix released into Ubuntu Trusty?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.