Ubuntu

dhclient does not send hostname to dhcp-server

Reported by Thomas Schweikle on 2012-05-31
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
isc-dhcp (Ubuntu)
Undecided
Unassigned

Bug Description

Since the last update dhclient does not send the hostname any more if not explicitly set within /etc/dhcp/dhclient.conf. The line "send host-name "<hostname>";" does not work as expected.

I found:
kernel: [ 14.777460] type=1400 audit(1338471832.076:11): apparmor="STATUS" operation="profile_replace" name="/sbin/dhclient" pid=919 comm="apparmor_parser"
in /var/log/syslog. Nothing else.

After looking closely on if the config file was even read, I found it is not, because it is only searched at /usr/local/etc/dhclient.conf, /etc/dhclient.conf, but not at /etc/dhcp/dhclient.conf. Adding "-cf /etc/dhcp/dhclient.conf" to the commandline options solved the problem.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: isc-dhcp-client 4.1.ESV-R4-0ubuntu7
ProcVersionSignature: Ubuntu 3.4.0-3.8-generic 3.4.0
Uname: Linux 3.4.0-3-generic x86_64
ApportVersion: 2.1.1-0ubuntu1
Architecture: amd64
Date: Thu May 31 16:05:27 2012
InstallationMedia: Ubuntu-Server 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcEnviron:
 TERM=screen-bce
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: isc-dhcp
UpgradeStatus: No upgrade log present (probably fresh install)

Thomas Schweikle (tps) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in isc-dhcp (Ubuntu):
status: New → Confirmed
Stefan Bader (smb) wrote :

Right, seems a change to fix a FTBS rendered already set compile flags useless. And one of those is the location of the config file. Trying to cook up a fix for that.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package isc-dhcp - 4.1.ESV-R4-0ubuntu8

---------------
isc-dhcp (4.1.ESV-R4-0ubuntu8) quantal-proposed; urgency=low

  * Add "-Wno-unused-but-set-variable" instead of replacing all
    options already set. Otherwise the config file will not be
    found (LP: #1006937) for example.
 -- Stefan Bader <email address hidden> Tue, 05 Jun 2012 10:59:27 -0400

Changed in isc-dhcp (Ubuntu):
status: Confirmed → Fix Released
Jason Sharp (jsharp) wrote :

This still doesn't seem to be fixed

i'm running 12.10

root:~# apt-cache policy isc-dhcp-client
isc-dhcp-client:
  Installed: 4.2.4-1ubuntu10.1
  Candidate: 4.2.4-1ubuntu10.1
  Version table:
 *** 4.2.4-1ubuntu10.1 0
        100 /var/lib/dpkg/status

root@vut-jsharp01:~# nslookup vut-jsharp01
Server: 127.0.1.1
Address: 127.0.1.1#53

** server can't find vut-jsharp01: SERVFAIL

root@vut-jsharp01:~# nslookup 10.12.2.167
Server: 127.0.1.1
Address: 127.0.1.1#53

167.2.12.10.in-addr.arpa name = vut-jsharp01.us.drwholdings.com.

This is after I delete my DNS records...restart network-manager....run dhclient manually....or bounce my machine

still doesn't register my forward lookup

Jason Sharp (jsharp) wrote :

Quick update on my situation

If i comment out

send fqdn.fqdn = gethostname();

in dhclient.conf i successfully update DNS. I think my issues is different than this issue here. I will report this as a new bug

Cody Cryderman (codycryderman) wrote :

jsharp work around fix my issue as well

phil (fongpwf) wrote :

Jsharp, I'm not sure if you opened a bug... But I think the problem you are seeing is bug #1088682.

Stéphane Graber (stgraber) wrote :

The fix was pushed to the development release, not to 12.10, that's why you're still seeing the bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers